Try ERPNext Buy Support Partners Foundation

How to increase 'worker' timeout time?

I’ve read all the threads about increasing the number of workers.

How can increase their timeout setting?

Hi Martin,

That setting is here I think

frappe@ubuntu:~/frappe-bench$ grep gunicorn config/supervisor.conf
command=/home/frappe/frappe-bench/env/bin/gunicorn -b 127.0.0.1:8000 -w 1 -t 120 frappe.app:application --preload

This docs gunicorn timeout https://docs.gunicorn.org/en/stable/settings.html

Here trentmu notes a timeout from say a circular reference in a BOM tree Worker timeout (Stock Entry/transfer on Production Orders)