Try ERPNext Buy Support Partners Foundation

How to Get Rid of Salary Rounding in Payroll

Can someone please tell me how to get rid of rounding in Payroll? I have seen many threads about this issue but none fixed rounding in salaries. They only fix rounding issue in invoices. I would appreciate any help on this.

Have you tried “Disable Rounded Total” in Global Defaults?

I did that a long time ago and nothing has changed for Payroll. It worked for invoices but not for payroll.

hi how solveted this problem

No the problem is still there. I figured the issue is not important for those that are capable of looking at the issue and implementing a fix so I’ve moved on. I would fix the issue if I could.

ok thanks

Hi,

In salary components there is a checkbox “Round to the nearest integer”. This will round of the total.

Regards,
Reema

@Reema_Mehta i have run payroll both with the box checked and unchecked and Net Pay is still being rounded.

Hi,

Did you check if you have selected the no. of precision (decimal points) in system settings?
If yes, then disabling rounding from global defaults should work.
If no, then try doing that and check.

Regards,
Reema

@Reema_Mehta Here’s my system settings values:

and here’s my global settings:

Here’s the salary slip from this configuration:

No difference. Net Pay still being rounded.