How to disable auto exchange rates?

Is there a way to stop ERPNext from automatically fetching exchange rates if there isn’t one in the master? In the current system if the last manual rate has expired then it just uses a fresh one, but we want it to instead warn that there is not a valid exchange rate available.

Maybe this is what you are looking for?

No, this doesn’t quite do what we need. Manual exchange rates need to expire after a set period of time, and there needs to be a warning that there is no valid exchange rate if all exchange rates have expired. This is so we can ensure rates are kept consistent across all the various systems we use.

At the moment, if this flag is ticked then an exchange rate will never expire. If this is unticked, you can set an expiration date but after that date the system fetches a rate, so there will never be a warning that the rate has expired. Both scenarios are bad if someone posts a document before the new rate has been entered.

EDIT: Further, it seems to be getting today’s exchange rate regardless of the document date. This can’t be intended, I will raise an issue on GitHub for this.

can you provide the link to that github issue please? I’d like to check on the status