How to control the format of time on print?

Hi,

We have certain time fields in the print formats, the problem we are facing is that the time field is showing as HH:mm:ss.sssss for example (17:37:44.269161), see the below screen shot as well. Now the problem is that we display this field on print format we get a very long value which is not needed.

Is there a way I could only show H:mm in the print format we don't want to see the seconds or the milliseconds.



Note:

 

If you are posting an issue,

 

  1. ERPNext is a free and open source software and support is given on this forum by a team (https://frappe.io/webnotes). So please consider donating if you find this forum useful (https://frappe.io/buy). Even a small amount would be helpful.
  2. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  3. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  4. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/5496438f-4240-469c-b68d-9ec8d65e6c23%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.
Screen shot is here:



On Thursday, September 18, 2014 10:09:50 AM UTC+5:30, Aditya Duggal wrote:
Hi,

We have certain time fields in the print formats, the problem we are facing is that the time field is showing as HH:mm:ss.sssss for example (17:37:44.269161), see the below screen shot as well. Now the problem is that we display this field on print format we get a very long value which is not needed.

Is there a way I could only show H:mm in the print format we don't want to see the seconds or the milliseconds.



Note:

 

If you are posting an issue,

 

  1. ERPNext is a free and open source software and support is given on this forum by a team (https://frappe.io/webnotes). So please consider donating if you find this forum useful (https://frappe.io/buy). Even a small amount would be helpful.
  2. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  3. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  4. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/7dd96f90-6fae-4911-aae9-691b18b9c8d8%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.