How to change Guest default en language

I changed the default system language to arabic and I changed Guest user language to arabic

After that, when i open the system without login i find the language is English.

How can i change the guest user language to arabic foreaver!!!

The problem at “frappe.sessions” line 231 i removed guest checking, and i dont know why they check if user is guest, we have default language already at system settings?

#		if self.sid != "Guest":
		frappe.local.user_lang = frappe.translate.get_user_lang(self.data.user)
		frappe.local.lang = frappe.local.user_lang

@rmehta is this the correct solution?

1 Like

It should just use frappe.get_conf().get(‘lang’)

and set default lang in site_config.json

frappe.get_conf().get(‘lang’) in site_config.json
doesn’t work with me,still english.

why you didnt get the default website language from the system->setting?

Send a PR!

Are you solve this