How do I show a child doctype custom field in the Editable Grid view?

I have a custom field on ‘Sale Order Item’. In Sale Order form, I want my custom field to show up in the columns for the Items table grid. When I try to edit the grid to add my custom field as a column, my custom field is not listed as an option! How do I fix this?

As a side note, when I searched for information on this, I was first lead to this locked thread:
https://discuss.erpnext.com/t/child-table-column-arrangement-order/17891

Unfortunately, the issue talks about “Grid View” which seems to be an old term I can’t even find in v13. And it looks like maybe the suggested solution isn’t relevant anyway. I wanted to reply to the thread to ask for an updated solution, but its locked.

Some pics for clarification:
I click the Gear icon on the Items table to edit the columns. The following popup appears:

Then I click “Add/Remove Columns” and the following popup appears… but my custom column is not in the list!

I don’t Know Why your costume filed isn’t in the list.

but you can change what field should appear in the grid using Customize Form
check in_list_view for fields should be in grid

And set number of columns in columns

I already have ‘In List View’ checked.
The “Columns” input field shown in amadhaji’s screenshot doesn’t even show up as an option on my installation of Frappe which is on version v13.17.1.

Hello,
I have ERPNext: v13.22.1 (version-13)
Frappe Framework: v13.22.1 (version-13)
and it works on my instance.
I can change grid view as amadhaji showed and my custom column is in the list for “Add/Remove Columns”. When you click “Add/Remove Columns” try to scroll your mouse down maybe you custom field isn’t visible.

RESOLVED:

I was making a really dumb mistake. I had added my custom field to “Item”, but I forgot I also needed to add it to “Sales Order Item”. Every time I checked my work, I was going back to look at “Item” again.

Thanks for assistance everyone! It was helpful to have feedback about how it should be working!

1 Like