How do i completely delete ERPNext from my system

I want to relearn how to setup erpnext again so i will be completely deleting erpnext. whats the best way to do this aside from reformatting my drive.

also is there a way to install a specific version of erpnext?
is it better to manually install erpnext or automatically install it using the script found on frappe

The ERPNext is installed to one subdir - you can simply delete the subdir and that’s all there is to it.
The default is /home/FRAPPE_USER/frappe-bench/*, but sometimes it can be under /opt/bench/erpnext

After deleting that folder don’t forget to drop the database too… login to mariadb using sudo mysql -u root -p and delete the db using drop dabatbase ‘dbname’;

1 Like

@trentmu @M27
is it better if i install erpnext manually or with the easy install script found over here https://github.com/frappe/bench

as it says easy script is very easy to install… it will automatically install erpnext along with mariadb etc

after installing dependencies use the script to install the production or develop version as you need…

sudo python install.py --develop --user frappe (for develop version i.e version 12.x)
sudo python install.py --production --user frappe (for production version i.e version 11.x)

if you are installing manually you can learn many things as you have to install all dependencies, db etc by yourself…

I personally prefer to use manual install, since it allows you to see any errors as they happen, and you can learn what goes where at the same time.

is there any way to get only a specific version of erpnext?

From here… (adjust the 8.x.x to suit your needs)

cd /home/frappe/frappe-bench
bench switch-to-branch v8.x.x
bench update
.env/bin/pip install --upgrade pip==9.0.3
.env/bin/pip -q -e ./apps/frappe
.env/bin/pip -q -e ./apps/erpnext
bench migrate

Yes and No. You can use the the method @trentmu suggested, but be prepared for some difficulties the further back you go in versions. The bench underwent some major changes in the past year that may not be workable in older versions.

Also some program dependencies may break the further back you go as well.

BKM