How can i fix this issue

Installing frappe
$ /home/frappe/frappe-bench/env/bin/python -m pip install --quiet --upgrade -e /home/frappe/frappe-bench/apps/frappe
$ yarn install
yarn install v1.22.17
warning …/…/package.json: No license field
[1/4] Resolving packages…
[2/4] Fetching packages…
error redis@3.1.1: The engine “node” is incompatible with this module. Expected version “>=10”. Got “8.17.0”
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
ERROR:
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 8, in
sys.exit(cli())
File “/usr/local/lib/python3.6/site-packages/bench/cli.py”, line 117, in cli
raise e
File “/usr/local/lib/python3.6/site-packages/bench/cli.py”, line 107, in cli
bench_command()
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 1128, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 1053, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 1659, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 1395, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 754, in invoke
return __callback(*args, **kwargs)
File “/usr/local/lib/python3.6/site-packages/bench/commands/update.py”, line 23, in update
update(pull=pull, apps=apps, patch=patch, build=build, requirements=requirements, restart_supervisor=restart_supervisor, restart_systemd=restart_systemd, backup=not no_backup, compile=not no_compile, force=force, reset=reset)
File “/usr/local/lib/python3.6/site-packages/bench/utils/bench.py”, line 397, in update
bench.setup.requirements()
File “/usr/local/lib/python3.6/site-packages/bench/utils/render.py”, line 95, in wrapper_fn
return fn(*args, **kwargs)
File “/usr/local/lib/python3.6/site-packages/bench/bench.py”, line 337, in requirements
App(app, bench=self.bench, to_clone=False).install()
File “/usr/local/lib/python3.6/site-packages/bench/utils/render.py”, line 110, in wrapper_fn
return fn(*args, **kwargs)
File “/usr/local/lib/python3.6/site-packages/bench/app.py”, line 189, in install
app=app_name, bench_path=self.bench.name, verbose=verbose, skip_assets=skip_assets,
File “/usr/local/lib/python3.6/site-packages/bench/app.py”, line 414, in install_app
bench.run(“yarn install”, cwd=app_path)
File “/usr/local/lib/python3.6/site-packages/bench/bench.py”, line 43, in run
return exec_cmd(cmd, cwd=cwd or self.cwd)
File “/usr/local/lib/python3.6/site-packages/bench/utils/init.py”, line 126, in exec_cmd
raise CommandFailedError
bench.exceptions.CommandFailedError

The engine “node” is incompatible with this module. Expected version “>=10”. Got “8.17.0”

What does: node -v return? It may be necessary to upgrade your node to a more recent version.

https://www.tecmint.com/install-nodejs-npm-in-centos-ubuntu/