How can I access the installed erpnext on ubuntu?

Hello,

This is my ubuntu server http://82.196.0.190/ which I setup on digitalocean. Actually in the root I have setup the wordpress, and through the SSH, I have installed erpNext. So I am confused now that how I can open the erpnext in browser, because the url above is only pointing to the wordpress. Also I tried by adding 8080 at the end, even it is not working.

Let me provide you path where it has been installed :
WordPress installed at /var/www/html
ErpNext may be installed at /home/frappe

So do you have idea how I can open it?

Thanks.

How did you install your erpnext? Like this: https://github.com/frappe/bench#easy-way ?
If yes what is the output of supervisorctl status ?

Hello,

Thanks for getting back to me. Yes, I have used that easiest way to install erpnext.

Please check the status below.
root@corewaysolution:/# supervisorctl
frappe:frappe-web RUNNING pid 21383, uptime 0:30:15
frappe:frappe-worker RUNNING pid 21382, uptime 0:30:15
frappe:frappe-workerbeat RUNNING pid 21384, uptime 0:30:15
frappe-async-worker RUNNING pid 21377, uptime 0:30:15
frappe-longjob-worker RUNNING pid 21380, uptime 0:30:15
node-socketio RUNNING pid 21381, uptime 0:30:15
redis-async-broker RUNNING pid 21375, uptime 0:30:15
redis-cache RUNNING pid 21376, uptime 0:30:15

Thanks.

So normally your erpnext installation is running “locally” (on 127.0.0.1:8000). You can check it by running the command: wget http://127.0.0.1:8000

You can now make it accessible for the external world using a reverse proxy like nginx for example (described here: https://github.com/frappe/bench#nginx)

1 Like

Hello,

Thanks for be again quick to answer.

Please check the result of wget command :
root@corewaysolution:/# wget http://127.0.0.1:8000
–2016-03-09 08:06:47-- http://127.0.0.1:8000/
Connecting to 127.0.0.1:8000… connected.
HTTP request sent, awaiting response… 404 NOT FOUND
2016-03-09 08:06:47 ERROR 404: NOT FOUND.

Also what do I have to do with nginx?

Thanks.

Hey one more thing, I use this URL by checking my nginx configuration file,
http://82.196.0.190:3000/
it is giving me error like
Error: ENOENT, stat ‘/home/frappe/frappe-bench/sites/index.html’

Hope this could help you.

seems there are many approaches to this matter … here is mine:

I think there is a bench command that can change the port of nginx. This actually results into an entry in the site_config.json of your site. I’ll try to find the topic and post details in a bit

… [this is the topic I meant][1]

bench set-nginx-port [sitename] [new-port-number]

generally: I wasn’t sure whether it’s the best practice to run wordpress and ERPNext on the same physical or virtual server. Probably a dockerized ERPNext solution would be a good thing for such. Unfortunately that doesn’t exist yet.
[1]: How to stop bench

As @vrms mentioned.

You can get ERPNext running on another port.

There are some instructions here https://github.com/frappe/bench/wiki/Multitenant-Setup#port-based-multitenancy

Hope it helps @Varun_Patel

@vrms I tried your way but still it is not working. After setting up the 82 port I tried to open the erpNext using this url : http://82.196.0.190:82

Let me know if I am doing anything wrong here.

If you don’t want to setup a reverse proxy, you could change the listening IP of your gunicorn process in supervisord.conf file.
supervisord.conf should contain something like “command= ... /env/bin/gunicorn -b 127.0.0.1:8000 -w 2 -t ...”
You could change 127.0.0.1 to your public IP (82.196.0.190). And then restart your gunicorn process:

supervisorctl restart frappe:frappe-web

Note: this is not suitable for a production setup. Only for debug and test. :wink: