ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Hide Salary Component from payslip

customization

#1

I want to include in calculations (salary component), hide on payslip.Please advise if I should be including a hide button on salary component doctype.


#2

Hello @Saditi ,

If you want to hide this in the print, then create a custom print format for salary slip.

After creating the print format click on Edit format option.

It will show you the related fields in the salary slip document.

Then click on the select columns either under earning table or deductions.

Here you can hide any field by unchecking it and then click on update.

Then make this print format as default.

Hope this helps.

Regards,
Sujay


#3

Thanks for replying @Sujay,
Actually I want a checkbox in Salary component doctype, so when I click on the box, that particular component will get hidden from salary slip…
Looking forward for your reply.


#4

You can enable “Statistical Component” for those which you are using for calculations. Also note that you should use this in combination with “Do not include in total” flag which will omit the value from the earning / deduction total.

Hope this helps, thanks


#5

Thank for replying @akurungadam ,

Using “Do Not Include in Total” is half solution to my problem as I cannot use “Statistical Component” because it does not show components while making salary slip also…

I just want to hide component from salary slip now.


#6

can you explain

you want to hide component right then it should be hidden


#10

The “do not include in total” check is in salary_slip file on line 721, I am unable to solve your problem.


#11

Hi,

If you use “Do not include in total”, it will not hide the salary component, only that particular component will not be added in the gross total.

@Saditi - This is not a standard feature in ERPNext, although if you have resources then you can contribute.

Hope this helps.

Regards,
Reema


#12

Hi @Reema_Mehta,
Yes “Do not include in total” will not hide fields from print hide, but I get the solution to hide fields using this checkbox…