Has Batch No and Has Serial No not found in Item Master

Hello,

In my Item Master page, I do not see Has Batch No and Has Serial No check boxes under Inventory section. What are the settings I need to make them appear?

http://tinypic.com/r/5po10x/8

Thank you!

Check “Is Stock Item”

edit: seems like you have customizations in your form. try resetting your customizations via Customize Form and see if it works.

Thanks for your reply. I’ve ensure “Is Stock Item” (Maintain Stock) is checked. I also reset to defaults of in the Customize Form. But still don’t see those 2 fields appear. I attached image of the customize form here.


Is there any settings I missed out?

For some reason, your Item form may not have upated.

Can you run bench migrate again and test?

Executed “bench migrate”. Still same issue.

What is the next thing I need to check on?

Check your JS error log if any custom scripts broke.

Check “depends on” property in your item form. Do you have local commits?

Thanks for the reply.

No JS error found in the browser log. In fact, no custom scripts added.

I found that the field is rendered but it appears hidden.

Properties of “Has Batch No”, seems normal

Any clue?

This is very strange.

Did you set higher permissions levels.

Open your Item form, then run this in your console to get an idea what might be hiding it

cur_frm.get_field("has_batch_no").get_status(true);

I’ve executed that line above in the console and it gives me this:

But I couldn’t understand the result what make them hidden. Please give me some shades of lights. Worst case I will need to reset the site.

You have the “hidden” property set for has_batch_no

Did you directly update the doctype? Check again in Customize Form View