ERPNext Foundation ERPNext Cloud Chat Blog Discuss Frappé* Donate

Guide: Manual Install ERPNext on Ubuntu 17.xx & 18.xx




I also had the problem of accessing the database with a permissions error.

at the command line,
mysql -u root -p
would not login but
sudo mysql -u root -p
would so to fix it

If you could login with sudo but not without sudo then do:

$ sudo mysql -u root -p

[mysql] use mysql;
[mysql] update user set plugin=’’ where User=‘root’;
[mysql] flush privileges;
[mysql] \q

Once done, open a new shell, and then:

$ mysql -u root -p without sudo will work just fine.



I am not able to go further from here. Please advice on next step…

sudo bench new-site site1.local
MySQL root password:
Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/etc/opt/bench/erpnext/apps/frappe/frappe/utils/”, line 97, in
File “/etc/opt/bench/erpnext/apps/frappe/frappe/utils/”, line 18, in main
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/etc/opt/bench/erpnext/apps/frappe/frappe/commands/”, line 34, in new_site
verbose=verbose, install_apps=install_app, source_sql=source_sql, force=force)
File “/etc/opt/bench/erpnext/apps/frappe/frappe/commands/”, line 65, in _new_site
admin_password=admin_password, verbose=verbose, source_sql=source_sql,force=force, reinstall=reinstall)
File “/etc/opt/bench/erpnext/apps/frappe/frappe/”, line 38, in install_db
create_database_and_user(force, verbose)
File “/etc/opt/bench/erpnext/apps/frappe/frappe/”, line 62, in create_database_and_user
if force or (db_name not in dbman.get_database_list()):
File “/etc/opt/bench/erpnext/apps/frappe/frappe/model/”, line 554, in get_database_list
return [d[0] for d in self.db.sql(“SHOW DATABASES”)]
File “/etc/opt/bench/erpnext/apps/frappe/frappe/”, line 166, in sql
File “/etc/opt/bench/erpnext/apps/frappe/frappe/”, line 116, in connect
charset=‘utf8mb4’, use_unicode = True, conv = conversions, local_infile = self.local_infile)
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/pymysql/”, line 94, in Connect
return Connection(*args, **kwargs)
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/pymysql/”, line 327, in init
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/pymysql/”, line 598, in connect
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/pymysql/”, line 852, in _request_authentication
auth_packet = self._read_packet()
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/pymysql/”, line 683, in _read_packet
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/pymysql/”, line 220, in check_error
File “/etc/opt/bench/erpnext/env/local/lib/python2.7/site-packages/pymysql/”, line 109, in raise_mysql_exception
raise errorclass(errno, errval)
pymysql.err.InternalError: (1698, u"Access denied for user ‘root’@‘localhost’")


Check login in MySQL from command follow the steps from
above for mysql commands


kinda not clear , is “ " i can name it up to me , by replace “example” by what i want
and Isn’t it related to Frappe site we created " site1.local” ?


just note

I tried to install frappe with this lines but it makes MariaDB servers failed and down ,
when i just put these lines:

character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci 

It worked fine and the servers kept active


Welcome to ERPNext Ahmed_K_A_Awwad

Please start a new thread that describes what it is you wish to do, and gives what steps you are following that arecausing your problems.



and okay Mr Clarkej


its for the example if you have created the site for domain access
bench new-site then you have to install the app on the site


okay , i got it