Gsuite Integration error

Hello All,

I am trying to integrate Google GSuite with the help of this link https://frappe.io/docs/user/en/guides/integration/google_gsuite in my local setup, but i am not able to achieve this.

Can anyone please clear my doubts ? i am using virtual box production image.

erpnext : 10.0.23
frappe : 10.0.25

  1. is it possible to integrate Gsuite in local setup for initial testing purpose or it can be only able to integrate with production (Domain based site). for eg : abc.erpnext.com

i have followed each step of document, but it will raised an error after authenticate user on user selection page. error shown in attached image.

You have to share the specific error you got while setting up. Otherwise, it will be difficult to suggest any solution.

@netchampfaris Thanks for your kind words.

I have followed each steps as mentioned in Doc. after clicking on Allow GSuite Access button, the page is redirected to Choose User and allow access to this user page. And after selection of user it will show page URL http://localhost/?cmd=frappe.integrations.doctype.gsuite_settings.gsuite_settings.gsuite_callback&code=4/AACNelGhJiwY2YhwbjDirRho4iqJXuKGZcTH70D11Sbo7WhQURqKfMjr2nxGaGP9Qp7L5jD4x1x8mkD9EzDP6Mg#

And shows below error page

What is the wrong in this ?

Kind Regards,
Hardik Gadesha

Maybe your bench has stopped? Is desk loading fine?

@netchampfaris Yes i am able to load Desk page.

My question is that, is it possible to setup GSuite in localhost or it can be only work with domain based Multi-tenancy like if my site name is abc.domain.com ?

Can anyone help me with this ?

If you are using NAT, instead use bridge mode?

NAT limits connections to ‘localhost’ within the host environment whereas bridge supports a ‘transparent’ network connection.

I use qemu-kvm but VB has the same two network connection choices.

edit: This thread notes bridge setup on VB Accessing ERP Next On Network

Well done lots of us here would appreciate your progress reports!

Thanks @clarkej.

Now i am swithed to prodcution setup in my aws server and doing the same, but not using vm for this.

So now i am facing error explain in Error in Template : Gsuite Integration. Can you please guide me on this ?

Regards,
Hardik Gadesha

Assuming the current docs are insufficient to land you a working GSuite instance, another option is to post to erpnext.org jobs - that you seek a contractor to instruct and implement Gsuite for your workplace or client.

Best wishes with your project!

Thanks @clarkej.

But i want to solve this my self. And could not able to find cause of this error :disappointed:

@clarkej i am getting error on save buttom click. what should i do for that ?

So then you are determined -

“i am getting error on save buttom click”

What save button where - a screenshot would best establish your context

What else would help, for folks to follow along who may want to pitch in…

  • copy paste your complete traceback
    then it’s easy to browse code to investigate under the hood

  • identify what steps you have followed that worked and precisely what step blows up

  • refer to whatever docs and other recent posts as your info sources

  • actual versus expected results, observations - the experimental method here

You are a trail blazer who will learn from your initiative.

Just two py files and a few methods to study

https://github.com/frappe/frappe/tree/develop/frappe/integrations/doctype/gsuite_settings

https://github.com/frappe/frappe/tree/develop/frappe/integrations/doctype/gsuite_templates

What might help too for insight is to leverage the API docs, tools and support on the G Suite side https://developers.google.com/apis-explorer/#p/

@clarkej i have update my frappe aand erpnext app yesterday and then it does not give that error ==> Error in Template : Gsuite Integration.

I have follwed each steps from https://frappe.io/docs/user/en/guides/integration/google_gsuite and stuck with error. Here is the screen shot of the error message.

ok I did Step 1.1 and Step 1.2 as instructed.

But then for Step 1.3 two snags:

part 1 worked with http:// but I would prefer to use https://

part 2 no sign of the Run Test Script, likely because the project defined in Step 1.1 I could not find in Step 1.2, so I simply defined a new project!

You may have better success - this reference may help picture how Oath2 works https://www.digitalocean.com/community/tutorials/an-introduction-to-oauth-2