Git pull error while running bench update


i faced error on bench update command in my local setup. Please find attached snap for error message.

I also tried to change permission of .bench and frappe-bench directory, but it gives error as shown. What is the cause behind this. i run bench update command in my production server successfully.

Any help will be appreciate.

Thanks in Advance,
Hardik Gadesha

Hi, try to check permissions in the
or frappe-benchng/apps/frappe/.git
or frappe-benchng/apps/erpnext/.git/

Thanks for response @SwitsolAG

It still gives an error.

You have changes and you should decide what you want to do with them if you haven’t made any changes run git reset --hard but be sure that it wasn’t your changes

Yes, it’s not my changes.where to hit this command ?

Hardik Gadesha

Try in frappe-bench/apps/frappe

yes, i did this and now it’s give new error.

hmmm, sorry but I don’t have ideas how to help you

Okay @SwitsolAG. May be found the cause. it’s Mysql database permission error.

Thanks for such a helpful suggestions. :slight_smile: