ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Getting this error while bench start


#1

cd erpnext/
vijeta@vijeta-PowerEdge-T30:~/erpnext$ bench start
11:00:07 system | worker_long.1 started (pid=21037)
11:00:07 system | redis_socketio.1 started (pid=21039)
11:00:07 redis_socketio.1 | 21042:M 17 May 11:00:07.332 * Increased maximum number of open files to 10032 (it was originally set to 1024).
11:00:07 redis_socketio.1 | .
11:00:07 redis_socketio.1 | .-__ ''-._ 11:00:07 redis_socketio.1 | _.- .. ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
11:00:07 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 11:00:07 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 11:00:07 redis_socketio.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 12000 11:00:07 redis_socketio.1 | |-. ._ / _.-' | PID: 21042 11:00:07 redis_socketio.1 |-._ -._-./ .-’ .-’
11:00:07 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 11:00:07 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 11:00:07 redis_socketio.1 |-._ -._-..-’.-’ .-’
11:00:07 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 11:00:07 redis_socketio.1 | |-.
-._ _.-'_.-' | 11:00:07 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
11:00:07 redis_socketio.1 | -._-..-’ _.-’
11:00:07 redis_socketio.1 | -._ _.-' 11:00:07 redis_socketio.1 |-.
.-’
11:00:07 redis_socketio.1 |
11:00:07 redis_socketio.1 | 21042:M 17 May 11:00:07.333 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
11:00:07 redis_socketio.1 | 21042:M 17 May 11:00:07.333 # Server started, Redis version 3.0.6
11:00:07 redis_socketio.1 | 21042:M 17 May 11:00:07.333 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
11:00:07 redis_socketio.1 | 21042:M 17 May 11:00:07.333 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
11:00:07 redis_socketio.1 | 21042:M 17 May 11:00:07.333 * The server is now ready to accept connections on port 12000
11:00:07 system | web.1 started (pid=21040)
11:00:07 system | schedule.1 started (pid=21047)
11:00:07 system | worker_short.1 started (pid=21048)
11:00:07 system | redis_queue.1 started (pid=21036)
11:00:07 redis_queue.1 | 21063:M 17 May 11:00:07.355 * Increased maximum number of open files to 10032 (it was originally set to 1024).
11:00:07 redis_queue.1 | .
11:00:07 redis_queue.1 | .-__ ''-._ 11:00:07 redis_queue.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
11:00:07 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 11:00:07 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 11:00:07 redis_queue.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 11000 11:00:07 redis_queue.1 | |-._ ._ / _.-' | PID: 21063 11:00:07 redis_queue.1 |-._ -._-./ .-’ .-’
11:00:07 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 11:00:07 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 11:00:07 redis_queue.1 |-._ -._-..-’.-’ .-’
11:00:07 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 11:00:07 redis_queue.1 | |-.
-._ _.-'_.-' | 11:00:07 redis_queue.1 |-._ -._-.
.-’.-’ .-’
11:00:07 redis_queue.1 | -._-..-’ _.-’
11:00:07 redis_queue.1 | -._ _.-' 11:00:07 redis_queue.1 |-.
.-’
11:00:07 redis_queue.1 |
11:00:07 redis_queue.1 | 21063:M 17 May 11:00:07.355 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
11:00:07 redis_queue.1 | 21063:M 17 May 11:00:07.355 # Server started, Redis version 3.0.6
11:00:07 redis_queue.1 | 21063:M 17 May 11:00:07.355 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
11:00:07 redis_queue.1 | 21063:M 17 May 11:00:07.355 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
11:00:07 redis_queue.1 | 21063:M 17 May 11:00:07.355 * The server is now ready to accept connections on port 11000
11:00:07 system | watch.1 started (pid=21041)
11:00:07 system | socketio.1 started (pid=21053)
11:00:07 system | worker_default.1 started (pid=21067)
11:00:07 system | redis_cache.1 started (pid=21068)
11:00:07 redis_cache.1 | 21074:M 17 May 11:00:07.376 * Increased maximum number of open files to 10032 (it was originally set to 1024).
11:00:07 redis_cache.1 | .
11:00:07 redis_cache.1 | .-__ ''-._ 11:00:07 redis_cache.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
11:00:07 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 11:00:07 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 11:00:07 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 11:00:07 redis_cache.1 | |-._ ._ / _.-' | PID: 21074 11:00:07 redis_cache.1 |-._ -._-./ .-’ .-’
11:00:07 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 11:00:07 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 11:00:07 redis_cache.1 |-._ -._-..-’.-’ .-’
11:00:07 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 11:00:07 redis_cache.1 | |-.
-._ _.-'_.-' | 11:00:07 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
11:00:07 redis_cache.1 | -._-..-’ _.-’
11:00:07 redis_cache.1 | -._ _.-' 11:00:07 redis_cache.1 |-.
.-’
11:00:07 redis_cache.1 |
11:00:07 redis_cache.1 | 21074:M 17 May 11:00:07.376 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
11:00:07 redis_cache.1 | 21074:M 17 May 11:00:07.376 # Server started, Redis version 3.0.6
11:00:07 redis_cache.1 | 21074:M 17 May 11:00:07.376 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
11:00:07 redis_cache.1 | 21074:M 17 May 11:00:07.376 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
11:00:07 redis_cache.1 | 21074:M 17 May 11:00:07.376 * The server is now ready to accept connections on port 13000
11:00:07 socketio.1 | /home/vijeta/erpnext/apps/frappe/socketio.js:176
11:00:07 socketio.1 | socket.files[data.name].data.push(data.data
11:00:07 socketio.1 | ^^^^
11:00:07 socketio.1 |
11:00:07 socketio.1 | SyntaxError: missing ) after argument list
11:00:07 socketio.1 | at createScript (vm.js:80:10)
11:00:07 socketio.1 | at Object.runInThisContext (vm.js:139:10)
11:00:07 socketio.1 | at Module._compile (module.js:617:28)
11:00:07 socketio.1 | at Object.Module._extensions…js (module.js:664:10)
11:00:07 socketio.1 | at Module.load (module.js:566:32)
11:00:07 socketio.1 | at tryModuleLoad (module.js:506:12)
11:00:07 socketio.1 | at Function.Module._load (module.js:498:3)
11:00:07 socketio.1 | at Function.Module.runMain (module.js:694:10)
11:00:07 socketio.1 | at startup (bootstrap_node.js:204:16)
11:00:07 socketio.1 | at bootstrap_node.js:625:3
11:00:07 system | socketio.1 stopped (rc=1)
11:00:07 system | sending SIGTERM to redis_socketio.1 (pid 21039)
11:00:07 system | sending SIGTERM to worker_long.1 (pid 21037)
11:00:07 system | sending SIGTERM to watch.1 (pid 21041)
11:00:07 system | sending SIGTERM to redis_queue.1 (pid 21036)
11:00:07 system | sending SIGTERM to web.1 (pid 21040)
11:00:07 system | sending SIGTERM to schedule.1 (pid 21047)
11:00:07 system | sending SIGTERM to worker_default.1 (pid 21067)
11:00:07 system | sending SIGTERM to redis_cache.1 (pid 21068)
11:00:07 system | sending SIGTERM to worker_short.1 (pid 21048)
11:00:07 redis_queue.1 | 21063:signal-handler (1558071007) Received SIGTERM scheduling shutdown…
11:00:07 system | worker_default.1 stopped (rc=-15)
11:00:07 system | watch.1 stopped (rc=-15)
11:00:07 redis_socketio.1 | 21042:signal-handler (1558071007) Received SIGTERM scheduling shutdown…
11:00:07 redis_cache.1 | 21074:signal-handler (1558071007) Received SIGTERM scheduling shutdown…
11:00:07 system | worker_short.1 stopped (rc=-15)
11:00:07 system | schedule.1 stopped (rc=-15)
11:00:07 system | worker_long.1 stopped (rc=-15)
11:00:07 system | web.1 stopped (rc=-15)
11:00:07 redis_socketio.1 | 21042:M 17 May 11:00:07.535 # User requested shutdown…
11:00:07 redis_socketio.1 | 21042:M 17 May 11:00:07.535 # Redis is now ready to exit, bye bye…
11:00:07 system | redis_socketio.1 stopped (rc=-15)
11:00:07 redis_queue.1 | 21063:M 17 May 11:00:07.558 # User requested shutdown…
11:00:07 redis_queue.1 | 21063:M 17 May 11:00:07.558 # Redis is now ready to exit, bye bye…
11:00:07 system | redis_queue.1 stopped (rc=-15)
11:00:07 redis_cache.1 | 21074:M 17 May 11:00:07.581 # User requested shutdown…
11:00:07 redis_cache.1 | 21074:M 17 May 11:00:07.581 # Redis is now ready to exit, bye bye…
11:00:07 system | redis_cache.1 stopped (rc=-15)
vijeta@vijeta-PowerEdge-T30:~/erpnext$


#2

Possibly you have a malformed custom client side script?


#3

This is often suggested… (though I personally am not a fan as it can cause high memory usage)

echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p
cd ~/frappe-bench
bench restart

#4

@clarkej
@trentmu thanks for the reply