ERPNext Conference 2019* ERPNext.com Blog

Getting npm error while bench init


#1

npm ERR! A complete log of this run can be found in:
npm ERR! /home/robin/.npm/_logs/2019-04-30T19_08_46_788Z-debug.log
Traceback (most recent call last):
File “/home/robin/.local/bin/bench”, line 11, in
sys.exit(cli())
File “/home/robin/.local/lib/python2.7/site-packages/bench/cli.py”, line 40, in cli
bench_command()
File “/home/robin/.local/lib/python2.7/site-packages/click/core.py”, line 764, in call
return self.main(*args, **kwargs)
File “/home/robin/.local/lib/python2.7/site-packages/click/core.py”, line 717, in main
rv = self.invoke(ctx)
File “/home/robin/.local/lib/python2.7/site-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/robin/.local/lib/python2.7/site-packages/click/core.py”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/robin/.local/lib/python2.7/site-packages/click/core.py”, line 555, in invoke
return callback(*args, **kwargs)
File “/home/robin/.local/lib/python2.7/site-packages/bench/commands/make.py”, line 21, in init
verbose=verbose, clone_from=clone_from, skip_bench_mkdir=skip_bench_mkdir, skip_redis_config_generation=skip_redis_config_generation)
File “/home/robin/.local/lib/python2.7/site-packages/bench/utils.py”, line 72, in init
update_npm_packages(bench_path=path)
File “/home/robin/.local/lib/python2.7/site-packages/bench/utils.py”, line 442, in update_npm_packages
exec_cmd(‘npm install’, cwd=bench_path)
File “/home/robin/.local/lib/python2.7/site-packages/bench/utils.py”, line 140, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: npm install


#2

robin@CosmicSpirit:~/Documents$ bench init frappe-bench && cd frappe-bench
INFO:bench.utils:virtualenv -q env -p /usr/bin/python
Already using interpreter /usr/bin/python
INFO:bench.utils:./env/bin/pip -q install --upgrade pip
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
INFO:bench.utils:./env/bin/pip -q install wheel
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
INFO:bench.utils:./env/bin/pip -q install six
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
INFO:bench.utils:./env/bin/pip -q install -e git+https://github.com/frappe/python-pdfkit.git#egg=pdfkit
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
INFO:bench.app:getting app frappe
INFO:bench.utils:git clone https://github.com/frappe/frappe.git --origin upstream
Cloning into ‘frappe’…
remote: Enumerating objects: 27, done.
remote: Counting objects: 100% (27/27), done.
remote: Compressing objects: 100% (21/21), done.
remote: Total 175540 (delta 7), reused 9 (delta 6), pack-reused 175513
Receiving objects: 100% (175540/175540), 196.42 MiB | 435.00 KiB/s, done.
Resolving deltas: 100% (134220/134220), done.
(‘installing’, u’frappe’)
INFO:bench.app:installing frappe
INFO:bench.utils:frappe-bench/env/bin/pip install -q -e frappe-bench/apps/frappe --no-cache-dir
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
ERROR: requests 2.21.0 has requirement urllib3<1.25,>=1.21.1, but you’ll have urllib3 1.25.2 which is incompatible.
ERROR: botocore 1.12.138 has requirement urllib3<1.25,>=1.20; python_version == “2.7”, but you’ll have urllib3 1.25.2 which is incompatible.
Updating node libraries…
INFO:bench.utils:npm install
npm ERR! prepareGitDep 1>
npm ERR! prepareGitDep > uws@9.14.0 install /home/robin/.npm/_cacache/tmp/git-clone-e9a50443/node_modules/uws
npm ERR! prepareGitDep > node-gyp rebuild > build_log.txt 2>&1 || exit 0
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > wd@1.11.2 install /home/robin/.npm/_cacache/tmp/git-clone-e9a50443/node_modules/wd
npm ERR! prepareGitDep > node scripts/build-browser-scripts
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > sauce-connect-launcher@1.2.6 postinstall /home/robin/.npm/_cacache/tmp/git-clone-e9a50443/node_modules/sauce-connect-launcher
npm ERR! prepareGitDep > node scripts/install.js || nodejs scripts/install.js
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > parchment@2.0.0-dev prepare /home/robin/.npm/_cacache/tmp/git-clone-e9a50443
npm ERR! prepareGitDep > npm run build
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > parchment@2.0.0-dev build /home/robin/.npm/_cacache/tmp/git-clone-e9a50443
npm ERR! prepareGitDep > webpack --config webpack.conf.js
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep 2> npm WARN install Usage of the --dev option is deprecated. Use --only=dev instead.
npm ERR! prepareGitDep npm WARN deprecated istanbul@0.4.5: This module is no longer maintained, try this instead:
npm ERR! prepareGitDep npm WARN deprecated npm i nyc
npm ERR! prepareGitDep npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives.
npm ERR! prepareGitDep npm WARN deprecated circular-json@0.5.9: CircularJSON is in maintenance only, flatted is its successor.
npm ERR! prepareGitDep npm WARN deprecated nodemailer@2.7.2: All versions below 4.0.1 of Nodemailer are deprecated. See https://nodemailer.com/status/
npm ERR! prepareGitDep npm WARN deprecated babel-preset-es2015@6.24.1: :raised_hands: Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update!
npm ERR! prepareGitDep npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
npm ERR! prepareGitDep npm WARN deprecated uws@9.14.0: New code is available at github.com/uNetworking/uWebSockets.js
npm ERR! prepareGitDep npm WARN deprecated mailcomposer@4.0.1: This project is unmaintained
npm ERR! prepareGitDep npm WARN deprecated socks@1.1.9: If using 2.x branch, please upgrade to at least 2.1.6 to avoid a serious bug with socket data flow and an import issue introduced in 2.1.0
npm ERR! prepareGitDep npm WARN deprecated hawk@3.1.3: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm ERR! prepareGitDep npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm ERR! prepareGitDep npm WARN deprecated buildmail@4.0.1: This project is unmaintained
npm ERR! prepareGitDep npm WARN deprecated hoek@2.16.3: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm ERR! prepareGitDep npm WARN deprecated sntp@1.0.9: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
npm ERR! prepareGitDep npm WARN deprecated cryptiles@2.0.5: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm ERR! prepareGitDep npm WARN deprecated boom@2.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm ERR! prepareGitDep /home/robin/.npm/_cacache/tmp/git-clone-e9a50443/node_modules/webpack-cli/bin/config-yargs.js:89
npm ERR! prepareGitDep describe: optionsSchema.definitions.output.properties.path.description,
npm ERR! prepareGitDep ^
npm ERR! prepareGitDep
npm ERR! prepareGitDep TypeError: Cannot read property ‘properties’ of undefined
npm ERR! prepareGitDep at module.exports (/home/robin/.npm/_cacache/tmp/git-clone-e9a50443/node_modules/webpack-cli/bin/config-yargs.js:89:48)
npm ERR! prepareGitDep at /home/robin/.npm/_cacache/tmp/git-clone-e9a50443/node_modules/webpack-cli/bin/webpack.js:60:27
npm ERR! prepareGitDep at Object. (/home/robin/.npm/_cacache/tmp/git-clone-e9a50443/node_modules/webpack-cli/bin/webpack.js:515:3)
npm ERR! prepareGitDep at Module._compile (module.js:653:30)
npm ERR! prepareGitDep at Object.Module._extensions…js (module.js:664:10)
npm ERR! prepareGitDep at Module.load (module.js:566:32)
npm ERR! prepareGitDep at tryModuleLoad (module.js:506:12)
npm ERR! prepareGitDep at Function.Module._load (module.js:498:3)
npm ERR! prepareGitDep at Module.require (module.js:597:17)
npm ERR! prepareGitDep at require (internal/module.js:11:18)
npm ERR! prepareGitDep npm ERR! code ELIFECYCLE
npm ERR! prepareGitDep npm ERR! errno 1
npm ERR! prepareGitDep npm ERR! parchment@2.0.0-dev build: webpack --config webpack.conf.js
npm ERR! prepareGitDep npm ERR! Exit status 1
npm ERR! prepareGitDep npm ERR!
npm ERR! prepareGitDep npm ERR! Failed at the parchment@2.0.0-dev build script.
npm ERR! prepareGitDep npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! prepareGitDep
npm ERR! prepareGitDep npm ERR! A complete log of this run can be found in:
npm ERR! prepareGitDep npm ERR! /home/robin/.npm/_logs/2019-04-30T19_08_46_419Z-debug.log
npm ERR! prepareGitDep npm ERR! code ELIFECYCLE
npm ERR! prepareGitDep npm ERR! errno 1
npm ERR! prepareGitDep npm ERR! parchment@2.0.0-dev prepare: npm run build
npm ERR! prepareGitDep npm ERR! Exit status 1
npm ERR! prepareGitDep npm ERR!
npm ERR! prepareGitDep npm ERR! Failed at the parchment@2.0.0-dev prepare script.
npm ERR! prepareGitDep npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! prepareGitDep
npm ERR! prepareGitDep npm ERR! A complete log of this run can be found in:
npm ERR! prepareGitDep npm ERR! /home/robin/.npm/_logs/2019-04-30T19_08_46_597Z-debug.log
npm ERR! prepareGitDep
npm ERR! code ENOPACKAGEJSON
npm ERR! package.json Non-registry package missing package.json: parchment@github:quilljs/parchment#487850f7eb030a6c4e750ba809e58b09444e0bdb.
npm ERR! package.json npm can’t find a package.json file in your current directory.


#3

#4

can you please give these command line by line?


#5

Click on the link provided. The comment has all the commands written line by line. You can copy and paste onto the terminal with no issues.


#6

this error while trying to install npm:
sudo apt-get install npm
Reading package lists… Done
Building dependency tree… 50%
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
npm : Depends: nodejs but it is not going to be installed
Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
Depends: node-ansi-color-table but it is not going to be installed
Depends: node-ansi-regex but it is not going to be installed
Depends: node-ansistyles but it is not going to be installed
Depends: node-aproba but it is not going to be installed
Depends: node-archy but it is not going to be installed
Depends: node-are-we-there-yet but it is not going to be installed
Depends: node-aws-sign2 but it is not going to be installed
Depends: node-bluebird but it is not going to be installed
Depends: node-block-stream but it is not going to be installed
Depends: node-caseless but it is not going to be installed
Depends: node-chalk but it is not going to be installed
Depends: node-config-chain but it is not going to be installed
Depends: node-detect-indent but it is not going to be installed
Depends: node-editor but it is not going to be installed
Depends: node-encoding but it is not going to be installed
Depends: node-fs-vacuum but it is not going to be installed
Depends: node-fstream (>= 0.1.22) but it is not going to be installed
Depends: node-fstream-ignore but it is not going to be installed
Depends: node-gauge but it is not going to be installed
Depends: node-github-url-from-git but it is not going to be installed
Depends: node-glob (>= 3.1.21) but it is not going to be installed
Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
Depends: node-gyp (>= 0.10.9) but it is not going to be installed
Depends: node-har-validator but it is not going to be installed
Depends: node-has-unicode but it is not going to be installed
Depends: node-hawk but it is not going to be installed
Depends: node-hosted-git-info but it is not going to be installed
Depends: node-iferr but it is not going to be installed
Depends: node-import-lazy but it is not going to be installed
Depends: node-inflight but it is not going to be installed
Depends: node-inherits but it is not going to be installed
Depends: node-ini (>= 1.1.0) but it is not going to be installed
Depends: node-isstream but it is not going to be installed
Depends: node-is-npm but it is not going to be installed
Depends: node-is-typedarray but it is not going to be installed
Depends: node-jsonstream but it is not going to be installed
Depends: node-latest-version but it is not going to be installed
Depends: node-lazy-property but it is not going to be installed
Depends: node-lockfile but it is not going to be installed
Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
Depends: node-move-concurrently but it is not going to be installed
Depends: node-nopt but it is not going to be installed
Depends: node-normalize-package-data but it is not going to be installed
Depends: node-npmlog (>= 4.1.0) but it is not going to be installed
Depends: node-once but it is not going to be installed
Depends: node-opener but it is not going to be installed
Depends: node-osenv but it is not going to be installed
Depends: node-path-is-inside but it is not going to be installed
Depends: node-performance-now but it is not going to be installed
Depends: node-promise-inflight but it is not going to be installed
Depends: node-read but it is not going to be installed
Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
Depends: node-readable-stream but it is not going to be installed
Depends: node-request (>= 2.25.0) but it is not going to be installed
Depends: node-retry but it is not going to be installed
Depends: node-rimraf (>= 2.6.2) but it is not going to be installed
Depends: node-safe-buffer but it is not going to be installed
Depends: node-semver (>= 5.1.0) but it is not going to be installed
Depends: node-semver-diff but it is not going to be installed
Depends: node-set-blocking but it is not going to be installed
Depends: node-sha but it is not going to be installed
Depends: node-slide but it is not going to be installed
Depends: node-sorted-object but it is not going to be installed
Depends: node-stringstream but it is not going to be installed
Depends: node-strip-ansi but it is not going to be installed
Depends: node-tar (>= 4~) but it is not going to be installed
Depends: node-tough-cookie but it is not going to be installed
Depends: node-uid-number but it is not going to be installed
Depends: node-underscore but it is not going to be installed
Depends: node-unique-filename but it is not going to be installed
Depends: node-unpipe but it is not going to be installed
Depends: node-validate-npm-package-license but it is not going to be installed
Depends: node-which but it is not going to be installed
Depends: node-wrappy but it is not going to be installed
Depends: node-yargs but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


#7

Follow these 4 steps before installation:

  1. sudo apt-get install python-minimal
  2. sudo apt-get install build-essential python-setuptools
  3. wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
  4. sudo python install.py --production