Try ERPNext Buy Support Partners Foundation

Getting error for new installation using production script

Dear all,

I am trying to install fresh ERPNext on Ubuntu 18.04 LTS.

After installation of python-minimal, and running the installation script, I am getting following error.

vpm@vpm-VirtualBox:~$ sudo python install.py --production --user erp
Logs are saved under /tmp/logs/install_bench.log
Checking System Compatibility…
ubuntu 18 is compatible!
Traceback (most recent call last):
File “install.py”, line 425, in
check_system_package_managers()
File “install.py”, line 58, in check_system_package_managers
if not any([shutil.which(x) for x in [‘apt-get’, ‘yum’]]):
AttributeError: ‘module’ object has no attribute ‘which’

Please help me to resolve this error.

Sandeep Ulhalkar

1 Like

Try using the steps outlined here:

BKM

Seems like you’ve not installed setup tools.