Getting an installation issue

Hello there,

Thanks for review my post. I’m trying to setup frappe.sh and got lots of dependency error. i guess these belongs to EPEL repo. but it’s enabled in my system already.

—> Package nginx.x86_64 1:1.6.2-4.el7 will be installed
–> Processing Dependency: systemd for package: 1:nginx-1.6.2-4.el7.x86_64
–> Processing Dependency: systemd for package: 1:nginx-1.6.2-4.el7.x86_64
–> Processing Dependency: perl(:MODULE_COMPAT_5.16.3) for package: 1:nginx-1.6.2-4.el7.x86_64
–> Processing Dependency: GeoIP for package: 1:nginx-1.6.2-4.el7.x86_64
–> Processing Dependency: libpcre.so.1()(64bit) for package: 1:nginx-1.6.2-4.el7.x86_64
–> Processing Dependency: libGeoIP.so.1()(64bit) for package: 1:nginx-1.6.2-4.el7.x86_64
—> Package redis.x86_64 0:2.8.14-2.el7 will be installed
–> Processing Dependency: systemd for package: redis-2.8.14-2.el7.x86_64
–> Processing Dependency: systemd for package: redis-2.8.14-2.el7.x86_64
–> Finished Dependency Resolution
Error: Package: 1:nginx-1.6.2-4.el7.x86_64 (epel)
Requires: libpcre.so.1()(64bit)
Error: Package: 1:nginx-1.6.2-4.el7.x86_64 (epel)
Requires: GeoIP
Error: Package: 1:nginx-1.6.2-4.el7.x86_64 (epel)
Requires: perl(:MODULE_COMPAT_5.16.3)
Error: Package: redis-2.8.14-2.el7.x86_64 (epel)
Requires: systemd
Error: Package: 1:nginx-1.6.2-4.el7.x86_64 (epel)
Requires: systemd
Error: Package: 1:nginx-1.6.2-4.el7.x86_64 (epel)
Requires: libGeoIP.so.1()(64bit)
Error: Package: gperftools-libs-2.1-1.el7.x86_64 (epel)
Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), ‘yum check’ output follows:
ius-release-1.0-13.ius.el6.noarch has missing requires of epel-release = (‘0’, ‘6’, None)
mysql-server-5.1.71-1.el6.x86_64 has missing requires of mysql = (‘0’, ‘5.1.71’, ‘1.el6’)

any clue ? Please let me know where i’m wrong.

Thanks in advance

Best Regards
Arun

Are you on CentOS 7?

I experienced this with one machine that had CentOS 7 with EPEL 6 repos setup (on VPSime). If it’s possible start with a fresh minimal install.