Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

Getting 404 After Install

I installed and used frappe fine on localhost. I have now installed to a VPS and can’t figure out the URL. What should the URL be… instead of localhost:8080?

That would depend on the host and would be dependent on whether you have your domain pointing at the VPS or not. If you don’t then your host should provide you with the web address to access your site. You will replace localhost with whatever address you were provided with and then append the :8080 as you previously did to the end of it.

Thanks… but, I tried my VPS IP Address:8080… no luck.

I’m surprised I can’t find documentation which discusses how to “deploy.” Do you know where that sort of documentation can be found?

Again… thanks for the reply.

Did you pass --setup-production to the install script? (https://github.com/frappe/bench#easy-way)

If yes, then it should be running on port 80, so http://{vps_ip} should work

If you didn’t pass --setup-production, you can setup for production by running

sudo bench setup production frappe # assuming frappe is the frappe user, don't worry if you used defaults

If you still face an issue, check if you need to open up any firewalled ports for your vps.

Thanks! I’ll check for firewalled ports.

I tried to use --setup-production… but, I received a script error relating to some mariadb password being wrong. So, I gave up on that and installed the whole thing.

I gave up on getting the VPS to work. I installed a Vbox, on my laptop. After install, I still get a 404. When I do “bench start,” I receive:

mike@mike-VirtualBox:~$ bench start
11:43:55 system | web.1 started (pid=15138)
11:43:55 system | worker.1 started (pid=15137)
11:43:55 system | workerbeat.1 started (pid=15140)
11:43:55 system | socketio.1 started (pid=15148)
11:43:55 system | redis_async_broker.1 started (pid=15141)
11:43:55 redis_async_broker.1 | [15149] 05 Oct 11:43:55.910 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
11:43:55 redis_async_broker.1 | [15149] 05 Oct 11:43:55.911 # Creating Server TCP listening socket *:12311: bind: Address already in use
11:43:55 system | redis_async_broker.1 stopped (rc=1)
11:43:55 system | redis_cache.1 started (pid=15146)
11:43:56 system | sending SIGTERM to workerbeat.1 (pid 15140)
11:43:56 system | sending SIGTERM to worker.1 (pid 15137)
11:43:56 system | sending SIGTERM to web.1 (pid 15138)
11:43:56 system | sending SIGTERM to socketio.1 (pid 15148)
11:43:56 system | sending SIGTERM to redis_cache.1 (pid 15146)
11:43:55 redis_cache.1 | [15155] 05 Oct 11:43:55.943 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
11:43:56 system | worker.1 stopped (rc=-15)
11:43:56 system | web.1 stopped (rc=-15)
11:43:56 system | workerbeat.1 stopped (rc=-15)
11:43:56 system | socketio.1 stopped (rc=-15)
11:43:55 redis_cache.1 | [15155] 05 Oct 11:43:55.943 # Creating Server TCP listening socket *:11311: bind: Address already in use
11:43:56 system | redis_cache.1 stopped (rc=1)
mike@mike-VirtualBox:~$ ^C
mike@mike-VirtualBox:~$

Any help would be greatly appreciated. It been days and I still can’t get this thing to work. Sorry, I’m such a nube.

This indicates that you’ve setup for production. If you do so, you need to bench start
what is the output of

curl -I localhost

Also, if you downloaded the vm from our website, go to http://localhost:8080 on the host machine.

Thanks! Let me start, completely, from the beginning… without any assumptions or baggage from what we have been doing.

We are trying to install frappe for development/installation of our own apps. That is, we do not need to/plan to use the erpnext apps.

  1. Should we use:

wget https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh
sudo bash setup_frappe.sh --setup-production

with or without the “–setup-production” to install frappe on our server?

  1. After the “sudo bash setup_frappe.sh…” step… what’s next? That is, will we have ToDo, Calendar, etc. already installed, a first site installed, etc?

Thanks!

Yeah, just run this on a clean install of Ubuntu / CentOS, ERPNext will be running on port 80

wget https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh
sudo bash setup_frappe.sh --setup-production

Thanks… we will start clean :smile:

I am using port 80 but still I have same issue Not Found page