ERPNext Foundation ERPNext Cloud Chat Blog Discuss Frappé* Donate

G Suite Email Setup


#1

Hi,

I have been experiencing issues getting my G Suite emails to work.
I followed the instructions but no luck

I have tried the following

  1. Setup Email Domain
  2. Set up each email account >
  3. Created each user as a system user
  4. Allow less secure apps on G Suite
  5. Confirmed that usernames and passwords are correct

Not sure what I am missing here, any assistance is greatly appreciated.


#2

Are you on localhost or server live server ?


#3

Hi Joe, thanks for the response.

I am on a live server. using online.net


#4

You only miss to allow less secure app on your G suite account
Click here to do it.

Hope it helps. Comment back when you are done @Samoroai7


#5

Hi Jo3e

I have done so, any other ideas?

Regards
Samir


#6

Hi all, so I have managed to get the outgoing emails to work however inbox still proves to be a challenge. I have an error report below that might help me in solving this


#7

I believe there’s been a small change in the way that Gmail operates (not sure what exactly ) and because of this there has been a very recent commit to fix this just a day or two ago.

Try a bench update and I’m hoping it will be fixed for you …


#8

Hey Julian,

thanks for the help.
I have updated and still does not work.

Some feedback on what I have done thus far.
I setup a new instance on a totally different domain also using g suite. It all seems to be working fine

Is there a way to just update or duplicate the email sending modules from one instance to the next?
I am tempted to do a new instance manually importing new content

any ideas, greatly appreciated