Try ERPNext Buy Support Partners Foundation Foundation Members

[FYI/solved] yarn errors on bench update

I am still using v10.1.70/80 on a Debian Stretch 9.x manual install, and everything works perfectly :slight_smile:
I have seen in the past few weeks that there are many posts about yarn related errors during updates.
I have/had not experienced any errors on my normal installation/server, but…

While installing a backup/secondary machine to do some testing, I installed a v11 master copy (manually) and then downgraded to v10.x.x with a branch switch and did indeed, experience the yarn error. The manual method is something I posted here and which may be a bit out of date (I’ll fix it one of these days).

Specifically these lines…are “problematic”…

#I downgraded to pip to 9.0.3 and things worked for me. Command for downgrading pip is
python -m pip install –user pip==9.0.3

That WAS working OK up until recently, but apparently is NOT right for the newer v11.
I edited the pip line from 9.03 to 19.03 and the yarn issue disappears, so it would seem that it is just a versioning/compatibility problem. So in short…

#I DON’T downgrade to pip to 9.0.3 anymore…use v19.03 instead
python -m pip install –user pip==19.0.3

Just thought I’d share this and hope it’s helpful for someone

3 Likes