aim using the docker installation from https://github.com/frappe/
But running into a installation error:
ERROR: frontmatter 3.0.5 has requirement PyYAML==3.13, but you’ll have pyyaml 5.1.1 which is incompatible.
what can i do to pin down a specific version or how can i fix this?
anyone else having this issue?
bench setup requirements
I am also facing the same issue, please let me know if you find any solution
Have you tried installing PyYAML==3.13 which is clearly stated as a requirement in the error message?
yes tried this. but didnt work, Gave the same error message
can you please tell how to un-install 5.1.1.? I am not able find this .
I also tried "sudo pip install --ignore-installed PyYAML==3.13
Have you found a solution @itsdipak?
Same error in debian stretch.
I don’t see any bug for this, where frontmatter is used ?
I deleted the installed bench and then re-install using
git clone https://github.com/frappe/bench bench-repo
pip install --user -e bench-repo
bench init frappe-bench
sudo python install.py --develop --python python3
While installing i also got error related to testfm , resolve running below script.
$ sudo apt-get install gfortran libatlas-base-dev liblapack-dev python-dev build-essential
(Note: I was installing python3 ERPNEXT V12 ) Finally up and running now
Hope this help!
what is the solution of this i am facing same issue while doing setup
Bump guys, I’m getting this now
I contacted the maintainer for
frontmatter and he has made a release for 3.0.6. He should soon be making a PYPI release for the same as well, post that we can update that in frappe too.