Try ERPNext Buy Support Partners Foundation

Frappeframework install problem

Hi, I’m new in frappe framework software. after installing frappe bench, when I try to start I face the error bellow. I’m trying to install for 2 week but I didn’t get any solution. Please help me.

hafiq@shafiq-desktop:~/frappe-bench$ bench start
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench

01:09:26 system | web.1 started (pid=3563)
01:09:26 system | worker_short.1 started (pid=3570)
01:09:26 system | schedule.1 started (pid=3566)
01:09:26 system | redis_socketio.1 started (pid=3556)
01:09:26 redis_socketio.1 | 3565:C 23 Sep 2020 01:09:26.169 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
01:09:26 redis_socketio.1 | 3565:C 23 Sep 2020 01:09:26.169 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=3565, just started
01:09:26 redis_socketio.1 | 3565:C 23 Sep 2020 01:09:26.169 # Configuration loaded
01:09:26 redis_socketio.1 | 3565:M 23 Sep 2020 01:09:26.169 * Increased maximum number of open files to 10032 (it was originally set to 1024).
01:09:26 system | redis_queue.1 started (pid=3578)
01:09:26 system | watch.1 started (pid=3560)
01:09:26 redis_socketio.1 | 3565:M 23 Sep 2020 01:09:26.178 * Running mode=standalone, port=12000.
01:09:26 redis_socketio.1 | 3565:M 23 Sep 2020 01:09:26.178 # Server initialized
01:09:26 redis_socketio.1 | 3565:M 23 Sep 2020 01:09:26.178 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
01:09:26 redis_socketio.1 | 3565:M 23 Sep 2020 01:09:26.178 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
01:09:26 redis_socketio.1 | 3565:M 23 Sep 2020 01:09:26.178 * Ready to accept connections
01:09:26 redis_queue.1 | 3582:C 23 Sep 2020 01:09:26.178 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
01:09:26 redis_queue.1 | 3582:C 23 Sep 2020 01:09:26.178 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=3582, just started
01:09:26 redis_queue.1 | 3582:C 23 Sep 2020 01:09:26.178 # Configuration loaded
01:09:26 redis_queue.1 | 3582:M 23 Sep 2020 01:09:26.179 * Increased maximum number of open files to 10032 (it was originally set to 1024).
01:09:26 redis_queue.1 | 3582:M 23 Sep 2020 01:09:26.179 * Running mode=standalone, port=11000.
01:09:26 redis_queue.1 | 3582:M 23 Sep 2020 01:09:26.179 # Server initialized
01:09:26 redis_queue.1 | 3582:M 23 Sep 2020 01:09:26.179 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
01:09:26 redis_queue.1 | 3582:M 23 Sep 2020 01:09:26.179 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
01:09:26 redis_queue.1 | 3582:M 23 Sep 2020 01:09:26.180 * Ready to accept connections
01:09:26 system | worker_long.1 started (pid=3558)
01:09:26 system | worker_default.1 started (pid=3597)
01:09:26 system | redis_cache.1 started (pid=3574)
01:09:26 redis_cache.1 | 3581:C 23 Sep 2020 01:09:26.186 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
01:09:26 redis_cache.1 | 3581:C 23 Sep 2020 01:09:26.186 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=3581, just started
01:09:26 redis_cache.1 | 3581:C 23 Sep 2020 01:09:26.186 # Configuration loaded
01:09:26 redis_cache.1 | 3581:M 23 Sep 2020 01:09:26.186 * Increased maximum number of open files to 10032 (it was originally set to 1024).
01:09:26 redis_cache.1 | 3581:M 23 Sep 2020 01:09:26.187 * Running mode=standalone, port=13000.
01:09:26 redis_cache.1 | 3581:M 23 Sep 2020 01:09:26.187 # Server initialized
01:09:26 redis_cache.1 | 3581:M 23 Sep 2020 01:09:26.187 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
01:09:26 redis_cache.1 | 3581:M 23 Sep 2020 01:09:26.187 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
01:09:26 redis_cache.1 | 3581:M 23 Sep 2020 01:09:26.187 * Ready to accept connections
01:09:26 system | socketio.1 started (pid=3575)
01:09:26 socketio.1 | module.js:550
01:09:26 socketio.1 | throw err;
01:09:26 socketio.1 | ^
01:09:26 socketio.1 |
01:09:26 socketio.1 | Error: Cannot find module ‘express’
01:09:26 socketio.1 | at Function.Module._resolveFilename (module.js:548:15)
01:09:26 socketio.1 | at Function.Module._load (module.js:475:25)
01:09:26 socketio.1 | at Module.require (module.js:597:17)
01:09:26 socketio.1 | at require (internal/module.js:11:18)
01:09:26 socketio.1 | at Object. (/home/shafiq/frappe-bench/apps/frappe/socketio.js:1:73)
01:09:26 socketio.1 | at Module._compile (module.js:653:30)
01:09:26 socketio.1 | at Object.Module._extensions…js (module.js:664:10)
01:09:26 socketio.1 | at Module.load (module.js:566:32)
01:09:26 socketio.1 | at tryModuleLoad (module.js:506:12)
01:09:26 socketio.1 | at Function.Module._load (module.js:498:3)
01:09:26 system | socketio.1 stopped (rc=1)
01:09:26 system | sending SIGTERM to redis_socketio.1 (pid 3556)
01:09:26 system | sending SIGTERM to worker_long.1 (pid 3558)
01:09:26 system | sending SIGTERM to watch.1 (pid 3560)
01:09:26 system | sending SIGTERM to redis_queue.1 (pid 3578)
01:09:26 system | sending SIGTERM to web.1 (pid 3563)
01:09:26 system | sending SIGTERM to schedule.1 (pid 3566)
01:09:26 system | sending SIGTERM to worker_default.1 (pid 3597)
01:09:26 system | sending SIGTERM to redis_cache.1 (pid 3574)
01:09:26 system | sending SIGTERM to worker_short.1 (pid 3570)
01:09:26 system | schedule.1 stopped (rc=-15)
01:09:26 system | worker_short.1 stopped (rc=-15)
01:09:26 redis_cache.1 | 3581:signal-handler (1600801766) Received SIGTERM scheduling shutdown…
01:09:26 system | worker_default.1 stopped (rc=-15)
01:09:26 redis_socketio.1 | 3565:signal-handler (1600801766) Received SIGTERM scheduling shutdown…
01:09:26 redis_queue.1 | 3582:signal-handler (1600801766) Received SIGTERM scheduling shutdown…
01:09:26 system | worker_long.1 stopped (rc=-15)
01:09:26 system | watch.1 stopped (rc=-15)
01:09:26 system | web.1 stopped (rc=-15)
01:09:26 redis_socketio.1 | 3565:M 23 Sep 2020 01:09:26.378 # User requested shutdown…
01:09:26 redis_socketio.1 | 3565:M 23 Sep 2020 01:09:26.378 * Removing the pid file.
01:09:26 redis_socketio.1 | 3565:M 23 Sep 2020 01:09:26.378 # Redis is now ready to exit, bye bye…
01:09:26 system | redis_socketio.1 stopped (rc=-15)
01:09:26 redis_queue.1 | 3582:M 23 Sep 2020 01:09:26.380 # User requested shutdown…
01:09:26 redis_queue.1 | 3582:M 23 Sep 2020 01:09:26.380 * Removing the pid file.
01:09:26 redis_queue.1 | 3582:M 23 Sep 2020 01:09:26.380 # Redis is now ready to exit, bye bye…
01:09:26 system | redis_queue.1 stopped (rc=-15)
01:09:26 redis_cache.1 | 3581:M 23 Sep 2020 01:09:26.387 # User requested shutdown…
01:09:26 redis_cache.1 | 3581:M 23 Sep 2020 01:09:26.387 * Removing the pid file.
01:09:26 redis_cache.1 | 3581:M 23 Sep 2020 01:09:26.387 # Redis is now ready to exit, bye bye…
01:09:26 system | redis_cache.1 stopped (rc=-15)
shafiq@shafiq-desktop:~/frappe-bench$