Frappe update issues

Hello Guys

when i update my system i received this issues

frappe-bench$ bench update --restart
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench

Traceback (most recent call last):
File “/usr/lib/python3.6/runpy.py”, line 183, in _run_module_as_main
mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
File “/usr/lib/python3.6/runpy.py”, line 109, in _get_module_details
import(pkg_name)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 26, in
from frappe.query_builder import get_query_builder, patch_query_execute
File “/home/frappe/frappe-bench/apps/frappe/frappe/query_builder/init.py”, line 6, in
from frappe.query_builder.terms import ParameterizedFunction, ParameterizedValueWrapper
File “/home/frappe/frappe-bench/apps/frappe/frappe/query_builder/terms.py”, line 7, in
from frappe.utils.data import format_timedelta
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/init.py”, line 28, in
from frappe.utils.html_utils import sanitize_html
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/html_utils.py”, line 6, in
from bleach_allowlist import bleach_allowlist
ModuleNotFoundError: No module named ‘bleach_allowlist’

Traceback (most recent call last):
File “/home/frappe/.local/bin/bench”, line 8, in
sys.exit(cli())
File “/home/frappe/.local/lib/python3.6/site-packages/bench/cli.py”, line 48, in cli
if sys.argv[1] in get_frappe_commands() + ["–site", “–verbose”, “–force”, “–profile”]:
TypeError: unsupported operand type(s) for +: ‘NoneType’ and ‘list’

please help me ,

any update help me ,

@soome_rs version 13 or 12 ?

erpnext & frappe 13

@soome_rs try this on your bench directory :

./env/bin/pip3 install bleach_allowlist

Thank you so much