Format number in french

Hello,

I just found ERPNext and I’m excited. I installed a virtualbox UBUNTU 14 then a Droplet DigitalOcean with UBUNTU 14.04.3 x64.
However, I have a big problem with the number format. Indeed, everything must be in French and in particular the number format. I did several tests by changing the number format in [Setup/Settings/System Settings]

  1. number format: # ###,##
    1234567,89 save 1,234,567.00
  2. number format: #,##,###.##
    1234567.89 save 1,234,567.89
  3. number format:. #.###,##
    1234567,89 save 1,234,567.89

Note:
Often when I change the format of numbers, I have the following message:

"Error: Document has been modified after-you-have it ouvert (2016-01-04 00: 07: 35.840890, 2016-01-04 00: 11: 32.680832) Please refresh to get the latest document…
Did not save "

I reload the document, I change again and I record.

My setup:

  • Ubuntu 14.04.3 x64
  • ERPNext: v6.15.1
  • Strike Framework: v6.16.4

Thank you in advance.

@rlesouef Thanks for reporting and welcome to the fourm. We will look in tho this soon.

Hello,
Other users have reported me the same format problem (# ###,## and #. ###,##). It would he seems a bug. ERPNext difficult to use with this kind of problem.

@rlesouef

Say that the number format in your System Settings is #.###,##. This implies that . is the thousands separator and , is the decimal separator.

When you type 11.234,5 in a Float field, it will render it as 11.234,500 assuming the default float precision as 3 in the System Settings.

However, when you type 11.234,5 in a Currency field, the system will re-format the value using the currency’s number format. Say the currency is USD, then the value will be rendered as 11,234.50.

This is intentionally designed assuming that the user will be typing using the number format as per System Settings and not in the number format of the currency.

Hello,
Thank you for this information.
I have trouble understanding. The number format should enable display according to an international currency format. What interest to have a kind of #.###,## format, if it appears to me 1,234,567.89 ?
The following format


should display

Do I need to configure debian (locales or other)?
Thanks in advance.

You can change each currency’s number format in the Currency master - rather than the number format.

Confirm that Setup->Currency->Euro is in the number format #.###,##. If the currency’s number format is blank, it will revert to the system settings.

Hope this helps :smile:

2 Likes

Where is ?

Apologies! It’s in Setup->Accounts->Currency.

1 Like

@rlesouef is EUR formatted as #.###,##? Not according to this website: http://www.thefinancials.com/Default.aspx?SubSectionID=curformat

It works, thank you.
Another question I would like to improve the translation into French. How should I proceed to improve the French translation?
thanks in advance

@rlesouef https://translate.erpnext.com/view?lang=fr

Translations are updated back roughly once a week.