Fixed Asset Register (with repairs and revaluations)

Hi all, first post here. We are a manufacturer looking to implement ERPNext. I have been experimenting with the Fixed Assets module and have run into a few, shall we say, roadblocks.

Things seem to work cleanly when dealing with simple asset purchases/capitalization and depreciation. However when using the Asset Repair and Asset Value Adjustment features, things seem to behave unexpectedly.

Specifically:

  1. When using either Asset Repair (where there is a capitalized repair cost) or Asset Value Adjustment on any asset, the revised asset value is not reflected in the Fixed Asset Register report. It still seems to reflect the original cost and accumulated depreciation only, and nothing else.

  2. Performing an Asset Value Adjustment seems to post a JV hitting Acc. Dep. and Depr. Expense for the asset, it doesn’t actually affect the asset cost or a revaluation surplus or impairment account, which would in my view be the correct way to do this. Also as I already mentioned, the revaluation seems to not be reflected in the FA Register.

  3. Performing an Asset Repair with capitalized repair cost seems to do weird things to the depreciation schedule for an asset (where depreciation is automatically calculated and posted by the system). In many cases it seems to add the increased capitalized value of the repair to the very final depreciation entry, making it outsized in value compared to the other scheduled entries. I am still experimenting with this, trying to understand how Asset Repair affects depreciation schedules to understand the behavior. Also as before, any asset value increases seem due to capitalized repair seem to not be reflected in the FA Register, just the cost and regular depreciation.

Any thoughts on this? Am I completely missing something or not using the module correctly, or is something genuinely wrong with the way it works? Thanks for any responses.

1 Like