First error after installation

I receive this error message after following this guide, manual installation on ubuntu 16.04; https://github.com/frappe/frappe/wiki/The-Hitchhiker’s-Guide-to-Installing-Frappé-on-Linux-OS

Traceback (most recent call last):
  File "/home/alp/frappe-bench/apps/frappe/frappe/app.py", line 62, in application
    response = frappe.handler.handle()
  File "/home/alp/frappe-bench/apps/frappe/frappe/handler.py", line 22, in handle
    data = execute_cmd(cmd)
  File "/home/alp/frappe-bench/apps/frappe/frappe/handler.py", line 53, in execute_cmd
    return frappe.call(method, **frappe.form_dict)
  File "/home/alp/frappe-bench/apps/frappe/frappe/__init__.py", line 942, in call
    return fn(*args, **newargs)
  File "/home/alp/frappe-bench/apps/frappe/frappe/client.py", line 314, in get_js
    with open(contentpath, "r") as srcfile:
IOError: [Errno 2] No such file or directory: u'./assets/erpnext/js/setup_wizard.js'

any ideas?

Did you do the install with --develop or --production?

I had issues with the setup wizard on --develop, but it worked on --production.

Another option is bypassing the setup wizard by either restoring from an existing instance or using the bench cli, but I couldn’t get either to work.

thanks for your answer and sorry for my silly reply, but how do I know
which branch I installed? there was no any detail on the guide whether it
is any of those…

Alp ŞEBER

Try to use this


This code to reinstall your site

bench --site sitename reinstall

Install Erpnext

bench --site sitename install-app erpnext

nope, it didnt work. I guess, I’ll use another software like odoo.

Going to the app repos

cd apps/erpnext & cd apps/frappe

and running the command git branch

Good luck with that :+1: but no need to announce it if you’re angry with the installation.

Simple searches or some questions would have helped you install in a better manner.

For stable installation: https://github.com/frappe/bench#easy-install

If you were on the Develop branch you just had to use the bench switch-to-master command and then do a bench migrate.

If you were still having difficulties to install, could’ve just gone for a trial account first.

PS: an old thread from 2015 where users have said that getting started with ERPNext has been much easier.

Note that the Hitchhiker’s guide is meant for developers and by default installs the develop branch. You could have also raised an issue regarding the same to make sure that fixes are pushed.

Again, this is a community forum where people will always try to help you.

2 Likes

Dear Kenneth,

Thanks for your reply, after your support, I erased everything and did a
fresh start on a blank ubuntu server, easy install was easy, I dont know
why I went for develepor installation at first.

Anyway, I look forward to have your support for future.

Regards,

Alp ŞEBER

1 Like

Glad to know! :smile: