Error with Easy Script (and Manual)

I tried to install on a VM with Debian 10, just installed.
I’m following the Easy Install Script "guide, so I ran the following commands:

apt install python3-minimal build-essential python3-setuptools
python3 --production

The messages with the last command are:

Installing curl...
curl installed!
wget already installed!
git already installed!
Installing pip3...
pip3 installed!
pip3 already installed!
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
Collecting distro
Downloading distro-1.5.0-py2.py3-none-any.whl (18 kB)
Installing collected packages: distro
Successfully installed distro-1.5.0
Checking System Compatibility...
Sorry, the installer doesn't support debian gnu/linux. Aborting installation!
Bench's CLI needs these to be defined!
Run the following commands in shell:
export LC_ALL=C.UTF-8

I don’t understand what’s wrong with it

Just run this command in the console/shell and then install.

Edit: Your OS seems to be unsupported by Easy Install Script as well.

It’s a clean Debian 10 server.

Now, after the commands:

export LC_ALL=C.UTF-8
python3 --production

there are still too many errors and Waring to be considered an Easy Installation.
At this point, if I have to spend some time figuring out what’s wrong with Easy Installation, I try Manual Installation.

Manual installation also ends with errors.
Is it possible that there is no step-by-step installation guide from scratch to the ERPNext login page?