Error while running site after new app installation - multi bench setup

Created new bench , created new site and Installed ERPnext … everything ok
started bench , setup site and worked on it -smooth…

Today created a new app(just basic with name and description ) with bench --site <site_name> install-app <app_name> i got this error :

Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 162, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/home/taher/saloon-bench/apps/frappe/frappe/utils/”, line 94, in
File “/home/taher/saloon-bench/apps/frappe/frappe/utils/”, line 18, in main
File “/home/taher/saloon-bench/env/local/lib/python2.7/site-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/home/taher/saloon-bench/env/local/lib/python2.7/site-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/home/taher/saloon-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/taher/saloon-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/taher/saloon-bench/env/local/lib/python2.7/site-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/taher/saloon-bench/env/local/lib/python2.7/site-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/taher/saloon-bench/env/local/lib/python2.7/site-packages/click/”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/taher/saloon-bench/apps/frappe/frappe/commands/”, line 24, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/taher/saloon-bench/apps/frappe/frappe/commands/”, line 157, in install_app
File “/home/taher/saloon-bench/apps/frappe/frappe/”, line 135, in init
local.conf = _dict(get_site_config())
File “/home/taher/saloon-bench/apps/frappe/frappe/”, line 189, in get_site_config
File “/home/taher/saloon-bench/apps/frappe/frappe/”, line 880, in get_file_json
return json.load(f)
File “/usr/lib/python2.7/json/”, line 290, in load
File “/usr/lib/python2.7/json/”, line 338, in loads
return _default_decoder.decode(s)
File “/usr/lib/python2.7/json/”, line 366, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File “/usr/lib/python2.7/json/”, line 382, in raw_decode
obj, end = self.scan_once(s, idx)
ValueError: Expecting , delimiter: line 5 column 2 (char 94)

then now if i try to access the site after running bench i get error page

File “/home/taher/saloon-bench/apps/frappe/frappe/”, line 15, in call
return super(StaticDataMiddleware, self).call(environ, start_response)
File “/home/taher/saloon-bench/env/lib/python2.7/site-packages/werkzeug/”, line 600, in call
return, start_response)
File “/home/taher/saloon-bench/env/lib/python2.7/site-packages/werkzeug/”, line 600, in call
return, start_response)
File “/home/taher/saloon-bench/env/lib/python2.7/site-packages/werkzeug/”, line 228, in application
return ClosingIterator(app(environ, start_response), self.cleanup)
File “/home/taher/saloon-bench/env/lib/python2.7/site-packages/werkzeug/”, line 301, in application
return f(*args[:-2] + (request,))(*args[-2:])
File “/home/taher/saloon-bench/apps/frappe/frappe/”, line 83, in application
response = handle_exception(e)
File “/home/taher/saloon-bench/apps/frappe/frappe/”, line 178, in handle_exception
File “/home/taher/saloon-bench/apps/frappe/frappe/utils/”, line 21, in make_error_snapshot
if frappe.conf.disable_error_snapshot:
File “/home/taher/saloon-bench/env/lib/python2.7/site-packages/werkzeug/”, line 347, in getattr
return getattr(self._get_current_object(), name)
File “/home/taher/saloon-bench/env/lib/python2.7/site-packages/werkzeug/”, line 310, in _get_current_object
raise RuntimeError(‘no object bound to %s’ %
RuntimeError: no object bound to conf

any help ?

It seems that the site_config.json file has the invalid json content please check and validate the json and try to access the site again

Solved it ,
i forgot to put “,” after i set “developer_mode” : 1 in site_config.