Error while installation of frappe 6

Hello All,

Getting following error during installation: -

Compiling /home/indictrance/Documents/receipher-setup/frappe-bench/env/build/gunicorn/gunicorn/workers/ …
File “/home/indictrance/Documents/receipher-setup/frappe-bench/env/build/gunicorn/gunicorn/workers/”, line 68
yield from self.wsgi.close()
SyntaxError: invalid syntax

Compiling /home/indictrance/Documents/receipher-setup/frappe-bench/env/build/selenium/selenium/test/selenium/webdriver/ …
File “/home/indictrance/Documents/receipher-setup/frappe-bench/env/build/selenium/selenium/test/selenium/webdriver/”, line 21
from selenium.##PACKAGE_NAME## import ##GENERAL_FILENAME##
SyntaxError: invalid syntax

npm http GET
npm http GET
npm http GET
npm http GET
npm http GET
npm http 304
npm ERR! Error: EACCES, mkdir ‘/home/indictrance/tmp/npm-25466-Fov26X_T’
npm ERR! { [Error: EACCES, mkdir ‘/home/indictrance/tmp/npm-25466-Fov26X_T’]
npm ERR! errno: 3,
npm ERR! code: ‘EACCES’,
npm ERR! path: ‘/home/indictrance/tmp/npm-25466-Fov26X_T’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! System Linux 3.13.0-32-generic
npm ERR! command “/usr/bin/nodejs” “/usr/bin/npm” “install” “” “redis” “express” “superagent” “cookie”
npm ERR! cwd /home/indictrance/Documents/receipher-setup/frappe-bench
npm ERR! node -v v0.10.25
npm ERR! npm -v 1.3.10
npm ERR! path /home/indictrance/tmp/npm-25466-Fov26X_T
npm ERR! code EACCES
npm ERR! errno 3
npm ERR! stack Error: EACCES, mkdir ‘/home/indictrance/tmp/npm-25466-Fov26X_T’
npm http 304
npm http 304
npm http 304
npm http 304
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/indictrance/Documents/receipher-setup/frappe-bench/npm-debug.log
npm ERR! not ok code 0
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.92’, ‘console_scripts’, ‘bench’)()
File “/home/indictrance/Documents/receipher-setup/bench-repo/bench/”, line 60, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 609, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 589, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 935, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 781, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 416, in invoke
return callback(*args, **kwargs)
File “/home/indictrance/Documents/receipher-setup/bench-repo/bench/”, line 165, in init
no_auto_update=no_auto_update, frappe_path=frappe_path, frappe_branch=frappe_branch)
File “/home/indictrance/Documents/receipher-setup/bench-repo/bench/”, line 82, in init
File “/home/indictrance/Documents/receipher-setup/bench-repo/bench/”, line 112, in setup_socketio
exec_cmd(“npm install redis express superagent cookie”, cwd=bench)
File “/home/indictrance/Documents/receipher-setup/bench-repo/bench/”, line 104, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: npm install redis express superagent cookie

I have checked frappe-bench/npm-debug.log file, which showing an error Error: EACCES, mkdir '/home/indictrance/tmp/npm-25466-Fov26X_T’

I am using the ubuntu 14.04
I have also tried to install using the sudo but still same error persists
Please suggest

Thanks, Rohit

Seems that you’ve permission issues for your home dir

Thanks Pratik, it works after changing the permission of the folder tmp