Try ERPNext Buy Support Partners Foundation

Error while Bench start Error: ENOSPC

i stopped the supervisorctl process and it give that error any help?

 sudo supervisorctl stop all
frappe-bench-workers:frappe-bench-frappe-schedule: stopped
frappe-bench-web:frappe-bench-node-socketio: stopped
frappe-bench-redis:frappe-bench-redis-queue: stopped
frappe-bench-redis:frappe-bench-redis-cache: stopped
frappe-bench-redis:frappe-bench-redis-socketio: stopped
frappe-bench-workers:frappe-bench-frappe-default-worker-0: stopped
frappe-bench-workers:frappe-bench-frappe-long-worker-0: stopped
frappe-bench-workers:frappe-bench-frappe-short-worker-0: stopped
frappe-bench-web:frappe-bench-frappe-web: stopped
frappe@ubuntu:~/frappe-bench$ bench start
19:23:13 system           | watch.1 started (pid=3307)
19:23:13 system           | redis_queue.1 started (pid=3308)
19:23:13 system           | worker_long.1 started (pid=3313)
19:23:13 system           | worker_default.1 started (pid=3310)
19:23:13 system           | schedule.1 started (pid=3309)
19:23:13 system           | socketio.1 started (pid=3319)
19:23:13 system           | web.1 started (pid=3320)
19:23:13 system           | redis_socketio.1 started (pid=3316)
19:23:13 redis_queue.1    | 3314:M 15 Jun 19:23:13.866 * Increased maximum number of open files to 10032 (it was originally set to 1024).
19:23:13 redis_queue.1    |                 _._                                                  
19:23:13 redis_queue.1    |            _.-``__ ''-._                                             
19:23:13 redis_queue.1    |       _.-``    `.  `_.  ''-._           Redis 3.0.6 (00000000/0) 64 bit
19:23:13 redis_queue.1    |   .-`` .-```.  ```\/    _.,_ ''-._                                   
19:23:13 redis_queue.1    |  (    '      ,       .-`  | `,    )     Running in standalone mode
19:23:13 redis_queue.1    |  |`-._`-...-` __...-.``-._|'` _.-'|     Port: 11000
19:23:13 redis_queue.1    |  |    `-._   `._    /     _.-'    |     PID: 3314
19:23:13 redis_queue.1    |   `-._    `-._  `-./  _.-'    _.-'                                   
19:23:13 redis_queue.1    |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
19:23:13 redis_queue.1    |  |    `-._`-._        _.-'_.-'    |           http://redis.io        
19:23:13 redis_queue.1    |   `-._    `-._`-.__.-'_.-'    _.-'                                   
19:23:13 redis_queue.1    |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
19:23:13 redis_queue.1    |  |    `-._`-._        _.-'_.-'    |                                  
19:23:13 redis_queue.1    |   `-._    `-._`-.__.-'_.-'    _.-'                                   
19:23:13 redis_queue.1    |       `-._    `-.__.-'    _.-'                                       
19:23:13 redis_queue.1    |           `-._        _.-'                                           
19:23:13 redis_queue.1    |               `-.__.-'                                               
19:23:13 redis_queue.1    | 
19:23:13 redis_queue.1    | 3314:M 15 Jun 19:23:13.869 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:23:13 redis_queue.1    | 3314:M 15 Jun 19:23:13.869 # Server started, Redis version 3.0.6
19:23:13 redis_queue.1    | 3314:M 15 Jun 19:23:13.870 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
19:23:13 redis_queue.1    | 3314:M 15 Jun 19:23:13.870 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:23:13 redis_queue.1    | 3314:M 15 Jun 19:23:13.870 * The server is now ready to accept connections on port 11000
19:23:13 system           | redis_cache.1 started (pid=3330)
19:23:13 system           | worker_short.1 started (pid=3332)
19:23:13 redis_socketio.1 | 3324:M 15 Jun 19:23:13.882 * Increased maximum number of open files to 10032 (it was originally set to 1024).
19:23:13 redis_socketio.1 |                 _._                                                  
19:23:13 redis_socketio.1 |            _.-``__ ''-._                                             
19:23:13 redis_socketio.1 |       _.-``    `.  `_.  ''-._           Redis 3.0.6 (00000000/0) 64 bit
19:23:13 redis_socketio.1 |   .-`` .-```.  ```\/    _.,_ ''-._                                   
19:23:13 redis_socketio.1 |  (    '      ,       .-`  | `,    )     Running in standalone mode
19:23:13 redis_socketio.1 |  |`-._`-...-` __...-.``-._|'` _.-'|     Port: 12000
19:23:13 redis_socketio.1 |  |    `-._   `._    /     _.-'    |     PID: 3324
19:23:13 redis_socketio.1 |   `-._    `-._  `-./  _.-'    _.-'                                   
19:23:13 redis_socketio.1 |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
19:23:13 redis_socketio.1 |  |    `-._`-._        _.-'_.-'    |           http://redis.io        
19:23:13 redis_socketio.1 |   `-._    `-._`-.__.-'_.-'    _.-'                                   
19:23:13 redis_socketio.1 |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
19:23:13 redis_socketio.1 |  |    `-._`-._        _.-'_.-'    |                                  
19:23:13 redis_socketio.1 |   `-._    `-._`-.__.-'_.-'    _.-'                                   
19:23:13 redis_socketio.1 |       `-._    `-.__.-'    _.-'                                       
19:23:13 redis_socketio.1 |           `-._        _.-'                                           
19:23:13 redis_socketio.1 |               `-.__.-'                                               
19:23:13 redis_socketio.1 | 
19:23:13 redis_socketio.1 | 3324:M 15 Jun 19:23:13.885 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:23:13 redis_socketio.1 | 3324:M 15 Jun 19:23:13.885 # Server started, Redis version 3.0.6
19:23:13 redis_socketio.1 | 3324:M 15 Jun 19:23:13.885 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
19:23:13 redis_socketio.1 | 3324:M 15 Jun 19:23:13.885 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:23:13 redis_socketio.1 | 3324:M 15 Jun 19:23:13.885 * The server is now ready to accept connections on port 12000
19:23:13 redis_cache.1    | 3344:M 15 Jun 19:23:13.898 * Increased maximum number of open files to 10032 (it was originally set to 1024).
19:23:13 redis_cache.1    |                 _._                                                  
19:23:13 redis_cache.1    |            _.-``__ ''-._                                             
19:23:13 redis_cache.1    |       _.-``    `.  `_.  ''-._           Redis 3.0.6 (00000000/0) 64 bit
19:23:13 redis_cache.1    |   .-`` .-```.  ```\/    _.,_ ''-._                                   
19:23:13 redis_cache.1    |  (    '      ,       .-`  | `,    )     Running in standalone mode
19:23:13 redis_cache.1    |  |`-._`-...-` __...-.``-._|'` _.-'|     Port: 13000
19:23:13 redis_cache.1    |  |    `-._   `._    /     _.-'    |     PID: 3344
19:23:13 redis_cache.1    |   `-._    `-._  `-./  _.-'    _.-'                                   
19:23:13 redis_cache.1    |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
19:23:13 redis_cache.1    |  |    `-._`-._        _.-'_.-'    |           http://redis.io        
19:23:13 redis_cache.1    |   `-._    `-._`-.__.-'_.-'    _.-'                                   
19:23:13 redis_cache.1    |  |`-._`-._    `-.__.-'    _.-'_.-'|                                  
19:23:13 redis_cache.1    |  |    `-._`-._        _.-'_.-'    |                                  
19:23:13 redis_cache.1    |   `-._    `-._`-.__.-'_.-'    _.-'                                   
19:23:13 redis_cache.1    |       `-._    `-.__.-'    _.-'                                       
19:23:13 redis_cache.1    |           `-._        _.-'                                           
19:23:13 redis_cache.1    |               `-.__.-'                                               
19:23:13 redis_cache.1    | 
19:23:13 redis_cache.1    | 3344:M 15 Jun 19:23:13.901 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:23:13 redis_cache.1    | 3344:M 15 Jun 19:23:13.902 # Server started, Redis version 3.0.6
19:23:13 redis_cache.1    | 3344:M 15 Jun 19:23:13.902 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
19:23:13 redis_cache.1    | 3344:M 15 Jun 19:23:13.902 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:23:13 redis_cache.1    | 3344:M 15 Jun 19:23:13.902 * The server is now ready to accept connections on port 13000
19:23:16 socketio.1       | listening on *: 9000
19:23:24 web.1            |  * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
19:23:24 web.1            |  * Restarting with inotify reloader
19:23:26 watch.1          | SyntaxError: Unexpected end of JSON input
19:23:26 watch.1          |     at JSON.parse (<anonymous>)
19:23:26 watch.1          |     at make_build_map (/home/frappe/frappe-bench/apps/frappe/frappe/build.js:193:22)
19:23:26 watch.1          |     at Object.<anonymous> (/home/frappe/frappe-bench/apps/frappe/frappe/build.js:22:17)
19:23:26 watch.1          |     at Module._compile (module.js:652:30)
19:23:26 watch.1          |     at Object.Module._extensions..js (module.js:663:10)
19:23:26 watch.1          |     at Module.load (module.js:565:32)
19:23:26 watch.1          |     at tryModuleLoad (module.js:505:12)
19:23:26 watch.1          |     at Function.Module._load (module.js:497:3)
19:23:26 watch.1          |     at Function.Module.runMain (module.js:693:10)
19:23:26 watch.1          |     at startup (bootstrap_node.js:191:16)
19:23:26 watch.1          | compiling avatar.less
19:23:26 watch.1          | compiling calendar.less
19:23:26 watch.1          | compiling common.less
19:23:26 watch.1          | compiling controls.less
19:23:26 watch.1          | compiling desk.less
19:23:26 watch.1          | compiling desktop.less
19:23:26 watch.1          | compiling docs.less
19:23:26 web.1            |  * Debugger is active!
19:23:26 web.1            |  * Debugger PIN: 233-127-265
19:23:26 watch.1          | compiling email.less
19:23:26 watch.1          | compiling form.less
19:23:26 watch.1          | compiling form_grid.less
19:23:26 watch.1          | compiling gantt.less
19:23:26 watch.1          | compiling indicator.less
19:23:26 watch.1          | compiling kanban.less
19:23:26 watch.1          | compiling list.less
19:23:26 watch.1          | compiling mixins.less
19:23:26 watch.1          | compiling mobile.less
19:23:26 watch.1          | compiling module.less
19:23:27 watch.1          | compiling navbar.less
19:23:27 watch.1          | compiling page.less
19:23:27 watch.1          | compiling report.less
19:23:27 watch.1          | compiling role_editor.less
19:23:27 watch.1          | compiling sidebar.less
19:23:27 watch.1          | compiling slickgrid.less
19:23:27 watch.1          | compiling tags.less
19:23:27 watch.1          | compiling tree.less
19:23:27 watch.1          | compiling website.less
19:23:27 watch.1          | compiling email.less
19:23:27 watch.1          | compiling erpnext.less
19:23:27 watch.1          | compiling hub.less
19:23:27 watch.1          | compiling pos.less
19:23:27 watch.1          | compiling website.less
19:23:27 watch.1          | file watching on *: 6787
19:23:28 watch.1          | Less files compiled
19:23:28 watch.1          | Wrote css/frappe-web.css - 65.43 KB
19:23:29 watch.1          | Wrote js/frappe-web.min.js - 135.24 KB
19:23:29 watch.1          | Wrote js/control.min.js - 81.64 KB
19:23:29 watch.1          | Wrote js/dialog.min.js - 124.27 KB
19:23:29 watch.1          | Wrote css/desk.min.css - 310.98 KB
19:23:29 watch.1          | Wrote css/frappe-rtl.css - 32.73 KB
19:23:29 watch.1          | Wrote js/libs.min.js - 1.13 MB
19:23:29 watch.1          | Wrote js/desk.min.js - 480.66 KB
19:23:29 watch.1          | Wrote css/module.min.css - 2.16 KB
19:23:29 watch.1          | Wrote css/form.min.css - 4.55 KB
19:23:29 watch.1          | Wrote js/form.min.js - 205.64 KB
19:23:29 watch.1          | Wrote css/list.min.css - 13.67 KB
19:23:29 watch.1          | Wrote js/list.min.js - 161.74 KB
19:23:29 watch.1          | Wrote css/report.min.css - 8.31 KB
19:23:29 watch.1          | Wrote js/report.min.js - 262.94 KB
19:23:29 watch.1          | Wrote js/web_form.min.js - 248.66 KB
19:23:29 watch.1          | Wrote css/web_form.css - 24.69 KB
19:23:29 watch.1          | Wrote js/print_format_v3.min.js - 25.87 KB
19:23:29 watch.1          | Wrote frappe_io/js/docs.js - 1.11 KB
19:23:29 watch.1          | Wrote css/erpnext.css - 8.08 KB
19:23:29 watch.1          | Wrote js/erpnext-web.min.js - 4.23 KB
19:23:29 watch.1          | Wrote js/erpnext.min.js - 170.87 KB
19:23:29 watch.1          | Wrote js/item-dashboard.min.js - 8.48 KB
19:23:34 watch.1          | events.js:183
19:23:34 watch.1          |       throw er; // Unhandled 'error' event
19:23:34 watch.1          |       ^
19:23:34 watch.1          | 
19:23:34 watch.1          | Error: watch /home/frappe/frappe-bench/apps/foundation/foundation/www/docs/current/models/stock/packing_slip.html ENOSPC
19:23:34 watch.1          |     at _errnoException (util.js:992:11)
19:23:34 watch.1          |     at FSWatcher.start (fs.js:1382:19)
19:23:34 watch.1          |     at Object.fs.watch (fs.js:1408:11)
19:23:34 watch.1          |     at createFsWatchInstance (/home/frappe/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:37:15)
19:23:34 watch.1          |     at setFsWatchListener (/home/frappe/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:80:15)
19:23:34 watch.1          |     at FSWatcher.NodeFsHandler._watchWithNodeFs (/home/frappe/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:228:14)
19:23:34 watch.1          |     at FSWatcher.NodeFsHandler._handleFile (/home/frappe/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:255:21)
19:23:34 watch.1          |     at FSWatcher.<anonymous> (/home/frappe/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:473:21)
19:23:34 watch.1          |     at FSReqWrap.oncomplete (fs.js:153:5)
19:23:35 system           | watch.1 stopped (rc=0)
19:23:35 system           | sending SIGTERM to redis_socketio.1 (pid 3316)
19:23:35 system           | sending SIGTERM to worker_long.1 (pid 3313)
19:23:35 system           | sending SIGTERM to redis_queue.1 (pid 3308)
19:23:35 system           | sending SIGTERM to web.1 (pid 3320)
19:23:35 system           | sending SIGTERM to schedule.1 (pid 3309)
19:23:35 system           | sending SIGTERM to worker_default.1 (pid 3310)
19:23:35 system           | sending SIGTERM to socketio.1 (pid 3319)
19:23:35 system           | sending SIGTERM to redis_cache.1 (pid 3330)
19:23:35 system           | sending SIGTERM to worker_short.1 (pid 3332)
19:23:35 redis_socketio.1 | 3324:signal-handler (1529079815) Received SIGTERM scheduling shutdown...
19:23:35 worker_long.1    | 19:23:35 Warm shut down requested
19:23:35 redis_queue.1    | 3314:signal-handler (1529079815) Received SIGTERM scheduling shutdown...
19:23:35 system           | schedule.1 stopped (rc=-15)
19:23:35 worker_default.1 | 19:23:35 Warm shut down requested
19:23:35 system           | socketio.1 stopped (rc=-15)
19:23:35 redis_cache.1    | 3344:signal-handler (1529079815) Received SIGTERM scheduling shutdown...
19:23:35 worker_short.1   | 19:23:35 Warm shut down requested
19:23:35 redis_queue.1    | 3314:M 15 Jun 19:23:35.069 # User requested shutdown...
19:23:35 redis_queue.1    | 3314:M 15 Jun 19:23:35.070 # Redis is now ready to exit, bye bye...
19:23:35 system           | redis_queue.1 stopped (rc=-15)
19:23:35 redis_socketio.1 | 3324:M 15 Jun 19:23:35.083 # User requested shutdown...
19:23:35 redis_socketio.1 | 3324:M 15 Jun 19:23:35.083 # Redis is now ready to exit, bye bye...
19:23:35 system           | redis_socketio.1 stopped (rc=-15)
19:23:35 redis_cache.1    | 3344:M 15 Jun 19:23:35.099 # User requested shutdown...
19:23:35 redis_cache.1    | 3344:M 15 Jun 19:23:35.099 # Redis is now ready to exit, bye bye...
19:23:35 system           | redis_cache.1 stopped (rc=-15)
19:23:35 system           | worker_long.1 stopped (rc=-15)
19:23:35 system           | worker_default.1 stopped (rc=-15)
19:23:35 system           | worker_short.1 stopped (rc=-15)
19:23:35 web.1            | Exception in thread Thread-1 (most likely raised during interpreter shutdown):
19:23:35 web.1            | Traceback (most recent call last):
19:23:35 web.1            |   File "/usr/lib/python2.7/threading.py", line 801, in __bootstrap_inner
19:23:35 web.1            |   File "/usr/lib/python2.7/threading.py", line 754, in run
19:23:35 web.1            |   File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py", line 777, in inner
19:23:35 web.1            |   File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py", line 612, in serve_forever
19:23:35 web.1            |   File "/usr/lib/python2.7/SocketServer.py", line 236, in serve_forever
19:23:35 web.1            |   File "/usr/lib/python2.7/threading.py", line 585, in set
19:23:35 web.1            |   File "/usr/lib/python2.7/threading.py", line 407, in notifyAll
19:23:35 web.1            | <type 'exceptions.TypeError'>: 'NoneType' object is not callable
19:23:35 system           | web.1 stopped (rc=-15)

The most commonly accepted reply/fix for this is here…

FWIW in a similar case of ‘many files to watch’ VS advises the same remedy https://code.visualstudio.com/docs/setup/linux#_visual-studio-code-is-unable-to-watch-for-file-changes-in-this-large-workspace-error-enospc

1 Like

Ah yes - a microsoft strategy that is not fussed about using 512MB of RAM - very surprising indeed :rofl::joy: