Error when trying to open System Settngs

I receive an error while trying to open the System Settings.

It has something to do with the Locale argument “sep”

I am using the Dutch translation of ERPNext on a fresh local virtualization install.

I will try looking in to, but my debuging skills are very limited. Any help is welcome.

Traceback (innermost last):
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 51, in application
        response = frappe.handler.handle()
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 62, in handle
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 85, in execute_cmd
        ret =, **frappe.form_dict)
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 709, in call
        return fn(*args, **newargs)
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/desk/form/", line 63, in getdoctype
        docs = get_meta_bundle(doctype)
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/desk/form/", line 73, in get_meta_bundle
        bundle = [frappe.desk.form.meta.get_meta(doctype)]
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/desk/form/", line 24, in get_meta
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/desk/form/", line 180, in set_translations
        self.set("__messages", frappe.get_lang_dict("doctype",
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 55, in get_lang_dict
        return get_dict(fortype, name)
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 115, in get_dict
        translation_assets[asset_key].update(get_dict_from_hooks(fortype, name))
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 128, in get_dict_from_hooks
      File "/home/erpnext/frappe-bench/apps/frappe/frappe/geo/", line 34, in get_translated_dict
        locale = Locale(frappe.local.lang, sep="-")
     TypeError: __init__() got an unexpected keyword argument 'sep'

Tried changing seperator sep="-" to sep="_" It did not help.
Tried changing translated_dict.update(frappe.get_attr(method)()) to translated_dict.update(frappe.get_attr(method))

i though the () were not necessary, not sure…
did not help either. Any other suggestions?

Thanks for reporting. Pushed now.

@rmehta Does this mean it is already implemented, or that it will be with the next release?

Just run bench update and it should be fixed