Error when config "developer_mode": 1

I have a error. When i set up “develop_mode”

To create models, you must set developer_mode as 1 in the site_config.json file.
{
“db_name”: “library”,
“db_password”: “v3qHDeVKvWVi7s97”,
“developer_mode”: 1
}

but I have a error.
i can’t start or restart bench .

RuntimeError

RuntimeError: no object bound to conf

Traceback (most recent call last)

File “/root/frappe-bench/apps/frappe/frappe/middlewares.py”,
line 15,
in call
return super(StaticDataMiddleware, self).call(environ, start_response)

File “/root/frappe-bench/env/lib/python2.7/site-packages/werkzeug/wsgi.py”,
line 588,
in call
return self.app(environ, start_response)

File “/root/frappe-bench/env/lib/python2.7/site-packages/werkzeug/wsgi.py”,
line 588,
in call
return self.app(environ, start_response)

File “/root/frappe-bench/env/lib/python2.7/site-packages/werkzeug/local.py”,
line 224,
in application
return ClosingIterator(app(environ, start_response), self.cleanup)

File “/root/frappe-bench/env/lib/python2.7/site-packages/werkzeug/wrappers.py”,
line 286,
in application
return f(*args[:-2] + (request,))(*args[-2:])

File “/root/frappe-bench/apps/frappe/frappe/app.py”,
line 78,
in application
response = frappe.website.render.render(“message”, http_status_code=http_status_code)

File “/root/frappe-bench/apps/frappe/frappe/website/render.py”,
line 47,
in render
data = render_page(path)

File “/root/frappe-bench/apps/frappe/frappe/website/render.py”,
line 96,
in render_page
if can_cache():

File “/root/frappe-bench/apps/frappe/frappe/website/utils.py”,
line 29,
in can_cache
return not (frappe.conf.disable_website_cache or no_cache)

File “/root/frappe-bench/env/lib/python2.7/site-packages/werkzeug/local.py”,
line 338,
in getattr
return getattr(self._get_current_object(), name)

File “/root/frappe-bench/env/lib/python2.7/site-packages/werkzeug/local.py”,
line 301,
in _get_current_object
raise RuntimeError(‘no object bound to %s’ % self.name)

RuntimeError: no object bound to conf

Seems like something else is broken too. Have you changed anything else?

I haven’t anything else. I installed frappe-bench, then I installed ERPNext from website: https://github.com/frappe/bench. then I created a ModeType, When I created a Doctype and Saved it. But It request me Enable “Developer_mode”: 1. and I enabled “Developer_mode”: 1 in the site_config.json file. But I can’t run bench and It error. I don’t know so. when I came back. It run simple.

If you revert developer_mode, does it work?

Yes. I revert developer_mode. it work. I tried working with a few virtual machines which installed frappe. It always can’t run if i set developer_mode. Do i have to config diffirent files ?. Thank you!

This is particularly strange. The VM uses Bench which is the standard development / deployment environment.

@pdvyas can you have a look?

Thank you. I sorry. I forgot add “,” then “developer_mode”:1.