[ERROR] Products page "missing or moved"

This is referring to the website portion of ERPNext- I have some products and so they show on the main page when visited by a user that is not logged in. However, when I click on the “products” link, it says:

“Page missing or moved
We are very sorry for this, but the page you are looking for is missing (this could be because of a typo in the address) or moved.”

How can I fix this?

Maybe this might help?

On your desktop (the screen I log into with the buttons to access all the apps) click:

Then Click “Item Group” in the Stock screen:

In the Item Group Tree click on “Products” and the little gray buttons appear:

Click “edit”.

This screen the appears:

Click "Show in Website"
Then Save that screen.
Refresh your site and see what happens.

2 Likes

“Show in Website” is already checked

And your item is checked “show in website”?
Like this:

Though when I uncheck that box on my setup the item just doesn’t show up. I do not receive your error message. I only see that when I uncheck the Item Group-show in web site box.

What is the Item Group of the product your trying to see?

How did you get that to happen?
I have added items and they only show under the products link. My homepage is still just the default Lorem Ipsum text.

1 Like

@orionstars which version are you using?

That dead link issue also happened to me. I accidentially deleted the “Products”-group while rearranging my item group structure.

Below that checkbox that says “show in website” there is a “Route”-textbox in which you have to enter the word products, then save that and try again.

The products on @rogueaustin’s main page are probably showed by the new experimental Portal/Homepage feature of V7. You can disable that by creating a ordinary Website (just be sure that it’s name is not “home”) and defining that website as landing page in the website general settings.

If you have any further questions, please ask :wink:

1 Like

@seteq: This is my version ERPNext: v6.27.26

I am using the free, single user service that Frappe/ERPNext offers.

1 Like

@orionstars that’s why you don’t have the portal/homepage feature (yet)… :wink:

For me, the issue was the URL for products in Website settings. Was /products but had to be /all-item-groups/products

Good luck.

1 Like