Error on upgradation v6-v7

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-G945ZV/frappe/
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==3.0.0’, ‘console_scripts’, ‘bench’)()
File “/home/ubuntu/bench-repo/bench/cli.py”, line 40, in cli
bench_command()
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 716, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 696, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 534, in invoke
return callback(*args, **kwargs)
File “/home/ubuntu/bench-repo/bench/commands/update.py”, line 60, in update
_update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, upgrade, force=force)
File “/home/ubuntu/bench-repo/bench/commands/update.py”, line 79, in _update
update_requirements(bench_path=bench_path)
File “/home/ubuntu/bench-repo/bench/utils.py”, line 375, in update_requirements
install_requirements(pip, req_file)
File “/home/ubuntu/bench-repo/bench/utils.py”, line 379, in install_requirements
exec_cmd("{pip} install -q -r {req_file}".format(pip=pip, req_file=req_file))
File “/home/ubuntu/bench-repo/bench/utils.py”, line 127, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: ./env/bin/pip install -q -r ./apps/erpnext/requirements.txt

Try this answer

not working

Run this

./env/bin/pip install -q -r ./apps/erpnext/requirements.txt

and see what error comes up.

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-H_rkZf/frappe/

sudo pip install frappe

InsecurePlatformWarning
Downloading frappe-2.1.4.tar.gz (217kB)
100% |████████████████████████████████| 225kB 374kB/s
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-build-qC7oHS/frappe/setup.py”, line 10, in
raise LookupError(“You must have test.fm >= 1.0.4 installed before (https://github.com/grafos-ml/frappe)”)
LookupError: You must have test.fm >= 1.0.4 installed before (https://github.com/grafos-ml/frappe)

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-qC7oHS/frappe/

issue solved by runnning

./env/bin/pip install -e ./apps/frappe
sudo apt-get install libsasl2-dev python-dev libldap2-dev libssl-dev

2 Likes