Error: Node Sass does not yet support your current environment: Linux 64-bit with Unsupported runtime (83)

error while updating from 12 to 13
Error: Node Sass does not yet support your current environment: Linux 64-bit with Unsupported runtime (83)

Hi,

It may help to say what operating environment and the commands being used to perform the upgrade.

ok I restored a snapshot, reran bench update, installed nodejs 10 and then got a successful upgrade to v13

now when loading shop pages I get popup saying

Failed to get method for command frappe.website.doctype.website_settings.website_settings.is_chat_enabled with module ‘frappe.website.doctype.website_settings.website_settings’ has no attribute ‘is_chat_enabled’

also I went to the website settings and made an edit and tried to save and now it says I cant have over 10 attachments to the page. (I have some custom js files attached as well as images)

this is on a virtual machine image from ERPNext original v12 ubuntu 18.04

cleared browser cache and it went away haha

Just for future readers.

The version of Node.js on your device has a direct impact on what Node-Sass you must use.
Here’s a link: https://www.npmjs.com/package/node-sass

To find the version of Node you’ve installed, type this in a terminal:

node -v

Knowing your version, look that up in the link I shared.

For example, my laptop is running Node v14.15.4. So I need Node-Sass 4.14+.
But some of my cloud VPS are using much-newer versions of Node, like v16. So they need Node-Sass 6.0+.

When you install Frappe framework, the 'package.json' and 'yarn.lock' files are provided for you. The Node-Sass specified inside those files may not be what you need, for your device.

In which case, manually install the correct Node-Sass using yarn.

5 Likes