Error Installing production of ERPNEXT

NO MORE HOSTS LEFT *************************************************************
to retry, use: --limit @production/install.retry

PLAY RECAP *********************************************************************
localhost : ok=38 changed=21 unreachable=0 failed=1

Traceback (most recent call last):
File “install.py”, line 351, in
install_bench(args)
File “install.py”, line 111, in install_bench
run_playbook(‘production/install.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 301, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/subprocess.py”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘pro duction/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user= frappe’]’ returned non-zero exit status 2

I’ve installed 2 hours ago and didn’t get any problem.

On what distribution are u installing? And what server?

This is Ubuntu 16. I remove and install on 14 and it now working. It seam like the script only for for 14 with product install.

I’ve installed in 16 LTS without any problem …by the way 14 is ok as well

Hello am still getting this error when installing.

TASK [Install production pre-requisites] ***************************************
failed: [localhost] (item=[u’nginx’, u’screen’, u’vim’, u’htop’, u’git’, u’postf ix’, u’supervisor’]) => {“cache_update_time”: 0, “cache_updated”: false, “failed “: true, “item”: [“nginx”, “screen”, “vim”, “htop”, “git”, “postfix”, “superviso r”], “msg”: “’/usr/bin/apt-get -y -o “Dpkg::Options::=–force-confdef” -o “Dp kg::Options::=–force-confold” install ‘nginx’ ‘htop’ ‘supervisor’’ failed: E : Sub-process /usr/bin/dpkg returned an error code (1)\n”, “stderr”: “E: Sub-pro cess /usr/bin/dpkg returned an error code (1)\n”, “stdout”: “Reading package lis ts…\nBuilding dependency tree…\nReading state information…\nThe following extra packages will be installed:\n libgd3 libvpx2 libxslt1.1 nginx-common ngin x-core python-meld3\nSuggested packages:\n strace ltrace libgd-tools fcgiwrap n ginx-doc\nThe following NEW packages will be installed:\n htop libgd3 libvpx2 l ibxslt1.1 nginx nginx-common nginx-core python-meld3\n supervisor\n0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.\nNeed to get 1712 kB of archi ves.\nAfter this operation, 6284 kB of additional disk space will be used.\nGet: 1 http://archive.ubuntu.com/ubuntu/ wily/main libxslt1.1 amd64 1.1.28-2build2 [1 47 kB]\nGet:2 http://archive.ubuntu.com/ubuntu/ wily/universe htop amd64 1.0.3-1 [65.3 kB]\nGet:3 http://archive.ubuntu.com/ubuntu/ wily/main libvpx2 amd64 1.4. 0-4 [688 kB]\nGet:4 http://archive.ubuntu.com/ubuntu/ wily-updates/main libgd3 a md64 2.1.1-4ubuntu0.15.10.2 [125 kB]\nGet:5 http://archive.ubuntu.com/ubuntu/ wi ly-updates/main nginx-common all 1.9.3-1ubuntu1.2 [26.7 kB]\nGet:6 http://archiv e.ubuntu.com/ubuntu/ wily-updates/main nginx-core amd64 1.9.3-1ubuntu1.2 [382 kB ]\nGet:7 http://archive.ubuntu.com/ubuntu/ wily-updates/main nginx all 1.9.3-1ub untu1.2 [3484 B]\nGet:8 http://archive.ubuntu.com/ubuntu/ wily/universe python-m eld3 amd64 1.0.2-1 [30.8 kB]\nGet:9 http://archive.ubuntu.com/ubuntu/ wily/unive rse supervisor all 3.0r1-1 [244 kB]\nFetched 1712 kB in 2s (741 kB/s)\nSelecting previously unselected package libxslt1.1:amd64.\r\n(Reading database … \r(Rea ding database … 5%\r(Reading database … 10%\r(Reading database … 15%\r(Rea ding database … 20%\r(Reading database … 25%\r(Reading database … 30%\r(Re ading database … 35%\r(Reading database … 40%\r(Reading database … 45%\r(R eading database … 50%\r(Reading database … 55%\r(Reading database … 60%\r( Reading database … 65%\r(Reading database … 70%\r(Reading database … 75%\r (Reading database … 80%\r(Reading database … 85%\r(Reading database … 90%\ r(Reading database … 95%\r(Reading database … 100%\r(Reading database … 44 089 files and directories currently installed.)\r\nPreparing to unpack …/libxs lt1.1_1.1.28-2build2_amd64.deb …\r\nUnpacking libxslt1.1:amd64 (1.1.28-2build2 ) …\r\nSelecting previously unselected package htop.\r\nPreparing to unpack … ./htop_1.0.3-1_amd64.deb …\r\nUnpacking htop (1.0.3-1) …\r\nSelecting previo usly unselected package libvpx2:amd64.\r\nPreparing to unpack …/libvpx2_1.4.0- 4_amd64.deb …\r\nUnpacking libvpx2:amd64 (1.4.0-4) …\r\nSelecting previously unselected package libgd3:amd64.\r\nPreparing to unpack …/libgd3_2.1.1-4ubunt u0.15.10.2_amd64.deb …\r\nUnpacking libgd3:amd64 (2.1.1-4ubuntu0.15.10.2) …\ r\nSelecting previously unselected package nginx-common.\r\nPreparing to unpack …/nginx-common_1.9.3-1ubuntu1.2_all.deb …\r\nUnpacking nginx-common (1.9.3-1 ubuntu1.2) …\r\nSelecting previously unselected package nginx-core.\r\nPrepari ng to unpack …/nginx-core_1.9.3-1ubuntu1.2_amd64.deb …\r\nUnpacking nginx-co re (1.9.3-1ubuntu1.2) …\r\nSelecting previously unselected package nginx.\r\nP reparing to unpack …/nginx_1.9.3-1ubuntu1.2_all.deb …\r\nUnpacking nginx (1. 9.3-1ubuntu1.2) …\r\nSelecting previously unselected package python-meld3.\r\n Preparing to unpack …/python-meld3_1.0.2-1_amd64.deb …\r\nUnpacking python-m eld3 (1.0.2-1) …\r\nSelecting previously unselected package supervisor.\r\nPre paring to unpack …/supervisor_3.0r1-1_all.deb …\r\nUnpacking supervisor (3.0 r1-1) …\r\nProcessing triggers for man-db (2.7.4-1) …\r\nProcessing triggers for mime-support (3.58ubuntu1) …\r\nProcessing triggers for systemd (225-1ubu ntu9.1) …\r\nSetting up libxslt1.1:amd64 (1.1.28-2build2) …\r\nSetting up ht op (1.0.3-1) …\r\nSetting up libvpx2:amd64 (1.4.0-4) …\r\nSetting up libgd3: amd64 (2.1.1-4ubuntu0.15.10.2) …\r\nSetting up nginx-common (1.9.3-1ubuntu1.2) …\r\nSetting up nginx-core (1.9.3-1ubuntu1.2) …\r\nJob for nginx.service fa iled because the control process exited with error code. See “systemctl status nginx.service” and “journalctl -xe” for details.\r\ninvoke-rc.d: initscript n ginx, action “start” failed.\r\ndpkg: error processing package nginx-core (–c onfigure):\r\n subprocess installed post-installation script returned error exit status 1\r\ndpkg: dependency problems prevent configuration of nginx:\r\n nginx depends on nginx-core (>= 1.9.3-1ubuntu1.2) | nginx-full (>= 1.9.3-1ubuntu1.2) | nginx-light (>= 1.9.3-1ubuntu1.2) | nginx-extras (>= 1.9.3-1ubuntu1.2); howeve r:\r\n Package nginx-core is not configured yet.\r\n Package nginx-full is not installed.\r\n Package nginx-light is not installed.\r\n Package nginx-extras is not installed.\r\n nginx depends on nginx-core (<< 1.9.3-1ubuntu1.2.1~) | ng inx-full (<< 1.9.3-1ubuntu1.2.1~) | nginx-light (<< 1.9.3-1ubuntu1.2.1~) | nginx -extras (<< 1.9.3-1ubuntu1.2.1~); however:\r\n Package nginx-core is not config ured yet.\r\n Package nginx-full is not installed.\r\n Package nginx-light is not installed.\r\n Package nginx-extras is not installed.\r\n\r\ndpkg: error pr ocessing package nginx (–configure):\r\n dependency problems - leaving unconfig ured\r\nSetting up python-meld3 (1.0.2-1) …\r\nSetting up supervisor (3.0r1-1) …\r\nProcessing triggers for libc-bin (2.21-0ubuntu4.3) …\r\nProcessing tri ggers for systemd (225-1ubuntu9.1) …\r\nErrors were encountered while processi ng:\r\n nginx-core\r\n nginx\r\n”, “stdout_lines”: [“Reading package lists…”, “Building dependency tree…”, “Reading state information…”, “The following ex tra packages will be installed:”, " libgd3 libvpx2 libxslt1.1 nginx-common ngin x-core python-meld3”, “Suggested packages:”, " strace ltrace libgd-tools fcgiwr ap nginx-doc”, “The following NEW packages will be installed:”, " htop libgd3 l ibvpx2 libxslt1.1 nginx nginx-common nginx-core python-meld3", " supervisor", " 0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.", “Need to get 17 12 kB of archives.”, “After this operation, 6284 kB of additional disk space wil l be used.”, “Get:1 http://archive.ubuntu.com/ubuntu/ wily/main libxslt1.1 amd64 1.1.28-2build2 [147 kB]”, “Get:2 http://archive.ubuntu.com/ubuntu/ wily/univers e htop amd64 1.0.3-1 [65.3 kB]”, “Get:3 http://archive.ubuntu.com/ubuntu/ wily/m ain libvpx2 amd64 1.4.0-4 [688 kB]”, “Get:4 http://archive.ubuntu.com/ubuntu/ wi ly-updates/main libgd3 amd64 2.1.1-4ubuntu0.15.10.2 [125 kB]”, “Get:5 http://arc hive.ubuntu.com/ubuntu/ wily-updates/main nginx-common all 1.9.3-1ubuntu1.2 [26. 7 kB]”, “Get:6 http://archive.ubuntu.com/ubuntu/ wily-updates/main nginx-core am d64 1.9.3-1ubuntu1.2 [382 kB]”, “Get:7 http://archive.ubuntu.com/ubuntu/ wily-up dates/main nginx all 1.9.3-1ubuntu1.2 [3484 B]”, “Get:8 http://archive.ubuntu.co m/ubuntu/ wily/universe python-meld3 amd64 1.0.2-1 [30.8 kB]”, “Get:9 http://arc hive.ubuntu.com/ubuntu/ wily/universe supervisor all 3.0r1-1 [244 kB]”, “Fetched 1712 kB in 2s (741 kB/s)”, “Selecting previously unselected package libxslt1.1: amd64.”, “(Reading database … “, “(Reading database … 5%”, “(Reading databas e … 10%”, “(Reading database … 15%”, “(Reading database … 20%”, “(Reading database … 25%”, “(Reading database … 30%”, “(Reading database … 35%”, “(R eading database … 40%”, “(Reading database … 45%”, “(Reading database … 50 %”, “(Reading database … 55%”, “(Reading database … 60%”, “(Reading database … 65%”, “(Reading database … 70%”, “(Reading database … 75%”, “(Reading d atabase … 80%”, “(Reading database … 85%”, “(Reading database … 90%”, “(Re ading database … 95%”, “(Reading database … 100%”, “(Reading database … 44 089 files and directories currently installed.)”, “Preparing to unpack …/libxs lt1.1_1.1.28-2build2_amd64.deb …”, “Unpacking libxslt1.1:amd64 (1.1.28-2build2 ) …”, “Selecting previously unselected package htop.”, “Preparing to unpack … ./htop_1.0.3-1_amd64.deb …”, “Unpacking htop (1.0.3-1) …”, “Selecting previo usly unselected package libvpx2:amd64.”, “Preparing to unpack …/libvpx2_1.4.0- 4_amd64.deb …”, “Unpacking libvpx2:amd64 (1.4.0-4) …”, “Selecting previously unselected package libgd3:amd64.”, “Preparing to unpack …/libgd3_2.1.1-4ubunt u0.15.10.2_amd64.deb …”, “Unpacking libgd3:amd64 (2.1.1-4ubuntu0.15.10.2) …” , “Selecting previously unselected package nginx-common.”, “Preparing to unpack …/nginx-common_1.9.3-1ubuntu1.2_all.deb …”, “Unpacking nginx-common (1.9.3-1 ubuntu1.2) …”, “Selecting previously unselected package nginx-core.”, “Prepari ng to unpack …/nginx-core_1.9.3-1ubuntu1.2_amd64.deb …”, “Unpacking nginx-co re (1.9.3-1ubuntu1.2) …”, “Selecting previously unselected package nginx.”, “P reparing to unpack …/nginx_1.9.3-1ubuntu1.2_all.deb …”, “Unpacking nginx (1. 9.3-1ubuntu1.2) …”, “Selecting previously unselected package python-meld3.”, " Preparing to unpack …/python-meld3_1.0.2-1_amd64.deb …”, “Unpacking python-m eld3 (1.0.2-1) …”, “Selecting previously unselected package supervisor.”, “Pre paring to unpack …/supervisor_3.0r1-1_all.deb …”, “Unpacking supervisor (3.0 r1-1) …”, “Processing triggers for man-db (2.7.4-1) …”, “Processing triggers for mime-support (3.58ubuntu1) …”, “Processing triggers for systemd (225-1ubu ntu9.1) …”, “Setting up libxslt1.1:amd64 (1.1.28-2build2) …”, “Setting up ht op (1.0.3-1) …”, “Setting up libvpx2:amd64 (1.4.0-4) …”, “Setting up libgd3: amd64 (2.1.1-4ubuntu0.15.10.2) …”, “Setting up nginx-common (1.9.3-1ubuntu1.2) …”, “Setting up nginx-core (1.9.3-1ubuntu1.2) …”, “Job for nginx.service fa iled because the control process exited with error code. See “systemctl status nginx.service” and “journalctl -xe” for details.”, “invoke-rc.d: initscript n ginx, action “start” failed.”, “dpkg: error processing package nginx-core (–c onfigure):”, " subprocess installed post-installation script returned error exit status 1”, “dpkg: dependency problems prevent configuration of nginx:”, " nginx depends on nginx-core (>= 1.9.3-1ubuntu1.2) | nginx-full (>= 1.9.3-1ubuntu1.2) | nginx-light (>= 1.9.3-1ubuntu1.2) | nginx-extras (>= 1.9.3-1ubuntu1.2); howeve r:", " Package nginx-core is not configured yet.", " Package nginx-full is not installed.", " Package nginx-light is not installed.", " Package nginx-extras is not installed.", " nginx depends on nginx-core (<< 1.9.3-1ubuntu1.2.1~) | ng inx-full (<< 1.9.3-1ubuntu1.2.1~) | nginx-light (<< 1.9.3-1ubuntu1.2.1~) | nginx -extras (<< 1.9.3-1ubuntu1.2.1~); however:", " Package nginx-core is not config ured yet.", " Package nginx-full is not installed.", " Package nginx-light is not installed.", " Package nginx-extras is not installed.", “”, “dpkg: error pr ocessing package nginx (–configure):”, " dependency problems - leaving unconfig ured", “Setting up python-meld3 (1.0.2-1) …”, “Setting up supervisor (3.0r1-1) …”, “Processing triggers for libc-bin (2.21-0ubuntu4.3) …”, “Processing tri ggers for systemd (225-1ubuntu9.1) …”, “Errors were encountered while processi ng:”, " nginx-core", " nginx"]}

NO MORE HOSTS LEFT *************************************************************
to retry, use: --limit @production/install.retry

PLAY RECAP *********************************************************************
localhost : ok=38 changed=21 unreachable=0 failed=1

Traceback (most recent call last):
File “install.py”, line 351, in
install_bench(args)
File “install.py”, line 111, in install_bench
run_playbook(‘production/install.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 301, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/subprocess.py”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘pro duction/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user= frappe’]’ returned non-zero

Am running Ubuntu 15.10

Try to install on Ubuntu 14 or 16 release

It works on 14 or 16 not issues, but on 15 it does not work. Why would that be and how can I fix the issue.

use 16 LTS …no sense to use 15 …