Error installing last ERPNext develop version from scratch

In this similar problem last month, jsukrut suggested a ‘bench reinstall’

This reports the problem has to do with ‘Py_Finalize wipes all globals while there are still daemon threads running’ and will not be fixed in 2.7…

http://bugs.python.org/issue14623

Sadly, it seems like a good number of users are experiencing this one. If reinstall doesn’t work, I think installing a previous version might be better.

Thx, it worked running also:

bench clear-cache

2 Likes

Anyone get to the bottom of the please let us know.

@kolate_sambhaji did you check the error log table of the site we created?

Also lots of users seem to be having problems with the fresh install.

Ok, i finally made all work, steps:

  1. install ubuntu

  2. install bench and frappe, erpnext

  3. run npm install babel-core less chokidar babel-preset-es2015 babel-preset-es2016 babel-preset-es2017 babel-preset-babili

  4. create bench new-site [sitename] && bench install-app erpnext

  5. run bench --site [sitename] reinstall

  6. clean the cache, bench clear-cache

  7. finally run setup wizard

not working

Did you clean the cache?

@JoEz
Yes I did

Worked for me…

@rmehta there is no error in error log, I ma checking this,
But after running following command, we can complete setup wizard.

npm install babel-core less chokidar babel-preset-es2015 babel-preset-es2016 babel-preset-es2017 babel-preset-babili

@kolate_sambhaji
frappe@localhost:/root$ cd ~/frappe-bench
frappe@localhost:~/frappe-bench$ npm install babel-core less chokidar babel-preset-es2015 babel-preset-es2016 babel-preset-es2017 babel-preset-babili
/home/frappe/frappe-bench
├── babel-core@6.24.1
├── babel-preset-babili@0.0.12
├── babel-preset-es2015@6.24.1
├── babel-preset-es2016@6.24.1
├── babel-preset-es2017@6.24.1
├── chokidar@1.7.0
└── less@2.7.2

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.1: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm WARN enoent ENOENT: no such file or directory, open ‘/home/frappe/frappe-bench/package.json’
npm WARN frappe-bench No description
npm WARN frappe-bench No repository field.
npm WARN frappe-bench No README data
npm WARN frappe-bench No license field.
frappe@localhost:~/frappe-bench$

I have faced the same error multiple times, both with 7.x and 8.x. I have reported it under “There were errors” message while configuring ERPNext. In fact, I wasn’t able to get the setup wizard working first time even once without this error. It generally used to work after several attempts, however failed completely 2 weeks back. This never happened on a production setup,so something specific to development setup.

Anyone got this solved? …i’m facing this again …

could someone please test a clean installation on ubuntu and double check?

update:

17:19:54 web.1            |  * Detected change in '/home/frappe/frappe-bench/apps/frappe/frappe/desk/doctype/todo/__init__.py', reloading
17:19:54 web.1            | INFO:werkzeug: * Detected change in '/home/frappe/frappe-bench/apps/frappe/frappe/desk/doctype/todo/__init__.py', reloading
17:19:54 web.1            |  * Detected change in '/home/frappe/frappe-bench/apps/frappe/frappe/desk/doctype/todo/__init__.py', reloading
17:19:54 web.1            | INFO:werkzeug: * Detected change in '/home/frappe/frappe-bench/apps/frappe/frappe/desk/doctype/todo/__init__.py', reloading
17:19:54 web.1            |  * Detected change in '/home/frappe/frappe-bench/apps/frappe/frappe/desk/doctype/todo/todo.py', reloading
17:19:54 web.1            | INFO:werkzeug: * Detected change in '/home/frappe/frappe-bench/apps/frappe/frappe/desk/doctype/todo/todo.py', reloading
17:19:54 web.1            |  * Detected change in '/home/frappe/frappe-bench/apps/frappe/frappe/desk/doctype/todo/todo.py', reloading
17:19:54 web.1            | INFO:werkzeug: * Detected change in '/home/frappe/frappe-bench/apps/frappe/frappe/desk/doctype/todo/todo.py', reloading
17:19:55 web.1            | Exception in thread Thread-15 (most likely raised during interpreter shutdown):Exception in thread Thread-2 (most likely raised during interpreter shutdown):
17:19:55 web.1            | Traceback (most recent call last):
17:19:55 web.1            |   File "/usr/lib/python2.7/threading.py", line 801, in __bootstrap_inner
17:19:55 web.1            |   File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/watchdog/observers/api.py", line 237, in run
17:19:55 web.1            | <type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'Empty'
17:19:55 web.1            |
17:19:55 web.1            | Traceback (most recent call last):
17:19:55 web.1            |   File "/usr/lib/python2.7/threading.py", line 801, in __bootstrap_inner
17:19:55 web.1            |   File "/usr/lib/python2.7/threading.py", line 754, in run
17:19:55 web.1            |   File "/usr/lib/python2.7/SocketServer.py", line 599, in process_request_thread
17:19:55 web.1            |   File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py", line 548, in handle_error
17:19:55 web.1            | <type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'handle_error'

Why is detecting changes in todo.py?

Hi all, i have installed a new ERP Next on a clean ubuntu 16 LTS install, it get stuck on erpnext set up wizard.

Hi @ManishKumar,

Have you tried following the steps @JoEz posted here: Error installing last ERPNext develop version from scratch ?

Clear cache usually works. If not, you can try doing the steps for Manual Install. But first, try out JoEz’s steps. :slight_smile:

it seems doesn’t work anymore …

I think it’s a case to case basis. :slight_frown:
Clear cache works half of the time but for other cases, you’ll have to install something or update something.

@littlehera @ManishKumar i finally has been able to complete setup-wizard …keep running bench clear-cache every time it get stuck, until it will succeed

1 Like

Running into the same issue here.

When using bench clear-cache I got to the point where it created the Accounts but then it was stuck again. Guess that’s about the end. But I’m unable to complete the setup wizard.

Maybe build in a way to skip it? At least for development.

// EDIT:

Same for just the frappe setup wizard. I ran bench clear-cache and changed the name of the new user, twice, because then it complained that the same user already exists. After that I could complete the setup.