Error installing ERPNext on Ubuntu 19.10

Team,

Good day. Im having errors installing erp on Ubuntu 19.10 fresh install server.
I’m using the Easy Script --> https://github.com/frappe/bench

The error i got is these====

Traceback (most recent call last):
File “install.py”, line 437, in
install_bench(args)
File “install.py”, line 241, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 362, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’), stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.7/subprocess.py”, line 363, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2.

Can someone please help.

I have been using this script for sometime and its been running fine until yesterday.

Thanks in advance.

there must be an error log dump made under a file name mentioned along with this output. Perhaps you’d need to go through that or share it so that we can help

Possibly a duplicate of this ERPNext install fails for Ubuntu 16 due to ansible missing

We see issues with the install.py at the moment in various places, always failing with the same trace without details

Traceback (most recent call last):
File “install.py”, line 437, in
install_bench(args)
File “install.py”, line 241, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 362, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’), stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.7/subprocess.py”, line 363, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2.

It seems like some sort of dependency issue…

Thanks for the response [gavindsouza] & [lasalesi]. I made a mistake earlier I thought I was
running the easy script on Ubuntu 18.04 server but I was actually doing it on a Ubuntu 19.10 server version maybe thats the reason for the errors.

Right now now Im doing it again but on a 18.04 server version and so far no error at this time. Hopefully this would end up successfully like the previous install I did before.

I will keep you guys posted.

Thanks again for always helping out newbies like me.

I have successfully completed the installation of erpnext with no errors.

Its confirmed that the errors i got was because of the ubuntu 19.10 version running on the server. Its seems the easy install script I used was still not compatible with version 19.10

Hope this helps to some future installs you will be doing.

Thanks again for the community. Always ready and willing to give their help and support. Until next time brothers. This issue is now close.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.