ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

Error install ERPNext on MacOS High Sierra

MACOS: High Sierra 10.13.6
Python: 2.7.10
Homebrew 2.1.4
Node.js v12.3.1.
redis 5.0.5

I am installing ERPNext according to this manual.

But an error occurred when I ran the following command:
bench init frappe-bench

The error message is as follows, can anyone help me? Thanks!

Updating node packages...
INFO:bench.utils:yarn install
yarn install v1.16.0
[1/4] 🔍  Resolving packages...
[2/4] 🚚  Fetching packages...
[3/4] 🔗  Linking dependencies...
warning " > bootstrap@4.3.1" has unmet peer dependency "jquery@1.9.1 - 3".
warning " > bootstrap@4.3.1" has unmet peer dependency "popper.js@^1.14.7".
[4/4] 🔨  Building fresh packages...
[1/2] ⠂ cypress
error /Users/fei-u001/Development/frappe-bench/apps/frappe/node_modules/node-sass: Command failed.
Exit code: 1
Command: node scripts/build.js
Arguments: 
Directory: /Users/fei-u001/Development/frappe-bench/apps/frappe/node_modules/node-sass
Output:
Building: /usr/local/bin/node /Users/fei-u001/Development/frappe-bench/apps/frappe/node_modules/node-gyp/bin/node-gyp.js rebuild --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library=
gyp info it worked if it ends with ok
gyp verb cli [

Perhaps either of these may give you clues