Error at: Create a new bench

Hello, I’m very new to this and I was manually installing ERPNext until the step where I need to create a new bench. I was following the steps given on https://github.com/frappe/bench and here what I’m getting as error when I type “bench init frappe-bench && cd frappe-bench”. Would you kindly please assist me with this error?
I am running Ubuntu 14.04.2 (trusty) LTS

Have you libmysqlclient-dev or libmariadbclient-dev installed?

When I run sudo apt-get install libmariadbclient-dev I have this error
The following packages have unmet dependencies:
libmariadbclient-dev : Depends: libmariadbclient18 (= 5.5.56-1ubuntu0.14.04.1)
E: Unable to correct problems, you have held broken packages.

When I run sudo apt-get install libmysqlclient-dev I have this error
The following packages have unmet dependencies:
libmysqlclient-dev : Depends: libmysqlclient18 (= 5.5.57-0ubuntu0.14.04.1)
E: Unable to correct problems, you have held broken packages…

Try to install mariadb client by hand with ‘apt install mariadb-client’

And do an apt-get update && apt-get upgrade, appears that you have broken dependences.

But I have installed already mariadb at the begining

But you have there mariadb version 10.2 but libmariadbclient-dev are looking by dependences for mariadb 5.5. I don’t known if you are using backports, but ubuntu trusty appears doesn’t have mariadb 10.x version.

[1] https://packages.ubuntu.com/search?suite=trusty&section=all&arch=any&keywords=mariadb&searchon=names

I still don’t understand what I should do sir. Do you want me to install mariadb 5.5? I tried to install mariadb-client your way and then tried to install libmariadbclient-dev still the same response.

@kyughost seems dependency issue.
first install libssl-dev sudo apt-get install libssl-dev then run bench init frappe-bench && cd frappe-bench.

Thank you for your answer. I followed the steps and here the the same result

Here the whole thing:

 ~$ bench init frappe-bench && cd frappe-bench
INFO:bench.utils:virtualenv -q env -p /usr/bin/python
Already using interpreter /usr/bin/python
INFO:bench.utils:./env/bin/pip -q install --upgrade pip
INFO:bench.utils:./env/bin/pip -q install wheel
INFO:bench.utils:./env/bin/pip -q install six
/home/benny/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/reque                                                                                        sts/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has b                                                                                        een made, but the SNI (Subject Name Indication) extension to TLS is not availabl                                                                                        e on this platform. This may cause the server to present an incorrect TLS certif                                                                                        icate, which can cause validation failures. You can upgrade to a newer version o                                                                                        f Python to solve this. For more information, see https://urllib3.readthedocs.io                                                                                        /en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/benny/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/reque                                                                                        sts/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContex                                                                                        t object is not available. This prevents urllib3 from configuring SSL appropriat                                                                                        ely and may cause certain SSL connections to fail. You can upgrade to a newer ve                                                                                        rsion of Python to solve this. For more information, see https://urllib3.readthe                                                                                        docs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
INFO:bench.utils:./env/bin/pip -q install -e git+https://github.com/frappe/pytho                                                                                        n-pdfkit.git#egg=pdfkit
INFO:bench.app:getting app frappe
INFO:bench.utils:git clone https://github.com/frappe/frappe.git   --origin upstr                                                                                        eam
Cloning into 'frappe'...
remote: Counting objects: 135922, done.
remote: Compressing objects: 100% (48/48), done.
remote: Total 135922 (delta 6), reused 3 (delta 0), pack-reused 135874
Receiving objects: 100% (135922/135922), 105.85 MiB | 70.00 KiB/s, done.
Resolving deltas: 100% (102974/102974), done.
Checking connectivity... done.
('installing', u'frappe')
INFO:bench.app:installing frappe
INFO:bench.utils:frappe-bench/env/bin/pip install -q  -e frappe-bench/apps/frappe --no-cache-dir
/home/benny/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarnin                                 g: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may c                                 ause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Pyt                                 hon to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/benny/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatform                                 Warning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL                                  connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.                                 io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-4C84c2/mysqlclient/
Traceback (most recent call last):
  File "/usr/local/bin/bench", line 11, in 
    load_entry_point('bench', 'console_scripts', 'bench')()
  File "/home/benny/bench-repo/bench/cli.py", line 40, in cli
    bench_command()
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 697, in main
    rv = self.invoke(ctx)
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 535, in invoke
    return callback(*args, **kwargs)
  File "/home/benny/bench-repo/bench/commands/make.py", line 19, in init
    verbose=verbose, clone_from=clone_from)
  File "/home/benny/bench-repo/bench/utils.py", line 56, in init
    get_app(frappe_path, branch=frappe_branch, bench_path=path, build_asset_files=False, verbose=verbose)
  File "/home/benny/bench-repo/bench/app.py", line 76, in get_app
    install_app(app=app_name, bench_path=bench_path, verbose=verbose)
  File "/home/benny/bench-repo/bench/app.py", line 107, in install_app
    find_links=find_links))
  File "/home/benny/bench-repo/bench/utils.py", line 130, in exec_cmd
    raise CommandFailedError(cmd)
bench.utils.CommandFailedError: frappe-bench/env/bin/pip install -q  -e frappe-bench/apps/frappe --no-cache-dir

This is no uncanny. I have the exact problem.

Can this be that there is a new problem that has got introduced on today’s install?

Thanks

Jay

Hi, anything yet sir?

sudo apt-get install python-dev libffi-dev libssl-dev

Hi, I ran the command you just gave me. All installed well then I run “rm -r frappe-bench” to delete the folder created last time. Finally I re-ran “bench init frappe-bench && cd frappe-bench”; may I know what’s wrong or missing?
here is the result:

INFO:bench.utils:virtualenv -q env -p /usr/bin/python
Already using interpreter /usr/bin/python
INFO:bench.utils:./env/bin/pip -q install --upgrade pip
INFO:bench.utils:./env/bin/pip -q install wheel
INFO:bench.utils:./env/bin/pip -q install six
/home/benny/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: , but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server t cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https#snimissingwarning.
  SNIMissingWarning
/home/benny/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122:  is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fato solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning
  InsecurePlatformWarning
INFO:bench.utils:./env/bin/pip -q install -e git+https://github.com/frappe/python-pdfkit.git#egg=pdfkit
INFO:bench.app:getting app frappe
INFO:bench.utils:git clone https://github.com/frappe/frappe.git   --origin upstream
Cloning into 'frappe'...
remote: Counting objects: 135934, done.
remote: Compressing objects: 100% (56/56), done.
remote: Total 135934 (delta 10), reused 14 (delta 4), pack-reused 135874
Receiving objects: 100% (135934/135934), 105.86 MiB | 62.00 KiB/s, done.
Resolving deltas: 100% (102978/102978), done.
Checking connectivity... done.
('installing', u'frappe')
INFO:bench.app:installing frappe
INFO:bench.utils:frappe-bench/env/bin/pip install -q  -e frappe-bench/apps/frappe --no-cache-dir
/home/benny/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/benny/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-goetQF/mysqlclient/
Traceback (most recent call last):
  File "/usr/local/bin/bench", line 11, in 
    load_entry_point('bench', 'console_scripts', 'bench')()
  File "/home/benny/bench-repo/bench/cli.py", line 40, in cli
    bench_command()
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 697, in main
    rv = self.invoke(ctx)
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 535, in invoke
    return callback(*args, **kwargs)
  File "/home/benny/bench-repo/bench/commands/make.py", line 19, in init
    verbose=verbose, clone_from=clone_from)
  File "/home/benny/bench-repo/bench/utils.py", line 56, in init
    get_app(frappe_path, branch=frappe_branch, bench_path=path, build_asset_files=False, verbose=verbose)
  File "/home/benny/bench-repo/bench/app.py", line 76, in get_app
    install_app(app=app_name, bench_path=bench_path, verbose=verbose)
  File "/home/benny/bench-repo/bench/app.py", line 107, in install_app
    find_links=find_links))
  File "/home/benny/bench-repo/bench/utils.py", line 130, in exec_cmd
    raise CommandFailedError(cmd)
bench.utils.CommandFailedError: frappe-bench/env/bin/pip install -q  -e frappe-bench/apps/frappe --no-cache-dir

I also try to run

~/frappe-bench$ env/bin/pip install -q -e apps/frappe
while being in frappe-bench folder. I get this error:
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-R_2pov/mysqlclient/