Try ERPNext Buy Support Partners Foundation

ERPNext with Ubuntu 18.04.3 Server

No need to install aptitude. Let the installation process continue.

BKM

The warning messages that you see are normal. You only need to take action if the process stops.

At this point the process should not stop until it is almost done. If it ends in and error AND that error ends with “exit status 2” then you are still working within the given instructions.

BKM

def_user@ubu:~$ sudo -H python3 install.py --production --user def_user
[sudo] password for def_user: 
Logs are saved under /tmp/logs/easy-install__2020-01-10__17-12.log
Checking System Compatibility...
ubuntu 18 is compatible!
Bench's CLI needs these to be defined!
Run the following commands in shell: 
export LC_ALL=C.UTF-8                                                                                
def_user@ubu:~$ export LC_ALL=C.UTF-8
def_user@ubu:~$ cd /tmp/.bench/playbooks/roles/nodejs/tasks
-bash: cd: /tmp/.bench/playbooks/roles/nodejs/tasks: No such file or directory
def_user@ubu:~$ export LC_ALL=C.UTF-8
def_user@ubu:~$ sudo -H python3 install.py --production --user def_user
Logs are saved under /tmp/logs/easy-install__2020-01-10__17-24.log
Checking System Compatibility...
ubuntu 18 is compatible!
curl already installed!
wget already installed!
git already installed!
pip3 already installed!
 [WARNING]: No inventory was parsed, only implicit localhost is available
 [WARNING]: provided hosts list is empty, only localhost is available. Note that the implicit
localhost does not match 'all'
Input MySQL and Frappe Administrator passwords:
Passwords saved at ~/passwords.txt
 [WARNING]: No inventory was parsed, only implicit localhost is available
 [WARNING]: provided hosts list is empty, only localhost is available. Note that the implicit
localhost does not match 'all'
 [WARNING]: Could not find aptitude. Using apt-get instead

 [WARNING]: Consider using the get_url or uri module rather than running 'curl'.  If you need to use
command because get_url or uri is insufficient you can add 'warn: false' to this command task or set
'command_warnings=False' in ansible.cfg to get rid of this message.
[DEPRECATION WARNING]: evaluating [] as a bare variable, this behaviour will go away and you might 
need to add |bool to the expression in the future. Also see CONDITIONAL_BARE_VARS configuration 
toggle.. This feature will be removed in version 2.12. Deprecation warnings can be disabled by 
setting deprecation_warnings=False in ansible.cfg.
 [WARNING]: Consider using the file module with owner rather than running 'chown'.  If you need to
use command because file is insufficient you can add 'warn: false' to this command task or set
'command_warnings=False' in ansible.cfg to get rid of this message.
 [WARNING]: Module remote_tmp /home/def_user/.ansible/tmp did not exist and was created with a mode
of 0700, this may cause issues when running as another user. To avoid this, create the remote_tmp    
dir with the correct permissions manually                                                            
                                                                                                     
Bench + Frappe + ERPNext has been successfully installed!                                            
def_user@ubu:~$

I must wait a very, very, very long time and i had see nothing action.

Next Step:

def_user@ubu:~$ cd /tmp/.bench/playbooks/roles/nodejs/tasks                                          
-bash: cd: /tmp/.bench/playbooks/roles/nodejs/tasks: No such file or directory                       
def_user@ubu:~$

Since you did not get the error that ends in “exit status 2” then you can attempt to login to the system ad Administrator.

The “/tmp/.bench/playbooks/roles/nodejs/tasks” is only generated if you get the long error message that ends with “exit status 2”. Since you did not get that, you can attempt to login as administrator.

However, if you run into any problem logging in, then you need to do this part of the instructions before you attempt to login again:

sudo npm install -g yarn
cd frappe-bench
bench update

So far, it looks like you are having better luck than most.

BKM

My output:

bench update

https://pastebin.com/gpx6RKQb

You should now be able to login as Administrator and let the Startup Wizard run to get your system configured.

BKM

3

Hello bkm, thank you for your big help.

:slight_smile:

I couldn’t have done it without you.

Can i use you tutorial with Debian 10 Buster to?

jannis

Actually the modifications made to the install process that caused so much grief and errors were made in order to make the Debian 10 installations work properly. :astonished:

So, the Easy Install method should work without anything special having to be done. Since it was originally made to work with Debian 10.

I have not personally tried the Debian 10 installs. I currently only use Ubuntu 16 and 18.

Good luck with your system!

BKM

Date, 2019-08-26

  • Posted on 2019-08-26
    With deb10+ERP12.0.8.ova for Virtualbox:

https://murgatroyd.za.net/?p=764

This tutorial will not work for me, but the vm works without problems.

########################

Date January 2, 2020:

This tutorial i don’t have testing.

Hello, i have a little problem.

How start i the setup wizard?

http://192.168.xxx.123/#login

Which “Email address” name, which “Password” must i use?

Hello,

Fresh Ubuntu 18.04.3 install and “Easy Install”:

https://pastebin.com/EPw1KQkR

But the same problem for me.

Solution, first Login:

Login: Administrator

Password: the same adminpassword as Ubuntu 18.04.3

Next Problem:
after logging in i get this message “‘ascii’ codec can’t decode byte 0xd0 in position 1801299: ordinal not in range(128)”

Error while running production mode for version 12

Open /etc/locale.gen in your favorite editor, and fine this line:

# en_US.UTF-8 UTF-8

and change it to this

en_US.UTF-8 UTF-8

Then run dpkg-reconfigure locales .

Finally, run update-locale LANG=en_US.UTF-8 , and restart your system. I would recommend running these instructions on a fresh install to guarantee that there will be no issues.

Fresh install on fresh VPS results in the following error using install script,

python install.py --production --version 11 --user USER
File "install.py", line 35
    print("Install script run at {0} on {1}\n\n".format(execution_time, execution_day), file=log_stream)

Lines 30-35 are,

	if not args.verbose:
		if not os.path.exists(tmp_log_folder):
			os.makedirs(tmp_log_folder)
		log_stream = open(log_path, 'w')
		log("Logs are saved under {0}".format(log_path), level=3)
		print("Install script run at {0} on {1}\n\n".format(execution_time, execution_day), file=log_stream)

Please advise, Thanks

The username is not going to be an email address for the first login. Instead just type in:

Administrator

For the password (if you do not remember what you typed in during the install) can be found in the install directory of your system. There will be a file called:

passwords.txt

This file records the passwsords you typed into the system during the install process. You will want to use the password for “Administrator” from this file.

On a linux system you can display the contents of a file with the ‘cat’ command like this:

cat /home/def_user/passwords.txt

Of course you replace “def_user” with whatever your linux username is in order to get to the file.

Hope this helps.

BKM

Thank you.

How can i get this background and icons with ERPNext 12?

f2e9f7cf8ca9288f8ca814bc00c42f6e4b2738c0_2_690x347

@ OnlineAlone

python install.py --production --version 11 --user USER

Why did you have choose ERPNext 11?

jannis

cause I prefer the iconic desktop which removed in v12
Please advise on script error above

Not in V12. You need to make custom app to make this or any other UI. Else move back to V11.

I’m trying to install v11 on fresh VPS but that error occurs,

File "install.py", line 35
    print("Install script run at {0} on {1}\n\n".format(execution_time, execution_day), file=log_stream)

please hint on the error causes.

well, the above error gone when used python3,

python3 install.py --production --version 11 --user USER

now, script stuck with the following,

Traceback (most recent call last):
  File "install.py", line 414, in <module>
    install_bench(args)
  File "install.py", line 230, in install_bench
    run_playbook('site.yml', sudo=True, extra_vars=extra_vars)
  File "install.py", line 351, in run_playbook
    success = subprocess.check_call(args, cwd=os.path.join(cwd, 'playbooks'), stdout=log_stream, stderr=sys.stderr)
  File "/usr/lib/python3.6/subprocess.py", line 311, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['ansible-playbook', '-c', 'local', 'site.yml', '-vvvv', '-e', '@/tmp/extra_vars.json', '--become', '--become-user=USER']' returned non-zero exit status 2.

Please advise.

check the log file for your respective installation for more information. This traceback isn’t sufficient.

In the beginning of the installation, the path of the log file is shown. Its one under /tmp/logs/easy-install__*

Try with: