Erpnext updating error ."Updating. We will be back in a few moments"

hi,
I am getting this error “Updating .we will be back in a few moments…” . please help me.
bench is starting properly . but whenever i am trying to open in web browser is coming


ubuntu2@ubuntu2-rmt:~/frappe-bench$ bench start
11:51:14 system | worker_long.1 started (pid=5686)
11:51:14 system | redis_socketio.1 started (pid=5680)
11:51:14 redis_socketio.1 | 5687:M 09 Jan 11:51:14.777 * Increased maximum number of open files to 10032 (it was originally set to 1024).
11:51:14 redis_socketio.1 | .
11:51:14 redis_socketio.1 | .-__ ''-._ 11:51:14 redis_socketio.1 | _.- .. ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
11:51:14 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 11:51:14 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 11:51:14 redis_socketio.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 12000 11:51:14 redis_socketio.1 | |-. ._ / _.-' | PID: 5687 11:51:14 redis_socketio.1 |-._ -._-./ .-’ .-’
11:51:14 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 11:51:14 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 11:51:14 redis_socketio.1 |-._ -._-..-’.-’ .-’
11:51:14 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 11:51:14 redis_socketio.1 | |-.
-._ _.-'_.-' | 11:51:14 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
11:51:14 redis_socketio.1 | -._-..-’ _.-’
11:51:14 redis_socketio.1 | -._ _.-' 11:51:14 redis_socketio.1 |-.
.-’
11:51:14 redis_socketio.1 |
11:51:14 redis_socketio.1 | 5687:M 09 Jan 11:51:14.778 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
11:51:14 redis_socketio.1 | 5687:M 09 Jan 11:51:14.778 # Server started, Redis version 3.0.6
11:51:14 redis_socketio.1 | 5687:M 09 Jan 11:51:14.778 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
11:51:14 redis_socketio.1 | 5687:M 09 Jan 11:51:14.778 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
11:51:14 redis_socketio.1 | 5687:M 09 Jan 11:51:14.778 * The server is now ready to accept connections on port 12000
11:51:14 system | socketio.1 started (pid=5694)
11:51:14 system | redis_cache.1 started (pid=5695)
11:51:14 redis_cache.1 | 5707:M 09 Jan 11:51:14.808 * Increased maximum number of open files to 10032 (it was originally set to 1024).
11:51:14 redis_cache.1 | .
11:51:14 redis_cache.1 | .-__ ''-._ 11:51:14 redis_cache.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
11:51:14 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 11:51:14 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 11:51:14 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 11:51:14 redis_cache.1 | |-._ ._ / _.-' | PID: 5707 11:51:14 redis_cache.1 |-._ -._-./ .-’ .-’
11:51:14 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 11:51:14 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 11:51:14 redis_cache.1 |-._ -._-..-’.-’ .-’
11:51:14 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 11:51:14 redis_cache.1 | |-.
-._ _.-'_.-' | 11:51:14 redis_cache.1 |-._ -._-.
.-’.-’ .-’
11:51:14 redis_cache.1 | -._-..-’ _.-’
11:51:14 redis_cache.1 | -._ _.-' 11:51:14 redis_cache.1 |-.
.-’
11:51:14 redis_cache.1 |
11:51:14 redis_cache.1 | 5707:M 09 Jan 11:51:14.809 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
11:51:14 redis_cache.1 | 5707:M 09 Jan 11:51:14.809 # Server started, Redis version 3.0.6
11:51:14 redis_cache.1 | 5707:M 09 Jan 11:51:14.809 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
11:51:14 redis_cache.1 | 5707:M 09 Jan 11:51:14.809 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
11:51:14 redis_cache.1 | 5707:M 09 Jan 11:51:14.809 * The server is now ready to accept connections on port 13000
11:51:14 system | schedule.1 started (pid=5697)
11:51:14 system | worker_short.1 started (pid=5696)
11:51:14 system | worker_default.1 started (pid=5692)
11:51:14 system | web.1 started (pid=5715)
11:51:14 system | watch.1 started (pid=5705)
11:51:14 system | redis_queue.1 started (pid=5719)
11:51:14 redis_queue.1 | 5722:M 09 Jan 11:51:14.888 * Increased maximum number of open files to 10032 (it was originally set to 1024).
11:51:14 redis_queue.1 | .
11:51:14 redis_queue.1 | .-__ ''-._ 11:51:14 redis_queue.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
11:51:14 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 11:51:14 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 11:51:14 redis_queue.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 11000 11:51:14 redis_queue.1 | |-._ ._ / _.-' | PID: 5722 11:51:14 redis_queue.1 |-._ -._-./ .-’ .-’
11:51:14 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 11:51:14 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 11:51:14 redis_queue.1 |-._ -._-..-’.-’ .-’
11:51:14 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 11:51:14 redis_queue.1 | |-.
-._ _.-'_.-' | 11:51:14 redis_queue.1 |-._ -._-.
.-’_.-’ _.-’
11:51:14 redis_queue.1 | -._-..-’ _.-’
11:51:14 redis_queue.1 | -._ _.-' 11:51:14 redis_queue.1 |-.
.-’
11:51:14 redis_queue.1 |
11:51:14 redis_queue.1 | 5722:M 09 Jan 11:51:14.889 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
11:51:14 redis_queue.1 | 5722:M 09 Jan 11:51:14.889 # Server started, Redis version 3.0.6
11:51:14 redis_queue.1 | 5722:M 09 Jan 11:51:14.889 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
11:51:14 redis_queue.1 | 5722:M 09 Jan 11:51:14.889 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
11:51:14 redis_queue.1 | 5722:M 09 Jan 11:51:14.889 * The server is now ready to accept connections on port 11000
11:51:16 socketio.1 | listening on *: 9000
11:51:17 worker_long.1 | 11:51:17 RQ worker u’rq:worker:ubuntu2-rmt.5688.long’ started, version 0.6.0
11:51:17 worker_long.1 | 11:51:17 Cleaning registries for queue: long
11:51:17 worker_long.1 | 11:51:17
11:51:17 worker_long.1 | 11:51:17 *** Listening on long…
11:51:17 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
11:51:17 watch.1 | Wrote ./assets/js/print_format_v3.min.js - 25k
11:51:17 watch.1 | Wrote ./assets/js/frappe-web.min.js - 141k
11:51:17 watch.1 | Wrote ./assets/js/form.min.js - 177k
11:51:17 web.1 | * Restarting with inotify reloader
11:51:17 watch.1 | Wrote ./assets/js/report.min.js - 253k
11:51:17 watch.1 | Wrote ./assets/js/erpnext.min.js - 103k
11:51:17 watch.1 | Wrote ./assets/css/list.min.css - 9k
11:51:17 watch.1 | Wrote ./assets/js/item-dashboard.min.js - 7k
11:51:17 watch.1 | Wrote ./assets/js/d3.min.js - 380k
11:51:17 watch.1 | Wrote ./assets/css/report.min.css - 8k
11:51:17 watch.1 | Wrote ./assets/css/frappe-web.css - 64k
11:51:17 worker_short.1 | 11:51:17 RQ worker u’rq:worker:ubuntu2-rmt.5709.short’ started, version 0.6.0
11:51:17 worker_short.1 | 11:51:17 Cleaning registries for queue: short
11:51:17 worker_short.1 | 11:51:17
11:51:17 worker_short.1 | 11:51:17 *** Listening on short…
11:51:17 watch.1 | Wrote ./assets/js/list.min.js - 119k
11:51:17 watch.1 | Wrote ./assets/js/dialog.min.js - 83k
11:51:17 watch.1 | Wrote ./assets/js/desk.min.js - 329k
11:51:17 watch.1 | Wrote ./assets/css/form.min.css - 4k
11:51:17 watch.1 | Wrote ./assets/js/editor.min.js - 45k
11:51:17 watch.1 | Wrote ./assets/css/erpnext.css - 3k
11:51:17 worker_default.1 | 11:51:17 RQ worker u’rq:worker:ubuntu2-rmt.5698.default’ started, version 0.6.0
11:51:17 worker_default.1 | 11:51:17 Cleaning registries for queue: default
11:51:17 worker_default.1 | 11:51:17
11:51:17 worker_default.1 | 11:51:17 *** Listening on default…
11:51:17 watch.1 | Wrote ./assets/js/libs.min.js - 692k
11:51:17 watch.1 | Wrote ./assets/js/erpnext-web.min.js - 4k
11:51:17 watch.1 | Wrote ./assets/css/desk.min.css - 256k
11:51:17 watch.1 | Wrote ./assets/css/frappe-rtl.css - 31k
11:51:17 watch.1 | Wrote ./assets/css/module.min.css - 2k
11:51:18 web.1 | * Debugger is active!
11:51:18 web.1 | * Debugger pin code: 313-895-945
11:52:23 web.1 | 127.0.0.1 - - [09/Jan/2017 11:52:23] “GET / HTTP/1.1” 503 -

Share the output of bench update

ubuntu2@ubuntu2-rmt:~/frappe-bench$ bench update
INFO:bench.utils:updating bench
Already up-to-date.
Requirement already satisfied: Pillow in ./env/lib/python2.7/site-packages
INFO:bench.app:pulling frappe
error: Pull is not possible because you have unmerged files.
hint: Fix them up in the work tree, and then use 'git add/rm ’
hint: as appropriate to mark resolution and make a commit.
fatal: Exiting because of an unresolved conflict.
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/ubuntu2/.bench/bench/cli.py”, line 40, in cli
bench_command()
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 716, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 696, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 534, in invoke
return callback(*args, **kwargs)
File “/home/ubuntu2/.bench/bench/commands/update.py”, line 62, in update
_update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, upgrade, force=force, reset=reset)
File “/home/ubuntu2/.bench/bench/commands/update.py”, line 78, in _update
pull_all_apps(bench_path=bench_path, reset=reset)
File “/home/ubuntu2/.bench/bench/app.py”, line 146, in pull_all_apps
remote=remote, branch=get_current_branch(app, bench_path=bench_path)), cwd=app_dir)
File “/home/ubuntu2/.bench/bench/utils.py”, line 127, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git pull upstream develop

Please fix this.

Now I am getting this error.
KeyError: u’introduction text’

Kindly help.

Sir , after fixing the previous issue i am getting another error. please help.


ubuntu2@ubuntu2-rmt:~/frappe-bench$ bench update
INFO:bench.utils:updating bench
Already up-to-date.
Requirement already satisfied: Pillow in ./env/lib/python2.7/site-packages
INFO:bench.app:pulling frappe
From https://github.com/frappe/frappe

  • branch develop -> FETCH_HEAD
    Already up-to-date.
    INFO:bench.app:pulling tea_garden
    From bitbucket.org:tearp/tea_garden
  • branch master -> FETCH_HEAD
    Already up-to-date.
    INFO:bench.app:pulling tea_admin
    From bitbucket.org:tearp/tea_admin
  • branch master -> FETCH_HEAD
    Already up-to-date.
    INFO:bench.app:pulling erpnext
    From https://github.com/frappe/erpnext
  • branch develop -> FETCH_HEAD
    Already up-to-date.
    Requirement already up-to-date: pip in ./env/lib/python2.7/site-packages
    Migrating farm
    Updating frappe : [========================================]
    Syncing help database…
    Migrating garden
    Updating frappe : [============== ]Traceback (most recent call last):
    File “/usr/lib/python2.7/runpy.py”, line 174, in _run_module_as_main
    main”, fname, loader, pkg_name)
    File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
    exec code in run_globals
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 79, in
    main()
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 16, in main
    click.Group(commands=commands)(prog_name=‘bench’)
    File “/home/ubuntu2/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 716, in call
    return self.main(*args, **kwargs)
    File “/home/ubuntu2/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 696, in main
    rv = self.invoke(ctx)
    File “/home/ubuntu2/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
    File “/home/ubuntu2/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
    File “/home/ubuntu2/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 889, in invoke
    return ctx.invoke(self.callback, **ctx.params)
    File “/home/ubuntu2/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 534, in invoke
    return callback(*args, **kwargs)
    File “/home/ubuntu2/frappe-bench/env/local/lib/python2.7/site-packages/click/decorators.py”, line 17, in new_func
    return f(get_current_context(), *args, **kwargs)
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/commands/init.py”, line 24, in _func
    ret = f(frappe._dict(ctx.obj), *args, **kwargs)
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/commands/site.py”, line 209, in migrate
    migrate(context.verbose, rebuild_website=rebuild_website)
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/migrate.py”, line 32, in migrate
    frappe.model.sync.sync_all(verbose=verbose)
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/model/sync.py”, line 19, in sync_all
    sync_for(app, force, verbose=verbose, reset_permissions=reset_permissions)
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/model/sync.py”, line 45, in sync_for
    reset_permissions=reset_permissions)
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/modules/import_file.py”, line 58, in import_file_by_path
    ignore_version=ignore_version, reset_permissions=reset_permissions)
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/modules/import_file.py”, line 129, in import_doc
    doc.insert()
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/model/document.py”, line 189, in insert
    self.run_before_save_methods()
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/model/document.py”, line 747, in run_before_save_methods
    self.set_title_field()
    File “/home/ubuntu2/frappe-bench/apps/frappe/frappe/model/document.py”, line 345, in set_title_field
    self.set(df.fieldname, df.options.format(**get_values()))
    KeyError: u’introduction text’

We have reinstall the site and now it’s working properly.

1 Like