Erpnext source install in ubuntu 16.04

How to install Erp next in ubuntu 16.04 from source

Refer to this

Give me the installation script please

I have provided the place where you should get the script from

I am trying from this link https://github.com/frappe/bench and got this error

TASK [create a new default site] ******************************************************************************************************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: [“bench”, “new-site”, “site1.local”, “–admin-password”, “password”, “–mariadb-root-password”, “NTSQL5y5t3m@dm1n”], “delta”: “0:00:03.876787”, “end”: “2018-01-16 13:46:01.119392”, “failed”: true, “rc”: 1, “start”: “2018-01-16 13:45:57.242605”, “stderr”: “ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)”, “stderr_lines”: [“ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)”], “stdout”: “Database not installed, this can due to lack of permission, or that the database name exists.\nCheck your mysql root password, or use --force to reinstall”, “stdout_lines”: [“Database not installed, this can due to lack of permission, or that the database name exists.”, “Check your mysql root password, or use --force to reinstall”]}
to retry, use: --limit @/tmp/.bench/playbooks/develop/install.retry

“Database not installed, this can due to lack of permission, or that the database name exists

You should install this on a completely clean system

Is it need root user? I have used additional and give command by sudo. then got same error again. I can’t login mysql DB. here is showing this error (ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)
)
,Is there any default format for mysql db?

i have the same error and i install the Pre-requisites

1 Like

please give me the procedure

TASK [create a new default site] ***********************************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: [“bench”, “new-site”, “site1.local”, “–admin-password”, “asdasd”, “–mariadb-root-password”, “asdasd”], “delta”: “0:00:01.933628”, “end”: “2018-01-16 12:20:10.005632”, “failed”: true, “rc”: 1, “start”: “2018-01-16 12:20:08.072004”, “stderr”: “ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)”, “stderr_lines”: [“ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)”], “stdout”: “Database not installed, this can due to lack of permission, or that the database name exists.\nCheck your mysql root password, or use --force to reinstall”, “stdout_lines”: [“Database not installed, this can due to lack of permission, or that the database name exists.”, “Check your mysql root password, or use --force to reinstall”]}
to retry, use: --limit @/tmp/.bench/playbooks/develop/install.retry

PLAY RECAP *********************************************************************
localhost : ok=48 changed=28 unreachable=0 failed=1

I have same, then what u did?

i don’t know i try to install mysql and run sudo python install.py --develop
but it give me error

So, how u installed that?

sudo apt-get update
sudo apt-get install mysql-server
mysql_secure_installation

Could you give erp next install full command which you have used?

I have used

#apt-get install python-minimal
#apt-get install build-essential python-setuptools
#wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
#sudo python install.py --production

but it showing the error :frowning:

Could you give me only command for setup erp next in ubuntu 14.04 or 16.04?

I have detailed instructions here. have a look.

https://jwrober.github.io/erpnext_admin_guide/i-u-b/install

1 Like

Remove the bench directory completely. Drop the database and run the instructions again.

James_Robertson

how can I setup LDAP for latest version 10+ and where is the frappe user login information and bench folder ?
N.B: I have successfully installed on ubuntu 16.04 by follow your link

I use 16.04 and have same error, and then I change Ubuntu 14.04. it’s running well.