Erpnext site not found error

Hello,

I have installed using this instructions https://github.com/frappe/erpnext_vagrant
but when i try to open erpnext in browser it seem it cant be found
any help…

vagrant@vagrant-ubuntu-trusty-32:/vagrant/frappe-bench$ bench start
08:53:34 system | web.1 started (pid=2580)
08:53:34 system | schedule.1 started (pid=2581)
08:53:34 system | worker_long.1 started (pid=2578)
08:53:34 system | watch.1 started (pid=2577)
08:53:34 system | redis_queue.1 started (pid=2579)
08:53:34 redis_queue.1 | [2587] 20 Jun 08:53:34.105 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
08:53:34 redis_queue.1 | [2587] 20 Jun 08:53:34.105 # Warning: 32 bit instance detected but no memory limit set. Setting 3 GB maxmemory limit with ‘noeviction’ policy now.
08:53:34 redis_queue.1 | .
08:53:34 redis_queue.1 | .-__ ''-._ 08:53:34 redis_queue.1 | _.- .. ‘’-._ Redis 2.8.4 (00000000/0) 32 bit
08:53:34 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 08:53:34 redis_queue.1 | ( ' , .-` | `, ) Running in stand alone mode 08:53:34 redis_queue.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 11000 08:53:34 redis_queue.1 | |-. ._ / _.-' | PID: 2587 08:53:34 redis_queue.1 |-._ -._-./ .-’ .-’
08:53:34 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 08:53:34 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 08:53:34 redis_queue.1 |-._ -._-..-’.-’ .-’
08:53:34 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 08:53:34 redis_queue.1 | |-.
-._ _.-'_.-' | 08:53:34 redis_queue.1 |-._ -._-.
.-’.-’ .-’
08:53:34 redis_queue.1 | -._-..-’ _.-’
08:53:34 redis_queue.1 | -._ _.-' 08:53:34 redis_queue.1 |-.
.-’
08:53:34 redis_queue.1 |
08:53:34 redis_queue.1 | [2587] 20 Jun 08:53:34.106 # Server started, Redis version 2.8.4
08:53:34 redis_queue.1 | [2587] 20 Jun 08:53:34.106 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
08:53:34 redis_queue.1 | [2587] 20 Jun 08:53:34.106 * The server is now ready to accept connections on port 11000
08:53:34 system | worker_default.1 started (pid=2585)
08:53:34 system | redis_socketio.1 started (pid=2602)
08:53:34 redis_socketio.1 | [2603] 20 Jun 08:53:34.168 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
08:53:34 redis_socketio.1 | [2603] 20 Jun 08:53:34.168 # Warning: 32 bit instance detected but no memory limit set. Setting 3 GB maxmemory limit with ‘noeviction’ policy now.
08:53:34 redis_socketio.1 | .
08:53:34 redis_socketio.1 | .-__ ''-._ 08:53:34 redis_socketio.1 | _.- .. ‘’-.
Redis 2.8.4 (00000000/0) 32 bit
08:53:34 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 08:53:34 redis_socketio.1 | ( ' , .-` | `, ) Running in stand alone mode 08:53:34 redis_socketio.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 12000 08:53:34 redis_socketio.1 | |-._ ._ / _.-' | PID: 2603 08:53:34 redis_socketio.1 |-._ -._-./ .-’ .-’
08:53:34 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 08:53:34 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 08:53:34 redis_socketio.1 |-._ -._-..-’.-’ .-’
08:53:34 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 08:53:34 redis_socketio.1 | |-.
-._ _.-'_.-' | 08:53:34 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
08:53:34 redis_socketio.1 | -._-..-’ _.-’
08:53:34 redis_socketio.1 | -._ _.-' 08:53:34 redis_socketio.1 |-.
.-’
08:53:34 redis_socketio.1 |
08:53:34 redis_socketio.1 | [2603] 20 Jun 08:53:34.169 # Server started, Redis version 2.8.4
08:53:34 redis_socketio.1 | [2603] 20 Jun 08:53:34.169 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
08:53:34 redis_socketio.1 | [2603] 20 Jun 08:53:34.171 * The server is now ready to accept connections on port 12000
08:53:34 system | worker_short.1 started (pid=2598)
08:53:34 system | redis_cache.1 started (pid=2597)
08:53:34 redis_cache.1 | [2614] 20 Jun 08:53:34.208 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
08:53:34 redis_cache.1 | .
08:53:34 redis_cache.1 | .-__ ''-._ 08:53:34 redis_cache.1 | _.- .. ‘’-.
Redis 2.8.4 (00000000/0) 32 bit
08:53:34 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 08:53:34 redis_cache.1 | ( ' , .-` | `, ) Running in stand alone mode 08:53:34 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 08:53:34 redis_cache.1 | |-._ ._ / _.-' | PID: 2614 08:53:34 redis_cache.1 |-._ -._-./ .-’ .-’
08:53:34 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 08:53:34 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 08:53:34 redis_cache.1 |-._ -._-..-’.-’ .-’
08:53:34 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 08:53:34 redis_cache.1 | |-.
-._ _.-'_.-' | 08:53:34 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
08:53:34 redis_cache.1 | -._-..-’ _.-’
08:53:34 redis_cache.1 | -._ _.-' 08:53:34 redis_cache.1 |-.
.-’
08:53:34 redis_cache.1 |
08:53:34 redis_cache.1 | [2614] 20 Jun 08:53:34.208 # Server started, Redis version 2.8.4
08:53:34 redis_cache.1 | [2614] 20 Jun 08:53:34.208 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
08:53:34 redis_cache.1 | [2614] 20 Jun 08:53:34.208 * The server is now ready to accept connections on port 13000
08:53:34 system | socketio.1 started (pid=2596)
08:53:39 socketio.1 | listening on *: 9000
08:54:23 watch.1 | Wrote ./assets/js/print_format_v3.min.js - 25k
08:54:23 watch.1 | Wrote ./assets/js/frappe-web.min.js - 116k
08:54:24 worker_long.1 | 08:54:24 RQ worker u’rq:worker:vagrant-ubuntu-trusty-32.2586.long’ started, version 0.6.0
08:54:24 worker_long.1 | 08:54:24 Cleaning registries for queue: long
08:54:24 worker_long.1 | 08:54:24
08:54:24 worker_long.1 | 08:54:24 *** Listening on long…
08:54:24 worker_short.1 | 08:54:24 RQ worker u’rq:worker:vagrant-ubuntu-trusty-32.2613.short’ started, version 0.6.0
08:54:24 worker_short.1 | 08:54:24 Cleaning registries for queue: short
08:54:24 worker_short.1 | 08:54:24
08:54:24 worker_short.1 | 08:54:24 *** Listening on short…
08:54:24 watch.1 | Wrote ./assets/js/form.min.js - 164k
08:54:24 worker_default.1 | 08:54:24 RQ worker u’rq:worker:vagrant-ubuntu-trusty-32.2601.default’ started, version 0.6.0
08:54:24 worker_default.1 | 08:54:24 Cleaning registries for queue: default
08:54:24 worker_default.1 | 08:54:24
08:54:24 worker_default.1 | 08:54:24 *** Listening on default…
08:54:24 watch.1 | Wrote ./assets/js/report.min.js - 247k
08:54:24 watch.1 | Wrote ./assets/js/erpnext.min.js - 86k
08:54:24 watch.1 | Wrote ./assets/css/list.min.css - 7k
08:54:24 watch.1 | Wrote ./assets/js/item-dashboard.min.js - 7k
08:54:24 watch.1 | Wrote ./assets/js/d3.min.js - 380k
08:54:24 watch.1 | Wrote ./assets/css/report.min.css - 7k
08:54:24 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
08:54:24 watch.1 | Wrote ./assets/css/frappe-web.css - 56k
08:54:24 watch.1 | Wrote ./assets/js/list.min.js - 95k
08:54:25 watch.1 | Wrote ./assets/js/dialog.min.js - 79k
08:54:25 web.1 | * Restarting with inotify reloader
08:54:25 watch.1 | Wrote ./assets/js/desk.min.js - 311k
08:54:25 watch.1 | Wrote ./assets/css/form.min.css - 2k
08:54:25 watch.1 | Wrote ./assets/js/editor.min.js - 43k
08:54:25 watch.1 | Wrote ./assets/css/erpnext.css - 3k
08:54:25 watch.1 | Wrote ./assets/js/libs.min.js - 662k
08:54:25 watch.1 | Wrote ./assets/js/erpnext-web.min.js - 2k
08:54:25 watch.1 | Wrote ./assets/css/desk.min.css - 263k
08:54:25 watch.1 | Wrote ./assets/css/module.min.css - 2k
08:54:34 web.1 | * Debugger is active!
08:54:34 web.1 | * Debugger pin code: 338-632-908

UPDATE

Am getting this new error

File “/vagrant/frappe-bench/apps/frappe/frappe/utils/scheduler.py”, line 48, in enqueue_events_for_all_sites
09:25:08 schedule.1 | enqueue_events_for_site(site=site, queued_jobs=jobs_per_site[site])
09:25:08 schedule.1 | File “/vagrant/frappe-bench/apps/frappe/frappe/utils/scheduler.py”, line 55, in enqueue_events_for_site
09:25:08 schedule.1 | frappe.init(site=site)
09:25:08 schedule.1 | File “/vagrant/frappe-bench/apps/frappe/frappe/init.py”, line 122, in init
09:25:08 schedule.1 | local.conf = _dict(get_site_config())
09:25:08 schedule.1 | File “/vagrant/frappe-bench/apps/frappe/frappe/init.py”, line 174, in get_site_config
09:25:08 schedule.1 | config.update(get_file_json(site_config))
09:25:08 schedule.1 | File “/vagrant/frappe-bench/apps/frappe/frappe/init.py”, line 831, in get_file_json
09:25:08 schedule.1 | return json.load(f)
09:25:08 schedule.1 | File “/usr/lib/python2.7/json/init.py”, line 290, in load
09:25:08 schedule.1 | **kw)
09:25:08 schedule.1 | File “/usr/lib/python2.7/json/init.py”, line 338, in loads
09:25:08 schedule.1 | return _default_decoder.decode(s)
09:25:08 schedule.1 | File “/usr/lib/python2.7/json/decoder.py”, line 366, in decode
09:25:08 schedule.1 | obj, end = self.raw_decode(s, idx=_w(s, 0).end())
09:25:08 schedule.1 | File “/usr/lib/python2.7/json/decoder.py”, line 382, in raw_decode
09:25:08 schedule.1 | obj, end = self.scan_once(s, idx)
09:25:08 schedule.1 | ValueError: Expecting , delimiter: line 4 column 1 (char 64)

Hey, sorry about that, the Vagrant repo hasn’t been updated since a long time. You can use this Vagrant Box instead.

Hello VjFaLk, thank you for quick reply, i have used vagrant box provided but still the same issue, below are logs

frappe@erpnext:~/frappe-bench$ bench start
04:34:53 system | watch.1 started (pid=2480)
04:34:53 system | redis_queue.1 started (pid=2482)
04:34:53 redis_queue.1 | [2492] 21 Jun 04:34:53.297 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
04:34:53 redis_queue.1 | [2492] 21 Jun 04:34:53.297 # Warning: 32 bit instance detected but no memory limit set. Setting 3 GB maxmemory limit with ‘noeviction’ policy now.
04:34:53 redis_queue.1 | .
04:34:53 redis_queue.1 | .-__ ''-._ 04:34:53 redis_queue.1 | _.- .. ‘’-._ Redis 2.8.4 (00000000/0) 32 bit
04:34:53 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 04:34:53 redis_queue.1 | ( ' , .-` | `, ) Running in stand alone mode 04:34:53 redis_queue.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 11000 04:34:53 redis_queue.1 | |-. ._ / _.-' | PID: 2492 04:34:53 redis_queue.1 |-._ -._-./ .-’ .-’
04:34:53 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 04:34:53 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 04:34:53 redis_queue.1 |-._ -._-..-’.-’ .-’
04:34:53 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 04:34:53 redis_queue.1 | |-.
-._ _.-'_.-' | 04:34:53 redis_queue.1 |-._ -._-.
.-’.-’ .-’
04:34:53 redis_queue.1 | -._-..-’ _.-’
04:34:53 redis_queue.1 | -._ _.-' 04:34:53 redis_queue.1 |-.
.-’
04:34:53 redis_queue.1 |
04:34:53 redis_queue.1 | [2492] 21 Jun 04:34:53.298 # Server started, Redis version 2.8.4
04:34:53 redis_queue.1 | [2492] 21 Jun 04:34:53.298 * The server is now ready to accept connections on port 11000
04:34:53 system | web.1 started (pid=2483)
04:34:53 system | worker_long.1 started (pid=2481)
04:34:53 system | schedule.1 started (pid=2484)
04:34:53 system | redis_socketio.1 started (pid=2485)
04:34:53 redis_socketio.1 | [2501] 21 Jun 04:34:53.322 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
04:34:53 redis_socketio.1 | [2501] 21 Jun 04:34:53.322 # Warning: 32 bit instance detected but no memory limit set. Setting 3 GB maxmemory limit with ‘noeviction’ policy now.
04:34:53 redis_socketio.1 | .
04:34:53 redis_socketio.1 | .-__ ''-._ 04:34:53 redis_socketio.1 | _.- .. ‘’-.
Redis 2.8.4 (00000000/0) 32 bit
04:34:53 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 04:34:53 redis_socketio.1 | ( ' , .-` | `, ) Running in stand alone mode 04:34:53 redis_socketio.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 12000 04:34:53 redis_socketio.1 | |-._ ._ / _.-' | PID: 2501 04:34:53 redis_socketio.1 |-._ -._-./ .-’ .-’
04:34:53 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 04:34:53 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 04:34:53 redis_socketio.1 |-._ -._-..-’.-’ .-’
04:34:53 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 04:34:53 redis_socketio.1 | |-.
-._ _.-'_.-' | 04:34:53 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
04:34:53 redis_socketio.1 | -._-..-’ _.-’
04:34:53 redis_socketio.1 | -._ _.-' 04:34:53 redis_socketio.1 |-.
.-’
04:34:53 redis_socketio.1 |
04:34:53 redis_socketio.1 | [2501] 21 Jun 04:34:53.322 # Server started, Redis version 2.8.4
04:34:53 redis_socketio.1 | [2501] 21 Jun 04:34:53.322 * The server is now ready to accept connections on port 12000
04:34:53 system | socketio.1 started (pid=2488)
04:34:53 system | worker_default.1 started (pid=2508)
04:34:53 system | redis_cache.1 started (pid=2510)
04:34:53 redis_cache.1 | [2512] 21 Jun 04:34:53.386 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
04:34:53 redis_cache.1 | .
04:34:53 redis_cache.1 | .-__ ''-._ 04:34:53 redis_cache.1 | _.- .. ‘’-.
Redis 2.8.4 (00000000/0) 32 bit
04:34:53 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 04:34:53 redis_cache.1 | ( ' , .-` | `, ) Running in stand alone mode 04:34:53 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 04:34:53 redis_cache.1 | |-._ ._ / _.-' | PID: 2512 04:34:53 redis_cache.1 |-._ -._-./ .-’ .-’
04:34:53 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 04:34:53 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 04:34:53 redis_cache.1 |-._ -._-..-’.-’ .-’
04:34:53 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 04:34:53 redis_cache.1 | |-.
-._ _.-'_.-' | 04:34:53 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
04:34:53 redis_cache.1 | -._-..-’ _.-’
04:34:53 redis_cache.1 | -._ _.-' 04:34:53 redis_cache.1 |-.
.-’
04:34:53 redis_cache.1 |
04:34:53 redis_cache.1 | [2512] 21 Jun 04:34:53.386 # Server started, Redis version 2.8.4
04:34:53 redis_cache.1 | [2512] 21 Jun 04:34:53.386 * The server is now ready to accept connections on port 13000
04:34:53 system | worker_short.1 started (pid=2504)
04:34:56 socketio.1 | listening on *: 9000
04:34:57 watch.1 | Wrote ./assets/js/print_format_v3.min.js - 25k
04:34:57 watch.1 | Wrote ./assets/js/frappe-web.min.js - 116k
04:34:57 worker_long.1 | 04:34:57 RQ worker u’rq:worker:erpnext.2490.long’ started, version 0.6.0
04:34:57 worker_long.1 | 04:34:57 Cleaning registries for queue: long
04:34:57 worker_long.1 | 04:34:57
04:34:57 worker_long.1 | 04:34:57 *** Listening on long…
04:34:57 watch.1 | Wrote ./assets/js/form.min.js - 164k
04:34:57 worker_default.1 | 04:34:57 RQ worker u’rq:worker:erpnext.2511.default’ started, version 0.6.0
04:34:57 worker_default.1 | 04:34:57 Cleaning registries for queue: default
04:34:57 worker_default.1 | 04:34:57
04:34:57 worker_default.1 | 04:34:57 *** Listening on default…
04:34:57 watch.1 | Wrote ./assets/js/report.min.js - 248k
04:34:57 watch.1 | Wrote ./assets/js/erpnext.min.js - 86k
04:34:57 worker_short.1 | 04:34:57 RQ worker u’rq:worker:erpnext.2517.short’ started, version 0.6.0
04:34:57 watch.1 | Wrote ./assets/css/list.min.css - 7k
04:34:57 worker_short.1 | 04:34:57 Cleaning registries for queue: short
04:34:57 watch.1 | Wrote ./assets/js/item-dashboard.min.js - 7k
04:34:57 worker_short.1 | 04:34:57
04:34:57 worker_short.1 | 04:34:57 *** Listening on short…
04:34:57 watch.1 | Wrote ./assets/js/d3.min.js - 380k
04:34:57 watch.1 | Wrote ./assets/css/report.min.css - 7k
04:34:58 watch.1 | Wrote ./assets/css/frappe-web.css - 56k
04:34:58 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
04:34:58 watch.1 | Wrote ./assets/js/list.min.js - 95k
04:34:58 watch.1 | Wrote ./assets/js/dialog.min.js - 79k
04:34:58 web.1 | * Restarting with inotify reloader
04:34:58 watch.1 | Wrote ./assets/js/desk.min.js - 311k
04:34:58 watch.1 | Wrote ./assets/css/form.min.css - 2k
04:34:58 watch.1 | Wrote ./assets/js/editor.min.js - 43k
04:34:58 watch.1 | Wrote ./assets/css/erpnext.css - 3k
04:34:58 watch.1 | Wrote ./assets/js/libs.min.js - 662k
04:34:58 watch.1 | Wrote ./assets/js/erpnext-web.min.js - 2k
04:34:58 watch.1 | Wrote ./assets/css/desk.min.css - 263k
04:34:58 watch.1 | Wrote ./assets/css/module.min.css - 2k
04:34:58 web.1 | * Debugger is active!
04:34:58 web.1 | * Debugger pin code: 209-375-471

Thank you

Is your terminal back to your directory or you still have content coming in your terminal? Have you given me the entire traceback? Because it seems your bench is running fine. You can access it by going to localhost:8000 in your browser.

That is entire trace, no terminal is hanging there, i have tried to access localhost:8000 on my browser but no page is displayed, i am using window so i use ssh shell