Try ERPNext Buy Support Partners Foundation

ERPNext setup on Ubuntu VM

Hi,

I’m trying to setup ERPNext on Ubuntu VM using the manual installation doc mentioned below but bench start is not working although it shows Running on http://0.0.0.0:8000/.

Installation Docs reference:

I’ve installed Redis, node js, MariaDB, Nginx, python 2.7.

Please find the logs of bench start:

/srv/bench/erpnext$ bench start
05:52:13 system           | redis_socketio.1 started (pid=28985)
05:52:13 redis_socketio.1 | 28996:C 24 Apr 05:52:13.685 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
05:52:13 redis_socketio.1 | 28996:C 24 Apr 05:52:13.688 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=28996, just started
05:52:13 redis_socketio.1 | 28996:C 24 Apr 05:52:13.688 # Configuration loaded
05:52:13 redis_socketio.1 | 28996:M 24 Apr 05:52:13.689 * Increased maximum number of open files to 10032 (it was originally set to 1024).
05:52:13 redis_socketio.1 | 28996:M 24 Apr 05:52:13.692 * Running mode=standalone, port=12000.
05:52:13 system           | web.1 started (pid=28995)
05:52:13 redis_socketio.1 | 28996:M 24 Apr 05:52:13.693 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
05:52:13 redis_socketio.1 | 28996:M 24 Apr 05:52:13.693 # Server initialized
05:52:13 redis_socketio.1 | 28996:M 24 Apr 05:52:13.694 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
05:52:13 redis_socketio.1 | 28996:M 24 Apr 05:52:13.694 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
05:52:13 redis_socketio.1 | 28996:M 24 Apr 05:52:13.694 * Ready to accept connections
05:52:13 system           | redis_queue.1 started (pid=28993)
05:52:13 system           | socketio.1 started (pid=28992)
05:52:13 system           | watch.1 started (pid=28997)
05:52:13 system           | redis_cache.1 started (pid=28998)
05:52:13 redis_cache.1    | 29003:C 24 Apr 05:52:13.698 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
05:52:13 redis_cache.1    | 29003:C 24 Apr 05:52:13.698 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=29003, just started
05:52:13 redis_cache.1    | 29003:C 24 Apr 05:52:13.698 # Configuration loaded
05:52:13 redis_cache.1    | 29003:M 24 Apr 05:52:13.699 * Increased maximum number of open files to 10032 (it was originally set to 1024).
05:52:13 redis_cache.1    | 29003:M 24 Apr 05:52:13.700 * Running mode=standalone, port=13000.
05:52:13 redis_cache.1    | 29003:M 24 Apr 05:52:13.700 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
05:52:13 redis_cache.1    | 29003:M 24 Apr 05:52:13.700 # Server initialized
05:52:13 redis_cache.1    | 29003:M 24 Apr 05:52:13.700 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
05:52:13 redis_cache.1    | 29003:M 24 Apr 05:52:13.700 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
05:52:13 redis_cache.1    | 29003:M 24 Apr 05:52:13.700 * Ready to accept connections
05:52:13 system           | worker_long.1 started (pid=29000)
05:52:13 system           | worker_default.1 started (pid=28994)
05:52:13 system           | worker_short.1 started (pid=28999)
05:52:13 redis_queue.1    | 29020:C 24 Apr 05:52:13.714 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
05:52:13 redis_queue.1    | 29020:C 24 Apr 05:52:13.714 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=29020, just started
05:52:13 redis_queue.1    | 29020:C 24 Apr 05:52:13.714 # Configuration loaded
05:52:13 redis_queue.1    | 29020:M 24 Apr 05:52:13.715 * Increased maximum number of open files to 10032 (it was originally set to 1024).
05:52:13 redis_queue.1    | 29020:M 24 Apr 05:52:13.716 * Running mode=standalone, port=11000.
05:52:13 redis_queue.1    | 29020:M 24 Apr 05:52:13.716 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
05:52:13 redis_queue.1    | 29020:M 24 Apr 05:52:13.716 # Server initialized
05:52:13 redis_queue.1    | 29020:M 24 Apr 05:52:13.716 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
05:52:13 redis_queue.1    | 29020:M 24 Apr 05:52:13.716 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
05:52:13 redis_queue.1    | 29020:M 24 Apr 05:52:13.716 * Ready to accept connections
05:52:13 system           | schedule.1 started (pid=29011)
05:52:14 socketio.1       | listening on *: 9000
05:52:20 web.1            |  * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
05:52:20 web.1            |  * Restarting with inotify reloader
05:52:20 watch.1          | yarn run v1.22.4
05:52:20 watch.1          | $ node rollup/watch.js
05:52:20 web.1            |  * Debugger is active!
05:52:20 web.1            |  * Debugger PIN: 859-977-580
05:52:21 watch.1          |
05:52:21 watch.1          | Rollup Watcher Started
05:52:21 watch.1          |
05:52:21 watch.1          | Watching...
05:52:22 watch.1          | Rebuilding frappe-web-b4.css
05:52:22 watch.1          | Rebuilding frappe-chat-web.css
05:52:22 watch.1          | Rebuilding chat.js
05:52:23 watch.1          | Rebuilding frappe-recorder.min.js
05:52:26 watch.1          | Rebuilding checkout.min.js
05:52:27 watch.1          | Rebuilding frappe-web.min.js
05:52:28 watch.1          | Rebuilding bootstrap-4-web.min.js
05:52:29 watch.1          | Rebuilding control.min.js
05:52:32 watch.1          | Rebuilding dialog.min.js
05:52:34 watch.1          | Rebuilding desk.min.css
05:52:34 watch.1          | Rebuilding frappe-rtl.css
05:52:34 watch.1          | Rebuilding printview.css
05:52:34 watch.1          | Rebuilding desk.min.js
05:52:39 watch.1          | Rebuilding form.min.css
05:52:39 watch.1          | Rebuilding form.min.js
05:52:42 watch.1          | Rebuilding list.min.css
05:52:42 watch.1          | Rebuilding list.min.js
05:52:43 watch.1          | Rebuilding report.min.css
05:52:43 watch.1          | Rebuilding report.min.js
05:52:44 watch.1          | Rebuilding web_form.min.js
05:52:45 watch.1          | Rebuilding web_form.css
05:52:45 watch.1          | Rebuilding email.css
05:52:45 watch.1          | Rebuilding social.min.js
05:52:46 watch.1          | Rebuilding barcode_scanner.min.js
05:52:48 watch.1          | Rebuilding data_import_tools.min.js
05:53:01 web.1            | 127.0.0.1 - - [24/Apr/2020 05:53:01] "GET / HTTP/1.1" 200 -
05:53:01 web.1            | INFO:werkzeug:127.0.0.1 - - [24/Apr/2020 05:53:01] "GET / HTTP/1.1" 200 -
05:53:01 web.1            |  * Detected change in '/srv/bench/erpnext/apps/frappe/frappe/www/__pycache__/login.cpython-36.pyc', reloading
05:53:01 web.1            | INFO:werkzeug: * Detected change in '/srv/bench/erpnext/apps/frappe/frappe/www/__pycache__/login.cpython-36.pyc', reloading
05:53:01 web.1            |  * Detected change in '/srv/bench/erpnext/apps/frappe/frappe/utils/__pycache__/oauth.cpython-36.pyc', reloading
05:53:01 web.1            | INFO:werkzeug: * Detected change in '/srv/bench/erpnext/apps/frappe/frappe/utils/__pycache__/oauth.cpython-36.pyc', reloading
05:53:01 web.1            |  * Detected change in '/srv/bench/erpnext/apps/frappe/frappe/integrations/__pycache__/oauth2_logins.cpython-36.pyc', reloading
05:53:01 web.1            | INFO:werkzeug: * Detected change in '/srv/bench/erpnext/apps/frappe/frappe/integrations/__pycache__/oauth2_logins.cpython-36.pyc', reloading
05:53:02 web.1            |  * Restarting with inotify reloader
05:53:03 web.1            |  * Debugger is active!
05:53:03 web.1            |  * Debugger PIN: 859-977-580

Those are quite normal looking logs, but since you aren’t making use of using the Markdown code formatting it’s very hard to read.

Please edit your post and place your output log results between triple back ticks.

   They look like this ```
   They must be all alone at the beginning of an empty line, one before your code block and one after it

Apart from that … what makes you say that bench is not working?
What do you expect to see?

Have changed the formatting. When I hit the UI (http://ip:8000), it says site can’t be reached.
I’ve installed erpnext on aws instance.

The “Computing for Geeks” site you were using as a guide is probably not the best.

Please review all the steps you took comparing to the instructions in the The Hitchhiker’s Guide to Installing Frappe on Linux.

Better yet, scrap what you did and start again with The Hitchhiker’s Guide.

If you wish to try it, I have published my own installation scripts as a GitHub gist here:
Install ERPNext on Ubuntu 18.04 LTS

The steps in the first file explain what I do when I use it.

It expects a completely fresh install of Xubuntu 18.04 LTS server.

1 Like