Try ERPNext Buy Support Partners Foundation Foundation Members

ERPNext persistent Installation Issues

Ok, so now the setup fails while getting the erpnext app, so after installing wkhtmtopdf it passed on, apparently, this --become-user=user appears to be kind of generic, being the exit point of a successful install so any errors that terminate the script also push this error.

So it appears that the main issue may be some ISP level connectivity problem, ie its a timeout, if you look at the attachments, the remote end hung up, rpc calls fail, so this may be a timeout issue; with this, this may not be a general problem, but to improve the experience; I will suggest strongly that these lines be added to the install process:

sudo apt-get install xvfb libfontconfig wkhtmltopdf
regarding the wkhtmltopdf error which is a very frequent occurrence during installs.

I will go ahead and give this another run… with a different internet connection


Oh well, same thing. Cannot get erpnext app and also terminates with same error. @flexy2ky Have you tried this? I want to conclude its an internet issue where certain resources are slow to download and timeout.

Virtualbox is giving me plenty issues on windows. Cannot get it to load 64bit processor. i’m trying to load it on my mac now.

Wait, at what point do you observe you can’t load 64bit? on creating a new virtual machine?

Yes. Virtualbox is telling me my host machine cannot handle 64-bit kernel whereas both my Processor and OS are 64-bit

O I see… and intelVTx is enabled in bios right? on the Windows machine…

Yes. Tried to troubleshoot but no progress. But i just determined that it was the machine after all. It’s installing on another windows machine now

ok great! Also if you succeed? and you’re currently local, let me know what connection you used… because asides the wkhtm issue there is obviously some issues with internet name resolution

Also noticed in the error, something to do with test.fm version issues, installing that now…

@noetico

I successfully installed on VirtualBox:

Screenshot 2019-06-26 at 1.32.15 PM

Installation was done on Ubuntu 16.04

Here are the steps I followed after installing the OS:

  1. Create user: adduser [username]
  2. Add created user to sudoers: usermod -aG sudo [username]
  3. Install setup tools: apt-get install build-essential python-setuptools Notice that I skipped installing python minimal
  4. Download playbook: wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
  5. Run production script: python install.py --production --user [username]

NOTE: Every single command was run using root user. I did not switch user for any reason or cd to any directory. You can also notice this from my ssh terminal screenshot.

Try again following these steps and let me know if you still face issues.

What was the source of your inspiratin to NOT install the python minimal?

BKM

I’m convinced I have a connectivity issue, although not today, but I have tried this method, it’s basically straightforward. Just use root, which em, in my stubbornness I have used to install the system numerous times over the years.

All I summarize when I view the errors is that certain packages don’t get downloaded.

But… I will give it a run again. Trust me, I have tried all mixtures hahaha. I even have 3 users created currently using them to try different ways, so… I’m concluding I may just reset my tcp/ip stack on Windows, maybe something is mentally unstable there.

@bkm

It was just a way to eliminate any conflict between a pre-installed python2 and failed check for a python installation.

@noetico

You are right about it being a connection issue. I tried running fresh installs again with a pretty slow network and faced the same download error with wkhtmltopdf. It failed several times until the network became stable again and the install went through without a hitch.

In fact, this morning I can’t access https://github.com , then I notice while doing normal browsing, some pages may show a connection reset for a few seconds an browser successfully reloads the page. So some instability there.

So maybe anyone having this problem may want to look at connectivity issues, apparently at ISP level, due to the various sources of these packages some are on slower or more distant servers, throttled servers with low resource Etc.

It’s good that the production VM download exists, VMs are our preferred option due to the fact that we deal with mainly retailers… So mainly on-site installs, sometimes; ins small shops; on a machine that is also used for other purposes by Windows-only users. Also, We are running VMs for easier management and disaster recovery, you can imagine trying to reinstall an Ubuntu machine, install Erpnext and restore a database; to get a business running, that may be totally off any acceptable Recovery Time Objective, customers may be waiting… Also it’s easy to test upgrades/updates with an image, quickly recover from ‘internal server error’ when something fails on the live update… so the VMs are quicker to recover with, quicker to also just backup and have a full ready image, imported by a simple double click, If host is dead; a maturing business can even have another lower staging server with a hypervisor already installed as part of the recovery plan, plug in the backup drive and double click the image, plug in network cable …worst case you work on normalizing balances and all that. VMs are one of the best inventions😬

Hello there,

I am having same issues installing on a DigitalOcean VPS…I have tried all suggestions here and having same issues.


Is there anything else that could be done.

can you post text of the error (including the red text)?

The --become-user errors are almost always related to the installer attempting to run from the same user account that it is trying to install into.

I you login as root to the server and then run the install using the --user switch to define the user account you want it to install into, this has always fixed it for me even on digital ocean.

BKM

1 Like

It will also be nice to see your full traceback if as you said, you followed the suggested process. One issue i noted last time i installed was with wkhtmltopdf failing to download due to slow connection and had nothing to do with the actual setup script.

Thanks. Yes as you noted it does appear to be an issue with my ISP as some other unrelated processes i was running timeout. I did however find another install route with this https://www.digitalocean.com/community/questions/tutorial-request-erpnext-platform which worked perfectly.

Thank you @bkm . This helped with some earlier install issues but i just couldnt get past the last. As @flexy2ky noted my ISP may be the culprit here.