ERPNext not working after a clean install

Hi there,

I’m new here and have searched the forum for hours now. I cannot get ERPNext working on my machine. I am trying to install it an a Leaseweb (Dutch hosting provider) cloud VM with Ubuntu 16.04 64-bit. I used a clean install 7 times now, and it is always having the same issue, giving me the impression that there is a problem in the application itself.

To install the application I have used the following script:

https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py

Prior to running the script I have installed Python 2.7 via: apt-get install python-minimal

After Python was installed I ran the following command:

python install.py --production --user frappe

The installation is always succesful, however if I try to login it keeps saying “Verifying…”

If I check the status via supervisorctl status the output is:

frappe-bench-redis:frappe-bench-redis-cache RUNNING pid 21341, uptime 0:06:35
frappe-bench-redis:frappe-bench-redis-queue RUNNING pid 21340, uptime 0:06:35
frappe-bench-redis:frappe-bench-redis-socketio RUNNING pid 21342, uptime 0:06:35
frappe-bench-web:frappe-bench-frappe-web RUNNING pid 21338, uptime 0:06:35
frappe-bench-web:frappe-bench-node-socketio RUNNING pid 21339, uptime 0:06:35
frappe-bench-workers:frappe-bench-frappe-default-worker-0 FATAL Exited too quickly (process log may have details)
frappe-bench-workers:frappe-bench-frappe-long-worker-0 FATAL Exited too quickly (process log may have details)
frappe-bench-workers:frappe-bench-frappe-schedule RUNNING pid 21894, uptime 0:02:31
frappe-bench-workers:frappe-bench-frappe-short-worker-0 FATAL Exited too quickly (process log may have details)

The log in /home/frappe/frappe-bench/logs/worker.error.log keeps showing the following error:

File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/redis/connection.py”, line 442, in connect
raise ConnectionError(self._error_message(e))
redis.exceptions.ConnectionError: Error 111 connecting to localhost:11000. Connection refused.

Redis seems to be running. If i run redis-cli -p 11000 and type PING it responds with PONG

I don’t have a clue on how to solve this. Can anyone help me?

check the *-worker.error.logs in ~/frappe-bench/logs directory for error traceback

Found the issue causing the Error 111 connecting to localhost:11000.

In Ubunty connecting to localhost is not possible by default. Apparently somewehere in the code localhost is specified, while in the config files it was 127.0.0.1.

After adding the following line to /etc/hosts it worked just fine:

127.0.0.1 localhost

Thanks for your suggestion! Just before I read it I found the actual problem :slight_smile: I have already posted how I’ve resolved my issue