Try ERPNext Buy Support Partners Foundation

ERPNext Invalid Outgoing mail Server or Port

When I am trying to create a new user, a message arises saying, Invalid Outgoing mail Server or Port

Earlier i have created users and and it worked properly.

Now I am working ErpNext in my local PC and I am getting such a message.

Please help me in solving this problem.

add the following entry to your site_config.json:
“mute_emails”: true

By adding this, will I be able to send emails further ?

I need to send emails. I don’t think, I will be able to receive mails by adding “mute_emails”:true.
Help me solve this problem too…
Thank You in advance.

@Deepika, my suggestion was to mute it once and check if error persists. My guess is you have incorrect email account related entries in you site_config.json

Following correct value should be present in site_config

mail_server: SMTP server hostname.
mail_port: STMP port.
use_ssl: Connect via SSL / TLS.
mail_login: Login id for SMTP server.
mail_password: Password for SMTP server.

Alternatively, you can delete email domain/account in desk and set it up again. This way you need not change or correct site_config.json values. It would be overwritten.

The error has gone. But the problem I face now is, no emails are sent from erpnext.

remove entry from your site_config.json:
“mute_emails”: true

By removing that I hit on the same error.
I have earlier worked in my server but when I try to work locally , such kind of error occur.
Please find me a solution for this.

  1. remote mute_emails entry from site_confing
  2. delete email domain/account detail aftter login to desk and set it up the account details again.

When I try to reset my email domain, I get such an error message

Hello, Have you solve the problema? We are facing the same issue.

hello,Facing the same issue. Did anyone found the solution?

A forum search like ‘incoming email account not correct’ will give you clues and pointers to resolve this.

You might try that and report what result you get?

@ashish-greycube
I’m having same problem.
As per your suggestion Deleting all domain/account > if domain is setup the “site_config” file should have the settings in places…?
mail_server: SMTP server hostname.
mail_port: STMP port.
use_ssl: Connect via SSL / TLS.
mail_login: Login id for SMTP server.
mail_password: Password for SMTP server.

But I got nothing but
“db_name”: “_ce396b2efafabf2f”,
“db_password”: “tyfDHdXR249edlyA”,
“db_type”: “mariadb”,
“domains”: […]

My situation is also the same.