ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Erpnext installation issue on 16.04 and 18.04


#1

Hi,

I have been trying over the last couple of days to get a clean install done to test V11 and V12 but have problems getting past the “bench init frappe-bench” command.

I have tried the install.py script as well as most of the manual install instructions I can find, but all have the same result.

Running the install.py script on a new 18.04 server has the following issues:-

Error: “msg”: “error getting key id from url: http://keyserver.ubuntu.com/pks/lookup?op=get&search=0xF1656F24C74CD1D8
Resolved with: wget -qO - “http://keyserver.ubuntu.com/pks/lookup?op=get&search=0xF1656F24C74CD1D8” | apt-key add -

Error: “msg”: “Connection failure: The read operation timed out”,
“url”: “https://github.com/frappe/wkhtmltopdf/raw/master/wkhtmltox-0.12.3_linux-generic-amd64.tar.xz
Resolved with: cd /tmp
wget https://github.com/frappe/wkhtmltopdf/raw/master/wkhtmltox-0.12.3_linux-generic-amd64.tar.xz
mv wkhtmltox-0.12.3_linux-generic-amd64.tar.xz wkhtmltox.tar.xz

Stops at:
TASK [bench : python3 bench init for production] *************************************************************************************************
task path: /tmp/.bench/playbooks/roles/bench/tasks/main.yml:37
<127.0.0.1> ESTABLISH LOCAL CONNECTION FOR USER: root
<127.0.0.1> EXEC /bin/sh -c ‘echo ~root && sleep 0’
<127.0.0.1> EXEC /bin/sh -c ‘( umask 77 && mkdir -p “echo /var/tmp/ansible-tmp-1564388112.916724-180630193921522” && echo ansible-tmp-1564388112.916724-180630193921522="echo /var/tmp/ansible-tmp-1564388112.916724-180630193921522" ) && sleep 0’
Using module file /usr/local/lib/python3.6/dist-packages/ansible/modules/commands/command.py
<127.0.0.1> PUT /root/.ansible/tmp/ansible-local-15786brkrkajg/tmp33svyfmo TO /var/tmp/ansible-tmp-1564388112.916724-180630193921522/AnsiballZ_command.py
<127.0.0.1> EXEC /bin/sh -c ‘setfacl -m u:corepos:r-x /var/tmp/ansible-tmp-1564388112.916724-180630193921522/ /var/tmp/ansible-tmp-1564388112.916724-180630193921522/AnsiballZ_command.py && sleep 0’
<127.0.0.1> EXEC /bin/sh -c ‘sudo -H -S -n -u corepos /bin/sh -c ‘"’"‘echo BECOME-SUCCESS-yauvixjrrsjqyctxskciyijrwcdrruyi ; /usr/bin/python3 /var/tmp/ansible-tmp-1564388112.916724-180630193921522/AnsiballZ_command.py’"’"’ && sleep 0’

Would appreciate any advice.

Thanks


How to install erpnext version 12 on ubuntu 18.04
#2

May we see your installation command?


#3

I used your command:-
sudo -H python3 install.py --production --site site.name --user erpnext --mysql-root-password whatever_you_fancy --admin-password whatever_you_fancy --bench-name bench_you_would_like_to_call

substituted the relevant passwords and user etc. The user is sudo

This method solved the first error with the ubuntu key, but the wkhtmltox error and the stall on bench init still occur

Thanks


#4

The following may shed more light on the issue:

  • If possible, how did you get there before Easy Install
  • try adding check_certificate = off to /etc/wgetrc file
  • If you know the root password, please try it with root user, the user you are installing may need to be added to several other groups as well
  • Please do not define erpnext user before you run the Easy Install
  • In case of an error, you can always go to the installation file where the error occurs and adjust the relevant line according to your system if it is not harmful towards the installed system. There are some installation criteria that I find obsolete.

#5

Hi,
Just an update to close this thread. I have finally managed to find out what was causing the various issues preventing me from installing on a fresh 18.04.

After testing on Digital Ocean using US, India and Singapore data-centres, and successfully installing without any issue, it seems that the ISP in Singapore I am using for one of our connections either keeps stale records for DNS or the cache is too long, but after changing the server DNS Server entry to 1.1.1.1 & 8.8.8.8 I was easily able to install using the following:-

New 18.04.3 Server on Proxmox (8GB Ram, 4CPU) - as “root” user

apt update && apt -y upgrade
apt -y install python-minimal python3-minimal build-essential python-setuptools python3-setuptools
wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
adduser [your-sudo-username]
usermod -aG sudo [your-sudo-username]
sudo python install.py --production --user [your-sudo-username]

Hope this helps someone